ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Particular- Keeping the same particles on

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
William SaviolaParticular- Keeping the same particles on
by on Nov 24, 2015 at 8:46:36 pm

I have a fish scene using particles as my fish using particular.

I want my fish/particles to not be born and not die but the same particles to remain on the screen.

How would i do that.

At the moment i have the opacity and size over life giving the fish a scale and fade down but i just want an amount of fish particles to be in the scene through out. If i dont have this set the particles/fish will just appear on and off


Thanks


Return to posts index

Kalle KannistoRe: Particular- Keeping the same particles on
by on Nov 24, 2015 at 9:22:11 pm

You want to have all your particles already emitted when you enter the first frame.

Two ways to accomplish this:

1) Set the birth rate to the desired number per second for one second, then to zero after one second. Trim layer to start after one second, move back one second.

2) Use the "Prerun" option to create the particles before the first frame

Then you want the particle life to be at least as long as the layer/comp.


Return to posts index

William SaviolaRe: Particular- Keeping the same particles on
by on Nov 25, 2015 at 9:48:50 am

neither of those ways are working.

the particles/fish still keep just coming on and off.

I am using a box emitter and directional with all rotations set to 0

my particle life is 12seconds for a 10 second comp


Return to posts index


Walter SoykaRe: Particular- Keeping the same particles on
by on Nov 25, 2015 at 11:09:32 am

What version of Particular are you using? Older versions were susceptible to two issues that are both resolved (I think) in more recent builds.

1) It's possible that Particular is not properly invalidating the cache, so you end up recycling old frames instead of rendering new ones. Clear your cache.

Ae CC/CC2014/CC2015:
Edit > Purge > All Memory & Disk Cache

Ae CS6:
Preferences > Media & Disk Cache > Empty Disk Cache


2) If your particles are popping on and off near the edges of your frame, this may be due to a problem with how Particular culled the frustum [link].

Basically, I think Particular did not take the true size of a particle into account when figuring out if it should be rendered on-screen or not. Large particles that are near the edge may be erroneously removed from the scene because their center points have gone outside the boundaries of the solid -- even though a significant amount of the particle is still on-screen. A workaround is to increase the size of the solid to which Particular is applied, so that the popping happens out of view of the comp.

Walter Soyka
Designer & Mad Scientist at Keen Live [link]
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
@keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]


Return to posts index

William SaviolaRe: Particular- Keeping the same particles on
by on Nov 25, 2015 at 2:59:08 pm

yep this fixed it

thanks Walter!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]