ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Weird Problem While Animating A Shape Layer (Imported From Illustrator)

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Filippo MarchettiWeird Problem While Animating A Shape Layer (Imported From Illustrator)
by on Oct 7, 2015 at 10:34:06 pm
Last Edited By Filippo Marchetti on Oct 7, 2015 at 10:39:22 pm

Greetings.
I have recently designed a layout inside Adobe Illustrator CC2015 (latest update) and imported it as usual inside After Effects CC2015 to animate it.
Converted the layers to shape layers (using the "Convert To Shapes" command) and set 2 very simple keyframes for the shape propriety.
During the shape animation a couple of points are deleted, but the mask, instead of adapting logically, shows some big artifacts.
Words can't really describe visual issues, so i have made a video showing the issue (scroll down)

Note 01: The function "Preserve Vertex Count For Masks" is disabled (After Effects General Preferences)

Note 02: the same problem happens if i copy the mask from illustrator on top of the layers, without turning them into shapes.

Note 03: If i remove vertex points from a shape layer directly produced inside After Effects the problem doesn't show up., but i haven't noticed anything odd in the illustrator project that might confuse After Effects.

Thanks a lot for the help, and have a nice day/evening (depending where you live)

Problem 01



https://vimeo.com/revandesign


Return to posts index

Ashish GuptaRe: Weird Problem While Animating A Shape Layer (Imported From Illustrator)
by on Oct 8, 2015 at 7:44:26 am

I think the problem is because you are deleting your first vertex point as well with other points.

Try setting the start point(or first vertex as ae says) of the path to the top center indented point, and make sure it stays the same in both before and after shapes.

Ashish Gupta
Motiongraphics artist and 3d generalist

aashi.29nov@gmail.com


Return to posts index

Filippo MarchettiRe: Weird Problem While Animating A Shape Layer (Imported From Illustrator)
by on Oct 8, 2015 at 9:49:57 pm

Thanks for the feedback; i changed the first vertex but unfortunately it still distorts the shape, although the distortion is less "random" this time.

https://vimeo.com/revandesign


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]