ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

Flythrough words

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Eugene ConstableFlythrough words
by on Sep 2, 2015 at 4:52:25 pm

I need to create a 3d field/cloud of words. Flythrough them straight on to arrive at a certain heading then fly through the heading to the next heading. Thats it.

I have approx 30 words, of differing colours/fonts, sizes and transparency, which need to be repeated throughout the 'cloud' to give a sense of overwhelming amount of words.

Its causing me alot of problems.

So - I duplicated my 30 layers lots (around 300 layers) and using DistributeLayers script I randomized the x and y positions within 500 and in z I staggered them about 200 apart each (perhaps too much?) then animated the z position of my camera.

OK, so my layers are nicely in z depth and looking ok, but the comp has so many 3d layers it is unworkable. even at quarter res, purged memory etc evrytime I try and move a lyered I get beachballed (mac pro retina, 3 years old) Also my client has fed back that it needs MORE words!

Under a deadline and now really stuck with how to get this done, can anyone think of a better workflow for this?

Here's a pic of my working render for reference.

As you can see the layout is a bit messy, it does look better moving, but it's so slow to move the layers around now, Im struggling to improve it.

Thanks in adv!

ps. I tried using particular2 custom particles but couldn't get that to work, (custom particles too big)

pps, working at 1920x1080

Return to posts index

Dave LaRondeRe: Flythrough words
by on Sep 2, 2015 at 5:13:54 pm

Without knowing more specifics, I recommend disabling Motion Blur (if enabled) at 25% and one-fourth resolution.

Dave LaRonde
Promotion Producer
KGAN (CBS) & KFXA (Fox) Cedar Rapids, IA

Return to posts index

John CuevasRe: Flythrough words
by on Sep 2, 2015 at 7:44:06 pm

When you tried particular did you quit when it said custom particle size to large, cause that's just a warning---one you can choose to ignore. I've created comps using particular and 100's of large jpegs as particles and it worked fine for me.

Johnny Cuevas, Editor

"I have not failed 700 times. I have succeeded in proving that those 700 ways will not work. When I have eliminated the ways that will not work, I will find the way that will work."
---THOMAS EDISON on inventing the light bulb.

Return to posts index

Eugene ConstableRe: Flythrough words
by on Sep 2, 2015 at 8:08:45 pm


Thanks for your response

I initially thought particular was the way to do this.

Yes- I did get the the warning about custom particle size and yes, I ignored it.. but the particles, despite having enough life span, seemed to randomly dissappear, for no apparent reason. I looked this up online and found a few others experiencing similar problems with large custom particles.
This problem occured with both sprite and textured polygon. Tried adjusting the particle opacity over life, and adding a 1percent opacity solid to my custom particle comp.

None of the above solved the problem so I gave up on particular. Any ideas?!

as a side note, I also couldn't see how to get the size variance that I was after in particular, as shown in my pic from earlier post. but Im sure this is achievable somehow.


Return to posts index

Walter SoykaRe: Flythrough words
by on Sep 2, 2015 at 8:15:53 pm

[Eugene Constable] "None of the above solved the problem so I gave up on particular. Any ideas?!"

I've found the most common cause of Particular particles "popping off" is that Particular doesn't render particles whose centers are outside the boundaries of the solid. For a large particle, or a particle very close to the camera, this means that something that hits the edge vanishes before it should be fully off-screen. My solution is to enlarge the solid that Particular is on beyond the comp boundaries so the particles are clear of the visible comp area before they pop off.

Also, make sure you've got all the latest Ae updates for your version (especially CS6) and the latest Particular. There were some bugs a few years back with the new cache system that can cause this same behavior.

[Eugene Constable] "as a side note, I also couldn't see how to get the size variance that I was after in particular, as shown in my pic from earlier post. but Im sure this is achievable somehow."

Adjust the Particular > Particle > Size Random property.

Walter Soyka
Designer & Mad Scientist at Keen Live [link]
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
@keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]

Return to posts index

Cassius MarquesRe: Flythrough words
by on Sep 3, 2015 at 5:45:29 pm
Last Edited By Cassius Marques on Sep 3, 2015 at 5:46:35 pm

how are you sorting the particles? with the random frame - freeze option? Is the composition containing them shorter than the composition you're working on?(it must be) Also the last layer should be extended 1f past the composition duration. These are commom mistakes that create odd results.

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved