ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Can't 3D track a frontal shot of a highway, speed is wrong due to parallaxing

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
David CabestanyCan't 3D track a frontal shot of a highway, speed is wrong due to parallaxing
by on Aug 7, 2015 at 5:07:58 pm

I have a POV shot of a driver going in the highway. I need to put some 3D text on the sides of the road much like any sign would be there, as the driver gets closer the sign grows in frame and then it gets out of frame.

I tracked the shot using AE 3D camera tracker, the solved camera has an average error of .94 pixels and the movement is followed correctly, however whenever I place the text (made with Element) or any other 3D object, such as a solid, it travels much slower, the direction of the movement is correct as it is getting closer to the camera and eventually out of frame, but there's definitely a mismatch on the speed, and obviously make the entire shot look fake.

The points in the ground are moving much faster than the points in the trees right next to the road, and that's the way it's supposed to, but shouldn't the camera be solved taking that into account? It seems that is only considering the farther points only.

Can anyone help me figure out this?
D.


Return to posts index

Dave LaRondeRe: Can't 3D track a frontal shot of a highway, speed is wrong due to parallaxing
by on Aug 7, 2015 at 5:12:21 pm
Last Edited By Dave LaRonde on Aug 7, 2015 at 7:23:00 pm

If you're using highly-compressed footage, don't. AE has big problems with highly-compressed footage and anything even remotely related to time.

Transcode it to something like quicktimes in Photo JPEG, ProRes 422, PNG or Animation codecs.

Dave LaRonde
Promotion Producer
KGAN (CBS) & KFXA (Fox) Cedar Rapids, IA


Return to posts index

David CabestanyRe: Can't 3D track a frontal shot of a highway, speed is wrong due to parallaxing
by on Aug 7, 2015 at 8:51:44 pm

Thanks Dave. The track seemed to be ok, the problem was with whatever I added to the scene.
You're talking about playback ability only, right? Not improving the quality of the file by transcoding it?



Anyway, I worked it out. I retracked the scene and unchecked Auto-delete points across time, also, instead of creating my camera using several feature points (with the "bullseye" icon) I used only one null. Everything is working now.

Best,
D.


Return to posts index


Dave LaRondeRe: Can't 3D track a frontal shot of a highway, speed is wrong due to parallaxing
by on Aug 7, 2015 at 9:27:42 pm

No, I'm talking about AE's ability to properly composite highly-compressed video. Now, it may NOT be the cause of your woes.... but it could.

Dave LaRonde
Promotion Producer
KGAN (CBS) & KFXA (Fox) Cedar Rapids, IA


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]