ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Mask Tracker (I am Stumped)

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Joel EvansMask Tracker (I am Stumped)
by on Jul 21, 2015 at 6:11:59 pm

Will try to keep this short.

Trying to do what I thought would be simple. An ellipse mask to follow an object in my footage. After several failed attempts yesterday, tried to research. Can see the key frames but mask just sits there.

On this forum I read that if your footage is H264 it causes AE fits.
Opened Media Encoder and tried to encode to DVxHD, the problem here is the final output came as a sequence and could not figure out how to import as a clip.

Original footage
1080p @ 60fps
about 3 mins long.

Today more research read that the GoPro Cineform codec is very AE friendly.
Back to the endcoder.
Opened AE, imported file......
Same result.

Changed the comp to 29.97 the Mask moved maybe 10 pixels.

What am I missing?

Thanks in advance for any help or ideas.


Thank you for taking the time to post.





Return to posts index

Michael SzalapskiRe: Mask Tracker (I am Stumped)
by on Jul 21, 2015 at 7:33:40 pm

Have you followed any of the tutorials for motion tracking [link] or mask tracking [link] in the help files?

- The Great Szalam
(The 'Great' stands for 'Not So Great, in fact, Extremely Humble')

No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.


Return to posts index

Joel EvansRe: Mask Tracker (I am Stumped)
by on Jul 21, 2015 at 9:43:49 pm

Did it yesterday, from the help menu.


Thank you for taking the time to post.





Return to posts index


Joel EvansRe: Mask Tracker (I am Stumped)
by on Jul 23, 2015 at 4:51:15 pm

Sometimes the Older Geeks (me) get stubborn.

I found an older tutorial by Eran Stern "Motion Tracking" instead Mask tracking. This technique is close to what I am trying to do.

Now I can get the Mask to follow the Null object.

The problem is my object on the footage walks out of the Mask, the Mask/Null to too slow to follow.

In the comp I changed the frame rate from 60 fps to 29.97.
Looking at the Ram preview at 50% resolution.

Thanks in advance for any helpful hints.


Thank you for taking the time to post.





Return to posts index

Michael SzalapskiRe: Mask Tracker (I am Stumped)
by on Jul 24, 2015 at 3:23:05 am

Can we see an example of your footage? If you get a solid track, it should work. I don't understand the issues you're describing.

- The Great Szalam
(The 'Great' stands for 'Not So Great, in fact, Extremely Humble')

No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.


Return to posts index

Joel EvansRe: Mask Tracker (I am Stumped)
by on Jul 24, 2015 at 6:45:59 pm

Thank you for taking the time to respond.

Gonna wipe the slate clean and go thru the process again.

After mentally walking thru the work flow a couple of times, think I might have created some issues with my work flow.

After I complete it.......I will either give the results or show the issues.

Thanks again for taking the time to respond.


Thank you for taking the time to post.





Return to posts index


Joel EvansRe: Mask Tracker (I am Stumped)
by on Jul 25, 2015 at 8:25:17 pm








Thank you for taking the time to post.





Return to posts index

Joel EvansRe: Mask Tracker (I am Stumped)
by on Jul 30, 2015 at 6:52:29 pm

Back with an update.

A couple of days ago I tried to do this project on AE CS4 on an older desk top. Got it close to what I am trying to do.
Was getting output module settings error.....so had to figure that out to get it to render.

Gonna give it try again hopefully this afternoon on the CS4.
Made some mistakes.

it appears there are some bugs in cc 2015


Thank you for taking the time to post.





Return to posts index

Michael SzalapskiRe: Mask Tracker (I am Stumped)
by on Jul 30, 2015 at 6:59:52 pm

Your choice isn't between CS4 and CC 2015. The Creative Cloud gives you access to all versions of AE from CS6 up. That means you can download CS6, CC, CC 2014, and CC 2015. In fact, you can have all of them simultaneously on your system. (I have all of them plus my old copy of CS5!)

This link explains how to get them: http://blogs.adobe.com/adobecare/2015/06/16/how-to-find-and-install-previou...

- The Great Szalam
(The 'Great' stands for 'Not So Great, in fact, Extremely Humble')

No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.


Return to posts index


Joel EvansRe: Mask Tracker (I am Stumped)
by on Jul 30, 2015 at 8:19:43 pm

Just got the link for the CC AE 2015 bug fix, had to go to adobe to get it.

Thought I read some where running multiple versions caused problems.
I am possible wrong about that.

Thanks for the info.
Also updating Pr Pro.


Thank you for taking the time to post.





Return to posts index

Michael SzalapskiRe: Mask Tracker (I am Stumped)
by on Jul 30, 2015 at 8:23:00 pm

It may have cause problems many years ago, but it doesn't now. Like I said, I have CS5, CS6, CC, CC 2014, and CC 2015 all on the same system with no problems.

The guys on the After Effects team at Adobe even recommend using both CC 2014 and CC 2015 in your workflow. Work in one, render in the other since CC 2015 doesn't have multiprocessing.
I can't remember if they talk about it here [link] or here [link].

- The Great Szalam
(The 'Great' stands for 'Not So Great, in fact, Extremely Humble')

No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.


Return to posts index

Joel EvansRe: Mask Tracker (I am Stumped)
by on Aug 10, 2015 at 6:14:20 pm

Was not being rude by not responding. My cable provider does not understand customer service, router went out.

The link you provided worked great, downloaded AE CS6.

The motion tracker worked much, much better. None of the problems before.
The issue is when I apply a mask over the object in the video, the object walks out of the mask in about 10 seconds.

Took mask layer and pic whipped it to the Tracker Data layer as the parent.

Thinking maybe I need to find an expression for the mask path.


Thank you for taking the time to post.





Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]