ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Interpolation issue with graph editor

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
John JennetteInterpolation issue with graph editor
by on Mar 27, 2015 at 4:35:52 pm

I am attempting to add some simple easing but I can't figure out what's going on "under the hood" in the graph editor. I inherited the file from a third-party videographer, so I don't know how any settings were initially set up.

The animation is of an object coming in from the left, going past center, and coming back. I don't know how the guy set up the overshoot, though, because I can't add any easing and the graph editor shows a hard break between the two keyframes:



The position keyframes are both for the object in the center. There are no keyframes for the overshoot position, and I can't find any expressions or other influences that would cause it to go past the position that is keyframed. I have never seen a graph look like that, so I am passing it to those more experienced than me. How do I work with this? There are no handles, even when changing the keyframe interpolation (this is Auto-Bezier, btw, but the break remains even in other formats).

Let me know if there is any other information that would be useful - Since I don't know how this was set up, I don't know what else to put here. Thanks!


Return to posts index

Michael SzalapskiRe: Interpolation issue with graph editor
by on Mar 27, 2015 at 6:19:00 pm

If you choose to separate dimensions, you should be able to grab things better.

Also, if you select your keyframes and choose to change the interpolation to linear, you could avoid that overshoot too.

- The Great Szalam
(The 'Great' stands for 'Not So Great, in fact, Extremely Humble')

No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.


Return to posts index

John JennetteRe: Interpolation issue with graph editor
by on Mar 27, 2015 at 8:01:17 pm

Thanks for the help! That's my issue: there doesn't seem to be anything TO grab. Those keyframes don't have handles, even if they are set to bezier.

I could set the keys to linear, and add another keyframe slightly forward from center for the bounce back effect (which I still want to include). The problem then becomes when I try to ease, that sharp 'V' point is still there, throwing off the curve.

It's a simple enough animation that I may just re-create it from scratch - I still don't understand what caused the curve to make that 'V' shape in the first place...


Return to posts index


Michael SzalapskiRe: Interpolation issue with graph editor
by on Mar 27, 2015 at 9:43:12 pm

Even when you separate dimensions?

- The Great Szalam
(The 'Great' stands for 'Not So Great, in fact, Extremely Humble')

No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.


Return to posts index

John JennetteRe: Interpolation issue with graph editor
by on Mar 30, 2015 at 4:48:26 pm

Separate Dimensions is ghosted. I have researched that issue, but nothing seems to work.

It may be worth noting that the animation is on the anchor point of the object (which seems a bizarre way to animate something's position, but it's not my file). I should still be able to separate the dimensions though. Also, changing it to a bezier keyframe does not create handles, so even if I could separate, would there be anything to grab?


Return to posts index

Michael SzalapskiRe: Interpolation issue with graph editor
by on Mar 30, 2015 at 5:01:14 pm

Any chance you can just copy the values to keyframes on the position property and then delete the anchor point keyframes (saving an incremental version of the file from this point and not saving over the original, of course)?

- The Great Szalam
(The 'Great' stands for 'Not So Great, in fact, Extremely Humble')

No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.


Return to posts index


John JennetteRe: Interpolation issue with graph editor
by on Mar 30, 2015 at 6:11:35 pm

Yeah, that's what I think I will do. Luckily it is a very straightforward, four/five keyframe motion. Thanks for helping me try to puzzle it out!

I may still see if I can ask him how he keyframed, because I've never seen a graph like that before, and don't know how (or why) you would create something like that. A little curiosity now can save time later - especially if it ends up in a more complex project...


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]