ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Layer shows through upon rendering

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
stephen roberts
Layer shows through upon rendering
on Feb 8, 2015 at 9:54:36 pm

Hi There!
When I render my comp (ProRes 442), there's one frame where the layer underneath shows through the layer above (see attached image).

Any ideas? … Not sure that it matters but the layer above (funny little mask) is Parented to the hand layer (so they move together)

using AE CC2014
Thanks!



maskproblem.jpg


Return to posts index

Spencer Tweed
Re: Layer shows through upon rendering
on Feb 8, 2015 at 10:50:40 pm

Are your layers 3d? Or do any of them have layer styles?

You can always try throwing an adjustment layer between the two with a curves or something on it (just add the effect, don't actually make an adjustment) which will sometimes sort out AE's render order problems. That forces AE to render everything below the adjustment layer before processing the mask layer and can fix some bugs.

- Spencer


Return to posts index

stephen roberts
Re: Layer shows through upon rendering
on Feb 8, 2015 at 10:52:06 pm

yes, they are all 3D layers. I'll try the adjustment layer idea. thanks!


Return to posts index


Spencer Tweed
Re: Layer shows through upon rendering
on Feb 8, 2015 at 10:55:28 pm

Yep, that sometimes happens when you have motion blur on 3d layers that are at the same z depth. I'm pretty sure the adjustment layer will fix it!

- Spencer


Return to posts index

stephen roberts
Re: Layer shows through upon rendering
on Feb 8, 2015 at 11:06:49 pm

Adding the adjustment layer didn't work. The layer still shows through (just on that one frame???)

I turned off the 3D layers and it worked fine! … So maybe I'll have to figure out a way to work around the layers being 3D. Or should I try to push that back layer backwards in Z Space?


Return to posts index

Spencer Tweed
Re: Layer shows through upon rendering
on Feb 8, 2015 at 11:16:23 pm

Hm, that should have worked... Yes, I have sometimes pushed the lower layer a pixel or half a pixel back in z space and had that work too. I think what happens is that the motion blur in 3D somehow makes AE think that it the layer stretches behind the other layer or something like that - and realize motion blur can span multiple frames, which is why you are seeing it on the frame BEFORE your actual keyframe. (easy-easing it might also help btw, if that is what you want animation-wise).

- Spencer


Return to posts index


stephen roberts
Re: Layer shows through upon rendering
on Feb 8, 2015 at 11:23:20 pm

Thanks for your patience! I tried moving the zSpace a pixel back and forward with no luck. I think you're right about the Motion Blur in 3d. I'm doing something wrong, obviously.

Here's what it is: There's this funny mask layer, and a Hand layer. The hand layer moves to mask, and when it touches, I swap out the Mask layer (turn Opacity to 0) and replace with a Duplicate mask layer that is Parented to the hand (I know, stupid workaround)

I could resolve this if there was a way to NOT Parent the Hand to the Mask as it approaches, and then TURN ON the parenting for the take away. Is that possible?


Return to posts index

stephen roberts
Re: Layer shows through upon rendering
on Feb 8, 2015 at 11:36:36 pm

Fixed! It seems as though UN-Parenting layers is tricky business, so most people suggest that you split the layers. And it worked!

I didn't know you could split layers. I'm not sure how this is different that my "two-layer-turn-one-off-and-the-other-one-on approach" … but from now on, I'll be splitting layers! Thanks!


Return to posts index

Spencer Tweed
Re: Layer shows through upon rendering
on Feb 8, 2015 at 11:39:04 pm

Haha, I just posted that you should try that! Glad you solved it!

- Spencer


Return to posts index


Spencer Tweed
Re: Layer shows through upon rendering
on Feb 8, 2015 at 11:38:10 pm

Are you sure the parenting is the problem? It is possible to sort of turn a parent on and off with expressions, but that gets a bit complicated. Instead of animating your opacity (which could also be the problem!) try just trimming your layers in and out points and leaving the opacity at 100%. So in other words when the parented layer needs to show up trim it's in point to that frame alt + [ and go back one frame and trim the non-parented layer's out point alt + ]. Give that a shot!

I'm still surprised the adjustment layer didn't work... I just want to make sure that was set up right. So basically you should have this:

1 Hand layer
2 Mask layer (parented)
3 Mask layer (unparented)
4 [adjustment layer]
5 face layer

and to just make sure why don't you change one of the parameters in the curves on the adjustment layer (just brighten it a tiny bit or something) to make sure that AE is actually rendering the layer and not just passing through it.

Hope one of those fixes it! I know how frustrating that can be...

- Spencer


Return to posts index

stephen roberts
Re: Layer shows through upon rendering
on Feb 8, 2015 at 11:43:55 pm

Thanks Spencer! I had another issue of layers showing through with motion blur and 3d Layers and your adjustment layer trick worked! .. Thanks again.


Return to posts index

Spencer Tweed
Re: Layer shows through upon rendering
on Feb 8, 2015 at 11:51:53 pm

Haha, glad I could help with that in the end!

- Spencer


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]