ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Ram Preview won't start when Render multiple frames simultaneously enabled

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Pavlos Etostone
Ram Preview won't start when Render multiple frames simultaneously enabled
on Feb 8, 2015 at 6:01:04 am
Last Edited By Pavlos Etostone on Feb 8, 2015 at 6:14:30 am

Hello everyone,

I have an issue with rendering AE CC , with my new PC computer in Windows 8.1 pro 64 bit

As the title says , my issue is Ram Preview won't start when Render multiple frames simultaneously enabled.Actually it starts after 8 -30 seconds depending of project complexity and the rendering is slower and skipping frames !
12 cores with 2 GB ram each.
When I disable the option of multiple frames simultaneously render starts ok,
but it's really very sad that I can't use this beast of CPU in full potential. its an new intel i7 5930K , 32 Ram DDR4 2.4 Ghz

Any advice and options would be much appreciated.

Thanks,
Vonzar.




Setup:
Windows 8.1 Pro 64 bit
CPU : Intel Core i7 5930K 3.5 GHz Six Core Socket 2011-3 140W Box
GPU : nVidia GeForce GTX 970 4GB DDR5 PCI-E
RAM : 32GB DDR4 Non ECC CL16 2400MHz Crucial Ballistix Sport
Mother board : Asrock x99 extreme 6


Return to posts index

Tero Ahlfors
Re: Ram Preview won't start when Render multiple frames simultaneously enabled
on Feb 8, 2015 at 9:40:01 am

What are your multiprocessing settings?


Return to posts index

Pavlos Etostone
Re: Ram Preview won't start when Render multiple frames simultaneously enabled
on Feb 11, 2015 at 8:00:27 am

When MP , I thing the best settings working so far are from the 12 cores to use the 6 cores, leaving 6 cores for other programs .
Memory usage is 24 GB out of 32 . 8 GB left for other programs.


Return to posts index


Walter Soyka
Re: Ram Preview won't start when Render multiple frames simultaneously enabled
on Feb 8, 2015 at 10:35:32 am

Per Todd Kopriva, posting in another thread [link]: What happens if you mute audio in the Preview panel? (This question is getting at a possible problem in how audio is cached first before the video RAM preview begins.)

Failing that, a quick note on how Ae's multiprocessing works: it saves a copy of your project, then multiple instances of the Ae renderer open that project, each within its own RAM space, and thus render multiple frames simultaneously.

As you note, there is a lot of time overhead for starting up multiprocessing: saving the project, launching the background renderers, and then each instance opening the project -- all before a single frame is rendered.

For short renders, this overhead is not always worth it; it may be faster just to render a single frame at a time because this incurs no overhead. This is why there's a preference to disable MP for RAM previews.

For longer renders, though, the ability to render multiple frames at the same time usually eventually pays back the overhead of starting the multiprocessing render in the first place. This is why there's a preference to leave MP on for render when it's disabled for RAM previews.

In other words, a 25 second render will probably not benefit from multiprocessing (especially if your apps and projects are not stored on SSD drives), but a 5 minute render will.

I think it's bad practice to leave 0 CPUs for other applications. This leads to overscheduled processors [link]. 2GB is also probably the minimum reasonable allocation for each process, and you might see better results with a higher minimum allocation -- but make sure you are also reserving enough RAM (I usually start at 25%) for other applications.

I think you will generally see better results reserving 8GB (or more) for other applications, reserving 6 CPUs (or more) for other applications, and allocating 4 GB (or more) for each background process, even though this will reduce the number of render threads.

I know that seems paradoxical -- but fewer render threads with sufficient resources trump more render threads with insufficient resources, with faster total render times.

Personally, I usually leave MP for RAM preview off because I cannot tolerate that lengthy startup time for just a few frames. You might consider using the cache work area in background feature to speed up single-process RAM previews where possible.

Walter Soyka
Designer & Mad Scientist at Keen Live [link]
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
@keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]


Return to posts index

Pavlos Etostone
Re: Ram Preview won't start when Render multiple frames simultaneously enabled
on Feb 11, 2015 at 7:58:34 am

Hi Walter. Thank you for your reply and advice . I am sorry for the delay.
Well I have tried to mute audio from the preview panel . It didnt fix anything at all.

I have tried to lower the Cores from 12 to 6 . Now it's working better , with 2 GB to each core.
The new problem is that the rendered Green bar is lost after I stop and continue the preview ram. It starts from zero or sometimes keeps only a small part of the preview render !!!
Another weird behavior is that the 2nd time I preview ram the render goes to a point and then the progress disappears . However after I stop the preview ram it shows that the preview was happening under the program ? (I know it's weird) but the green bar again is lost after i stop.

and to add more information , If I check the task bar , even after exiting AE I still can see one process of AE taking place in the background!

Nothing of these happens in rendering without MP . But avoiding MP is like going back in time. Even my older quadcore could perform better.

I have a feeling since my computer is the latest technology , AE has issues of compatibility .
They need to fix all these weird stuff going on. My older PC a quadcore is working very good with AE 6 , but it's an 7 years machine and it's rendering very slow.
I have seen many same like issues of mine with other users happening in this forum or Creative Cow. Adobe has great programs but can't upkeep with the technology
changes. They have stayed far behind. There are countless reports of this same issue and for some reason Adobe is not able to fix.
Well any other info would be much appreciated.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]