ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Having a problem with overlapping masks.

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Richard Garabedain
Having a problem with overlapping masks.
on Jan 8, 2015 at 8:05:55 pm

They are not really overlapping, they just meet in the middle. Which ive done a million times before. But today i have a gap in between the masks. I drew the masks using guides, so technically they meet at the same point. And i cannot get rid of the gap. Ive tried moving each mask both directions, mask expansions...etc. I tried going to ray trace comps and classic 3d comps. Whenever i try to move the mask, the gap seems to move with it. I dont understand why its different today.

i can see a sliver of colors from the layers behind it is the problem.


Return to posts index

Daniel Waldron
Re: Having a problem with overlapping masks.
on Jan 9, 2015 at 5:37:02 pm

Did you accidentally change the mask expansion settings?


Return to posts index

Daniel Waldron
Re: Having a problem with overlapping masks.
on Jan 9, 2015 at 5:37:42 pm

Oops, just saw you checked that already. Maybe post a screenshot?


Return to posts index


Jason Jantzen
Re: Having a problem with overlapping masks.
on Jan 9, 2015 at 8:59:48 pm

Try applying the Levels effect with individual controls. In the dropdown RGBA box, select Alpha and try boosting the alpha. Not sure if this will help with a masked layer. Might need to be precomped, and yet this still feels like a huge pain the ass. I think the issue lies with anti-aliasing. If your masks aren't meeting exactly on the pixel, then you'll see anti-aliasing in the form of some transparency at the edges.

I'd try creating the same masks in Illustrator, only snap them to the pixel grid and see how much that helps.

Good luck!

Jason Jantzen
vimeo.com/jasonj


Return to posts index

Jason Jantzen
Re: Having a problem with overlapping masks.
on Jan 9, 2015 at 9:04:17 pm

One other thought came to mind. I didn't think of this since you created the masks in AE and had done this a million times, so I figured they must be set to Add mode. Are they by chance somehow set to Intersect mode?

Jason Jantzen
vimeo.com/jasonj


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]