ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

Dynamic Link CC 2014 - continued issue

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Jim CunninghamDynamic Link CC 2014 - continued issue
by on Nov 26, 2014 at 2:45:46 pm

Still running into issues w/ Dynamic Link and Premiere(CC 2014). I've create animation in AE, import into Premiere. Initially it plays OK, but after a few minutes, it freezes in Premiere timeline. I can toggle to AE then back to Premiere, and the animation will play OK for a little while, then it freezes again (and I toggle to AE and back to continue working).
If I close AE things work OK. Not an issue in CS6 -- same machine. I believe this was originally fixed by turning off App Nap In AE, but that is not available in CC. It does seem as if AE is powering off while in the background, and toggling to it wakes it up and it works for a while.

This has been an on going issue for months, through several updates.
I've tried all of the cleaning/deleting/updating etc. suggested in the past.

Can someone please recommend a solution?

BTW, this doesn't seem to be happening w/ Speed Grade.


Late iMac 27, 32GB RAM, 4GB VRam, latest nVidea CUDA driver, OS 10.9.5
Thunderbolt RAID

Return to posts index

Todd KoprivaRe: Dynamic Link CC 2014 - continued issue
by on Nov 26, 2014 at 11:32:37 pm

You are encountering a known bug that we have fixed in an update that we'll be releasing in a few weeks.

As you have noted, the workaround is to quit the After Effects application to speed up the processing of After Effects compositions added to Premiere Pro using Dynamic Link.

In case you're curious: The bug is that the full version of the After Effects application is sending far too many (hundreds per second) of a certain kind of message when communicating over Dynamic Link. The "headless" version of After Effects doesn't send the same sort of message, so it's not susceptible to this bug.

Todd Kopriva, Adobe Systems Incorporated
After Effects product manager and curmudgeon
After Effects team blog

Return to posts index

Jim CunninghamRe: Dynamic Link CC 2014 - continued issue
by on Nov 27, 2014 at 2:10:56 pm


Thanks for the update. It is reassuring that it's not just me w/ the problem, and there is a fix on the way. The Dynamic Link workflow between AE & PP is an extremely powerful tool, and I am looking forward to not being hobbled by the above mentioned issue.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved