ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

RAM preview is delayed when I play back "green bar" sections---also skips the 1st second of work area (isn't from multi-processing)

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Chris King
RAM preview is delayed when I play back "green bar" sections---also skips the 1st second of work area (isn't from multi-processing)
on Nov 23, 2014 at 9:37:15 pm
Last Edited By Chris King on Nov 23, 2014 at 10:04:26 pm

Hi all,

Here's the issue: while I'm working in a comp, I'll create a work area around a specific section and hit "0" to RAM preview at which point the RAM preview begins immediately, stepping slowly through the frames.

BUT when it reaches the end of the work area the current time indicator as well as the video preview both freeze on the last frame. This lasts about one second before it begins playing again, but SKIPPING the first second of the work area. Then if I let it continue playing to the end, it loops back and plays from the first frame like everything is normal.

If I hit stop and then hit "0" again on that same exact work area, the current time indicator once again remains unresponsive for a second then begins playing, skipping the first second, despite the fact that the entire work area is green already.

I know AE hiccups like this are often attributed to the use of multi-processing, but I've tried testing this with MP both on and off and had the same freeze-skip results which makes me think this is some other (incredibly frustrating) bug. I recently upgraded to Yosemite which could very well work within the timeline of this bug appearing, but haven't read anything about it on Adobe's site.

Here are my specs:

OS: Yosemite

iMac 27" late 2012
3.4GHz Intel Core i7
16GB RAM
NVIDIA GeForce GTX 680MX 2GB

After Effects CC 2014, w/ latest updates.

Disk Cache: Have tried external 7200 1TB USB 3.0 as well as locally to desktop---no change

Thanks for any help.


Return to posts index

Dave LaRonde
Re: RAM preview is delayed when I play back "green bar" sections---also skips the 1st second of work area (isn't from multi-processing)
on Nov 24, 2014 at 1:41:23 am

It's a bug in AE. They know about it. They sau they'll have a fix sometime this winter. That's as much as they'll say at the moment.

Dave LaRonde
Promotion Producer
KGAN (CBS) & KFXA (Fox) Cedar Rapids, IA


Return to posts index

Todd Kopriva
Re: RAM preview is delayed when I play back "green bar" sections---also skips the 1st second of work area (isn't from multi-processing)
on Nov 24, 2014 at 5:17:10 pm

See the known issues here:
http://blogs.adobe.com/aftereffects/2014/10/after-effects-mac-osx-v10-10-yo...

---------------------------------------------------------------------------------------------------------
Todd Kopriva, Adobe Systems Incorporated
After Effects product manager and curmudgeon
After Effects team blog
---------------------------------------------------------------------------------------------------------


Return to posts index


Jimmy Brunger
Re: RAM preview is delayed when I play back "green bar" sections---also skips the 1st second of work area (isn't from multi-processing)
on Nov 26, 2014 at 11:56:57 am

Hi Todd,

Oh dear god...this is pretty fundamental!

My new MP shipped with Yosemite, so presumably I'd have to somehow wipe my system and re-install with Mavericks to fix this problem? Mavericks being incredibly buggy, I'm loathed to do that.

Also another problem which I wonder might be related Todd?...In conjunction with this delay I have been having a problem with cached frames (whether to RAM or Disk Cache) getting dumped after it's previewed? I.E: it will render all the frames and preview on loop...when I hit RP button to stop it all or some of the green bar disappears, so it has to re-render every time.

Please let me know if there is a fix for this one, as I can potentially live with the lag for now.

Thanks,
James

-------------------------------
Adobe CC 2014
MacPro 2013 8-core 3GHz / 64GB RAM / Dual FirePro D500s / OSX 10.10
Decklink Extreme+ 3D / 2TB SSD RAID-0 scratch / XServe + UD RAID on Small Tree 10GbE


Return to posts index

Jimmy Brunger
Re: RAM preview is delayed when I play back "green bar" sections---also skips the 1st second of work area (isn't from multi-processing)
on Dec 22, 2014 at 4:25:50 pm

Hi all,

Has anyone found a fix for this yet?

-------------------------------
Adobe CC 2014
MacPro 2013 8-core 3GHz / 64GB RAM / Dual FirePro D500s / OSX 10.10
Decklink Extreme+ 3D / 2TB SSD RAID-0 scratch / XServe + UD RAID on Small Tree 10GbE


Return to posts index

Dave LaRonde
Re: RAM preview is delayed when I play back "green bar" sections---also skips the 1st second of work area (isn't from multi-processing)
on Dec 22, 2014 at 10:18:34 pm

Have you ever let AE go through the preview a couple of times? I'm told it straightens itself out... no personal experience with it.

Dave LaRonde
Promotion Producer
KGAN (CBS) & KFXA (Fox) Cedar Rapids, IA


Return to posts index


Jimmy Brunger
Re: RAM preview is delayed when I play back "green bar" sections---also skips the 1st second of work area (isn't from multi-processing)
on Dec 23, 2014 at 10:46:51 am

The missing of the start of the work area on RAM playback is indeed ok on the 2nd run through if you leave it to loop, but still a pain to have to do that every time..

UPDATE: Just downloaded AE 13.2.0.49 and it seems to have fixed the losing of RAM cache and first few frames skipping issue....However there is now a massive delay (there was always *some* delay with MP switched on) before RAM Preview kicks in. I'm on an 8-core with 64GB RAM, so when it finally does kick in it chews through pretty quick, but I was waiting about 30" just now for it to think about it first..

Almost there Adobe - try try and try again please guys!

James

-------------------------------
Adobe CC 2014
MacPro 2013 8-core 3GHz / 64GB RAM / Dual FirePro D500s / OSX 10.10
Decklink Extreme+ 3D / 2TB SSD RAID-0 scratch / XServe + UD RAID on Small Tree 10GbE


Return to posts index

Jimmy Brunger
Re: RAM preview is delayed when I play back "green bar" sections---also skips the 1st second of work area (isn't from multi-processing)
on Dec 23, 2014 at 1:09:39 pm

STRIKE THAT!...


The 'skipping first second or so of RAM preview' bug still seems to be there I'm afraid. :(

-------------------------------
Adobe CC 2014
MacPro 2013 8-core 3GHz / 64GB RAM / Dual FirePro D500s / OSX 10.10
Decklink Extreme+ 3D / 2TB SSD RAID-0 scratch / XServe + UD RAID on Small Tree 10GbE


Return to posts index

Todd Kopriva
Re: RAM preview is delayed when I play back "green bar" sections---also skips the 1st second of work area (isn't from multi-processing)
on Dec 30, 2014 at 5:40:08 pm

This is a bug with Mac OSX v10.10 (Yosemite). We are working with Apple to isolate and fix the issue.

---------------------------------------------------------------------------------------------------------
Todd Kopriva, Adobe Systems Incorporated
After Effects product manager and curmudgeon
After Effects team blog
---------------------------------------------------------------------------------------------------------


Return to posts index


Jimmy Brunger
Re: RAM preview is delayed when I play back "green bar" sections---also skips the 1st second of work area (isn't from multi-processing)
on Jan 2, 2015 at 1:33:14 pm

Thanks Todd. Please do post here when you have any news.

-------------------------------
Adobe CC 2014
MacPro 2013 8-core 3GHz / 64GB RAM / Dual FirePro D500s / OSX 10.10
Decklink Extreme+ 3D / 2TB SSD RAID-0 scratch / XServe + UD RAID on Small Tree 10GbE


Return to posts index

Jimmy Brunger
Re: RAM preview is delayed when I play back "green bar" sections---also skips the 1st second of work area (isn't from multi-processing)
on Jan 2, 2015 at 1:39:43 pm

...Also Todd - do you know if there's any other memory leak problems with AE/Yosemite, particularly using project assets over a network?

I've been having alot of beachball lockups and unsaveable crashes when working on a project with alot of TIFF sequences (CG render passes) Only way to remedy is force quit hard restart machine and hope the last auto-save wasn't too long ago...

-------------------------------
Adobe CC 2014
MacPro 2013 8-core 3GHz / 64GB RAM / Dual FirePro D500s / OSX 10.10
Decklink Extreme+ 3D / 2TB SSD RAID-0 scratch / XServe + UD RAID on Small Tree 10GbE


Return to posts index

Matt Chiama
Re: RAM preview is delayed when I play back "green bar" sections---also skips the 1st second of work area (isn't from multi-processing)
on Jan 6, 2015 at 8:58:48 am

I've found a "home made" (but effective) fix : add a 1sec blank at the beginning of my comps during the creative part, and remove it when rendering.
Didn't found anything else, but it does the job while waiting for the update.


Return to posts index


Jimmy Brunger
Re: RAM preview is delayed when I play back "green bar" sections---also skips the 1st second of work area (isn't from multi-processing)
on Mar 3, 2015 at 10:22:08 am

Hi Todd any news on this?

Thanks,
James

-------------------------------
Adobe CC 2014
MacPro 2013 8-core 3GHz / 64GB RAM / Dual FirePro D500s / OSX 10.10
Decklink Extreme+ 3D / 2TB SSD RAID-0 scratch / XServe + UD RAID on Small Tree 10GbE


Return to posts index

Todd Kopriva
Re: RAM preview is delayed when I play back "green bar" sections---also skips the 1st second of work area (isn't from multi-processing)
on Mar 3, 2015 at 5:40:22 pm

The bug occurs because the new version of Mac OS makes a bad assumption. Apple knows about this, and the core bug is theirs to fix. Whether they choose to do so is up to them.

We are able to work around this problem by making a very major change to After Effects---which has other benefits, too. We intend to release a version of After Effects with this change as soon as possible; the current target is this spring.

---------------------------------------------------------------------------------------------------------
Todd Kopriva, Adobe Systems Incorporated
After Effects product manager and curmudgeon
After Effects team blog
---------------------------------------------------------------------------------------------------------


Return to posts index

Jimmy Brunger
Re: AM preview is delayed when I play back "green bar" sections---also skips the 1st second of work area (isn't from multi-processing)
on Mar 3, 2015 at 11:43:37 pm

Thanks for the update Todd. Look forward to the..err...update!

-------------------------------
Adobe CC 2014
MacPro 2013 8-core 3GHz / 64GB RAM / Dual FirePro D500s / OSX 10.10
Decklink Extreme+ 3D / 2TB SSD RAID-0 scratch / XServe + UD RAID on Small Tree 10GbE


Return to posts index


Simon Piniel
Re: RAM preview is delayed when I play back "green bar" sections---also skips the 1st second of work area (isn't from multi-processing)
on Jan 8, 2015 at 11:07:48 pm

I recently upgraded to a 2012 MacPro and have the same problem since. Everything gets better all the time.


Return to posts index

Anthony Carnevale
Re: RAM preview is delayed when I play back "green bar" sections---also skips the 1st second of work area (isn't from multi-processing)
on Apr 24, 2015 at 3:15:13 pm

One thing I have noticed while I am waiting for this bug to be fixed is if you enable Mercury Transmit so a second monitor is showing your ram preview then that displays the first second correctly that is missing from the composition preview window.

Hope that helps some.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]