ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

Excessive grain in footage after greenscreen keyed out.

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Greg SageExcessive grain in footage after greenscreen keyed out.
by on Nov 9, 2014 at 3:19:34 am

Not sure where to ask this as it could possibly be a number of things, but since I'm doing all keying in AE...


Gh2 (AVCHD) footage (.mts files)
Transcoded via 5dtoRGB into ProRes 4:2:2 with 709 / progressive / broadcast range / 1.0 gamma settings
Keyed in AE cc2014 using either keylight or Primatte. Same problem with both.

Basically, the footage looks fine before keying, but after keying, no matter what I do, the foreground is ridiculously grainy. No matter how much I zero in on the combined matte to make sure it's pure opaque in foreground, I get this same drastic grain.

My first thought is the footage. It's a bit confusing with gh2 since it doesn't do 1080p without being hacked, hack allows it, but it doesn't show you anywhere that it is in fact doing progressive. After being transcoded in 5dtoRGB, though, I'm setting it to progressive output and it looks fine before keying, so that seems like a dead end.

I've tried a dozen settings, but no matter how opaque I make the foreground, the issue persists. I know there is a known iso bug with this camera, but what's confusing me is that the footage looks smooth and noise-free prior to keying.

What else should I be checking?

Return to posts index

Oki PienandoroRe: Excessive grain in footage after greenscreen keyed out.
by on Nov 9, 2014 at 5:03:59 am

Can you send the sample ? Just 1-2 seconds is OK.
You can send to my email, farmasinema@gmail(dot)com

I bump into this problem as well with ISP Robust key (but not the same camera, it doesn't matter IMO if the files were already transcoded)

And the solution is in fact using a different keying method (Keylight)

I guess the algorithm/the setting you use is too aggressive.
Are the green screen is properly done ? If it's not, you can't helped the opaque problem.

Sorry for the english, not native speaker.

Return to posts index

Tudor "Ted" JelescuRe: Excessive grain in footage after greenscreen keyed out.
by on Nov 9, 2014 at 6:55:19 am

In Keylight use the Intermediate Result. Then apply the Spill Suppressor. That works most times for me.

Tudor "Ted" Jelescu
Senior VFX Artist

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved