ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Horizontal blocks/lines appear in random frames.

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Aaron J. MarchHorizontal blocks/lines appear in random frames.
by on Oct 21, 2014 at 6:44:51 am

Hello,

My apologies if there is already a thread with a solution to this problem - I have not been able to find it.

I am a producer on contract for a very large IT company and my team and I are producing online content mostly presentations on greenscreen with animated backgrounds.

The workflow I have once the footage is captured through Wirecast, is to take it into AE and then proceed to key out the greenscreen before creating a matte around the subject and then eliminating the key (thus avoiding losing colour by just keying out the green) I have recently begun to notice random blocks appearing in frames - parts where the alpha channel disappears in blocks/horizontal lines across the composition. This is not just an export issue as it appears before export.

Initially the problem was 'solved' by a restart of the machine, however the problem has not been going away after re-starts and when I took the project to another machine (a fresh AE project which had not been opened or created on the first machine) the same issue occurred.

Please see screen captures below. (note - the subjects head is blurred out in photoshop for privacy reasons, and is not part of the issue.)

WORKFLOW:
Capture footage from Canon XF105 through Wirecast Version 4.3.2 (20742) footage captured as .mov Apple Intermediate Codec 1920x1080 25fps. Footage imported to AE with the following steps: OR footage is edited in PR then exported back to original settings and then imported into AE (either way the problems still occur):

- Create new composition - drag greenscreen footage into new comp button.
- Create solid colour
- Layer >New>Solid OR cmd+Y and adjust colour settings to make it WHITE
- Drag ‘White Layer’ under Green Screen Footage in composition
- Matte out video if necessary using pen tool
- Add ‘Selective Colour’ effect, select ‘greens’ and adjust to
C=100%,
M= (minus) -100%,
Y=100%,
B/K=100%
- Duplicate effect if necessary - cmd+D
- Add ‘Keylight’ effect, use colour dropper to select green colour on the green screen
-Change view to ‘Combined Matte’
-Click the colour swatch and move dot left and down to remove some of the screen shadows and click OK
-Raise ‘Screen Gain’ a little (no more than 115) to help remove shadows in the screen
-Tweak ‘Screen Balance’ to even out whites - set between 40 and 60
-Under ‘Screen Matte’ raise ‘Clip Black’ until the background starts to disappear (no more than 15)
-Lower ‘Clip White’ until most of the semi transparent (grey sections) is gone from the white areas (no less than 85)
-Raise ‘Screen Despot White’ to fill the holes in the white - somewhere around 5
-Change the view drop-down to ‘Final Result’ - see how things are looking
-Tweak ‘Screen shrink/grow’ to make sure there isn’t any lines or artifacts showing on the edges
-Tweak ‘Screen Softness’
-Change view to ‘Combined Matte’
-Pre-compose Green Screen Footage layer - cmd+shift+C
- Name it “Green Screen”
- Check ‘Move all attributes’
- Check ‘Open New Comp’
- Click ‘OK’
-Create new Adjustment Layer - alt+cmd+Y
-Black ThreshRename it to “Black Threshold”
- click on ‘Solids’ in project window, right click on the Adjustment Layer and scroll down to ‘Rename’
-Change the layers Blend Mode (in the left of the composition click on ‘Mode’) to ‘Darken’
-Apply ‘Threshold’ effect onto ‘Black Threshold’ adjustment layer
-Scrub the settings down until the screen is completely black, but allow for some grey areas on the edges
-Create new Adjustment Layer, name it “White Threshold”, change Blend Mode to ‘Lighten’
- Add ‘Threshold’ effect and adjust till the white is white, but allow for some grey areas on the edges
- Create new Adjustment Layer, name it “Soften Matte”
- Add ‘Gaussian Blur’ to the ‘Soften Matte’ layer and set blurriness to about 3
- Duplicate ‘Green Screen ‘ layer - cmd+d
- In the composition, Highlight the top Green Screen layer and the three Adjustment Layers above it
- Pre-compose those layers - shift+cmd+c,
- name as “Green Screen Matte”
- uncheck ‘Open New Composition’,
- click ‘OK’
- Drag the ‘Green Screen’ Layer above the ‘Green Screen Matte’ layer/comp
- Delete all effects from the ‘Green Screen’ footage layer
- Apply ‘Set Matte’ effect to ‘Green Screen’ footage layer
- Set ‘Take Matte From Layer’ to ‘Green Screen Matte’
- Set ‘Use For Matte’ to ‘Luminance’
- Hide ‘Green Screen Matte’ by clicking the eyeball icon on the lefthand side of the timeline
- Pre-compose ‘Green Screen’ layer - highlight then shift+cmd+c,
- name it ‘Remove Green Fringe’,
- check ‘Leave All Attributes’,
- check ‘Open in New Composition’,
- click ‘OK’
- Duplicate the ‘Green Screen’ footage layer - highlight, then cmd+d
- Add ‘Keylight’ effect to top layer, click eyedropper and pick a pure green colour from the screen
- Add ‘Channel Combiner’ effect to the top layer
- Set ‘From’ to ‘Straight to Pre-Multiplied’
- Check ‘Solid Alpha’
- Set top layer Blend Mode to ‘Color’
- Click back on the main composition
- if everything is OK, Proceed to Export.

It is hard to say exactly where the problem occurs as it has either been picked up during the Matt creation or after export (the videos are usually between 5 to minutes long, with the blocks appearing quite often early in the timeline and often randomly - it might be at one point in the timeline then after a restart it will appear at another frame. There are often several instances of it occurring in one timeline or only on instance.

SPECS: (However the problem has occurred on another machine with vastly different specs)
Processor 2 x 2.66 GHz 6-Core Intel Xeon
Memory 24 GB 1333 MHz DDR3 ECC
Graphics ATI Radeon HD 5770 1024 MB
Software OS X 10.9.5 (13F34)

AE version 2014.1.1 version 13.1.1.3 (recently updated after the problem started occurring)

We have attempted to tweak such preferences as adjusting Alternative RAM preview, (GPU is not available with the current graphics card), texture memory, displays/number of displays used, reset disk Cache, adjusted various configurations for memory, all with restarts of either the program, or entire machine and with emptying the Caches - these step either make no difference to the composition having the Blocks on the same frame after re-opening the project or move the blocks to other frames with differently positioned blocks/lines.

Has anyone had any experience with such things? Thank you for your time and help - much appreciated you uber-cats of the digital world! :)

(the lines in the below example do not appear the entire width of the frame because of a matte created around the subject before the subject/greenscreen matte is applied)

8115_screenshot20141021at4.50.57pm.jpg.zip

8116_screenshot20141021at4.51.12pm.jpg.zip


Return to posts index

Walter SoykaRe: Horizontal blocks/lines appear in random frames.
by on Oct 21, 2014 at 5:57:34 pm

You mentioned Premiere. Have you tried Premiere's Ultra Key? It's really quite good, and much faster than you'll be used to keying in Ae.

It would probably be most helpful if you could post a (redacted) frame that's giving you trouble, including the original green screen, so we can follow along at home.

Are you seeing this on truly random frames, as in which frames are affected can change, or is it always on the same frames?

Walter Soyka
Designer & Mad Scientist at Keen Live [link]
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
@keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]


Return to posts index

Aaron J. MarchRe: Horizontal blocks/lines appear in random frames.
by on Oct 22, 2014 at 12:20:31 pm

Hi Walter, thank you for your reply.

We have not tried using Ultra Key. The current workflow has been used with the same system (on the machine) for 9 months of or so, with great success - the current issue has been happening for the last 4 weeks - although intermittently - that is to say some projects have had these artefacts, some have not.

BY 'redactive' I assume you mean a still from the final render? - I will post tomorrow when I get to the studio again.

The lines which appear and are exposing the greenscreen (which is grey, due to the workflow) are happening on truly random frames - with the odd occasion where they appear on the same frame after adjusting various parameters (as described in the initial post) - but mostly it appears on truly random frames.

Thank you again for your reply, I will post redactive frames tomorrow, althought the frames I have posted are redactive except the slide behind is removed showing only the alpha channel.

Best Regards,

Aaron


Return to posts index


Walter SoykaRe: Horizontal blocks/lines appear in random frames.
by on Oct 22, 2014 at 2:35:23 pm

[Aaron J. March] "We have not tried using Ultra Key. The current workflow has been used with the same system (on the machine) for 9 months of or so, with great success"

You should give it a spin -- there's a good chance that it will give you comparable results with a lot less time and effort.


[Aaron J. March] "BY 'redactive' I assume you mean a still from the final render? - I will post tomorrow when I get to the studio again."

Sorry, I meant an original frame, pre-key, with the face blurred for otherwise masked out for privacy.

You have a lot of steps in your workflow. I think it'd be enormously helpful for you to step through it when you see one of these glitches to determine where it is being introduced.

Can I suggest using almost any codec other than Apple Intermediate Codec? AIC uses 4:2:0 chroma subsampling and is thus a nightmare to key from. You'd be a lot better off recording ProRes 422.

Walter Soyka
Designer & Mad Scientist at Keen Live [link]
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
@keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]