ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Stroke on text, with overlapping letters

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Tom Shanan
Stroke on text, with overlapping letters
on Sep 3, 2014 at 5:28:01 am

So I've been trying to add a stroke effect on a bunch of text, but the font I need to use has intersecting letters (like handwriting, or script)

So when I apply stroke on the layer, which is broken down to individual letters, I get overlapping stroke, instead of a single flowing stroke:

it should look like this:




But it comes out like this:




Can anyone come up with a solution for this so I can apply it to a different bodies of text?
(I rather not do it through Photoshop, where the solution is easy)

Thank you!


Return to posts index

Joey McNamara
Re: Stroke on text, with overlapping letters
on Sep 3, 2014 at 9:41:43 am

Hmm... Just had a quick go to see if I can figure anything out and I could get what you wanted, but I've not figured out how to get the counters (inside the e and g) to be visible. I was working from a text layer that wasn't split up into different layers, but I'm guessing it'd still work.
Try using auto trace on your text (select your text and Layer>Auto Trace), then add an outline to the image by (Effect>Generate>Stroke), then from effect controls modify the brush size and colour, then change paint style to On Transparent.



Again, I couldn't get the counters to show up, but it's part of the way there,


Return to posts index

Paul Esteves
Re: Stroke on text, with overlapping letters
on Sep 3, 2014 at 12:39:21 pm

If I understand correctly, a possible solution (pretty sure not the best solution) would be to try this.

Stroke your text with whatever colour you want and have the fill be either white or black. Set the stroke to "All fills over strokes." Then use "extract" in effects to remove the white or black fill.

Or instead of using the "extract" effect. You can duplicate your text layer and set the bottom layer to Luma inverted.

I think that achieves the goal?


Return to posts index


Shumi cps
Re: Stroke on text, with overlapping letters
on Sep 4, 2014 at 9:07:22 am

Thanks me also was searching for the solution.Got it.


Return to posts index

William Scholik
Re: Stroke on text, with overlapping letters
on Sep 3, 2014 at 3:37:12 pm

In the character window you can select all fills over strokes and should get the result you're looking for.

“We cannot solve our problems with the same thinking we used when we created them.”
― Albert Einstein


Return to posts index

Kevin Camp
Re: Stroke on text, with overlapping letters
on Sep 3, 2014 at 8:57:37 pm

instead of using stroke from the character palette, select the text layer and choose layer>layer style>stroke.

then twirl down the text layer properties to layer styles>advanced blending and set the fill opacity to 0.

set the layer style>stroke settings as needed.

Kevin Camp
Art Director
KCPQ, KZJO & KRCW


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]