ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

composited render never looks like beauty render

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
roy achkarcomposited render never looks like beauty render
by on Jul 8, 2014 at 12:33:39 am

I simply want my composited render to look exactly like my beauty render but when overlaying the 2 final pictures on top of each other in After Effects, there is always a slight difference. As for my composited layers, it’s super simple consisting of one scene render of my foreground 3D objects with mia_sky “use background” checked ON and no texture plugged so the backgrounds is pure black and another render of my mia_sky background with all the rest hidden. I have “pre-multiply” checked on in the render globals and when importing to After Effects I check “premultiplied with black” in the import footage settings. I don’t understand why I don’t get the exact same result as my beauty render. What am I doing wrong?

Here is a link to the project so if you check the EXR renders in the image folder, and composite them you should see the difference. I also attache an After Effects projects in the same folder where comp1 shows the difference between the 2 results (comp2 is the background and foreground combined together):

http://www.filefactory.com/file/667...ition_issue.rar


Return to posts index

Walter SoykaRe: composited render never looks like beauty render
by on Jul 8, 2014 at 12:14:32 pm

Your link above does not work.

Walter Soyka
Designer & Mad Scientist at Keen Live [link]
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
@keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]


Return to posts index

roy achkarRe: composited render never looks like beauty render
by on Jul 9, 2014 at 12:19:47 am

sorry about that, here is a new link:
http://www.filefactory.com/file/48girh3u9n7j/2014_sample_issue.rar


Return to posts index


Walter SoykaRe: composited render never looks like beauty render
by on Jul 9, 2014 at 3:40:03 pm

[roy achkar] "I have “pre-multiply” checked on in the render globals and when importing to After Effects I check “premultiplied with black” in the import footage settings. I don’t understand why I don’t get the exact same result as my beauty render. What am I doing wrong?"

The rendered foreground element provided actually has straight alpha.

Walter Soyka
Designer & Mad Scientist at Keen Live [link]
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
@keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]


Return to posts index

roy achkarRe: composited render never looks like beauty render
by on Jul 10, 2014 at 1:43:47 am

that can be the case, because when rendering the image out of maya, i am checking the "premultiply" option. Any ideas?


Return to posts index

Walter SoykaRe: composited render never looks like beauty render
by on Jul 10, 2014 at 4:14:21 pm

[roy achkar] "that can be the case, because when rendering the image out of maya, i am checking the "premultiply" option. Any ideas?"

Yet, it is the case.

I am not a Maya user, so I can't help you on that end.

Look at your foreground EXR file -- in interpret settings, change the alpha interpretation to ignore. If it were premultiplied, the fully-transparent areas would be black. However, you see the background, indicating straight alpha.

Walter Soyka
Designer & Mad Scientist at Keen Live [link]
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
@keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]


Return to posts index


roy achkarRe: composited render never looks like beauty render
by on Jul 13, 2014 at 12:49:01 am

when I do this, the fully transparent pixels (so in my case the gray and blue area) show the background and not a black color. And its identical to the beauty render. Does this mean that maya is outputing a straight alpha and not pre-multiply?


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]