ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Composition won't show

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Egil Arntzen
Composition won't show
on Jun 26, 2014 at 1:41:17 pm

I have 2 comps. 1 main comp "gabba gabba" and a second comp "logo".
The "gabba" comp goes for 27 seconds where a camera is animated and so on.
In the "logo" comp, I have the more or less the same. A camera animated above some layers.

I put the "logo" comp on top of the layers in the main "gabba" comp, and it begins after 27 secs on the timeline. I preview and the first 27 secs are fine, but after 27 secs the "logo" comp doesn't show. And this what I don't understand…

I attached 2 photos showing my whole setup in AE, and also one that shows the frames I see, where I would like to see the graphics from the "logo" comp.





Return to posts index

George Goodman
Re: Composition won't show
on Jun 26, 2014 at 2:17:56 pm

try extending your camera in your gabba gabba comp and making sure that the logo comp is in the correct 3d position so the camera can see it.

"|_ (°_0) _|"

Sincerely,

George

http://www.vimeo.com/georgegoodman
http://www.linkedin.com/in/georgefranklingoodman


Return to posts index

Egil Arntzen
Re: Composition won't show
on Jun 26, 2014 at 2:37:42 pm

Thanks for answering!
But there is a camera in the "logo"-comp. That is why I end the camera in the gabba comp to let the other camera "take over". And If I am in the logo comp, everything looks fine (like you could see in the screen shot i attached in the first post.


Return to posts index


Michael Szalapski
Re: Composition won't show
on Jun 26, 2014 at 3:09:00 pm

What happens if you extend the camera layer underneath the logo layer?

What happens if the "collapse transformations" switch is turned off for the logo layer?

- The Great Szalam
(The 'Great' stands for 'Not So Great, in fact, Extremely Humble')

No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.


Return to posts index

Dave LaRonde
Re: Composition won't show
on Jun 26, 2014 at 3:10:42 pm

If I understand correctly, you want to have two cameras in this main comp. Sorry, but that's not going to work: AE can only have one active camera, and at the moment it's in the main comp.

Dave LaRonde
Promotion Producer
KGAN (CBS) & KFXA (Fox) Cedar Rapids, IA


Return to posts index

Walter Soyka
Re: Composition won't show
on Jun 26, 2014 at 3:26:44 pm

Looking at the times in the comps -- haven't all the layers in logo already ended by the time the comp layer starts in the gabba gabba comp?

Put another way, don't you want the logo comp's first frame to start at 27 seconds inside the gabba gabba comp?

Walter Soyka
Designer & Mad Scientist at Keen Live [link]
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
@keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]


Return to posts index


Egil Arntzen
Re: Composition won't show
on Jun 26, 2014 at 7:38:39 pm

Dave: I have one camera in the main comp. A 2 Node 50. I had two before, but removed it, so there is just one. See new screen shot.
In the "logo" comp I have a 2 Node 50 LHH. Is it not possible to have a different camera in the "sub-comp" (logo) that becomes the active camera when that comp starts playing?

Michael: Tried to switch of the "collapse transformation" for the logo-comp layer. No luck.

Walter: Yes I want the first frame of the logo-comp to start at 27 seconds. I went to the comp-settings in logo-comp and set it to start at 27 seconds. Still won't work unfortunately...





Return to posts index


Egil Arntzen
Re: Composition won't show
on Jun 26, 2014 at 7:58:46 pm

Walter! You were right. I had to go into the logo comp and move everything to 27 secs. So in other words, it didn't work to set the start timecode to 27 secs in the comp settings. Isn't that usually a way to do it?? Thought you should be able to set the animation to the first frame and put in the time in the time code (comp settings) and then it would start from there in the main comp?


Return to posts index

Dave LaRonde
Re: Composition won't show
on Jun 26, 2014 at 9:55:21 pm

In AE, there are two ways to do this:
In the nested comp, make the layers begin at :00 in time, and move the nested comp to start at 27-seconds.
Leave the beginning of the nested comp at :00 in time of the main comp, and move the layers of the nested comp to 27-sedconds.

Either way, the layers get moved to 27-seconds.

Dave LaRonde
Promotion Producer
KGAN (CBS) & KFXA (Fox) Cedar Rapids, IA


Return to posts index


Egil Arntzen
Re: Composition won't show
on Jun 26, 2014 at 10:48:08 pm

Thank you so much for your help! All of you.


Return to posts index

Walter Soyka
Re: Composition won't show
on Jun 26, 2014 at 10:56:44 pm

What Dave said.

For a little background, there is not just one "clock" in an Ae project; each comp has its own independent timeline. You can use a comp in another comp in Ae just like using a clip in an NLE; you can freely slide them in time.

Walter Soyka
Designer & Mad Scientist at Keen Live [link]
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
@keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]