ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Issues with Mocha tracking - Image in AE slightly off from planar surface in Mocha

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Eric McCarthy
Issues with Mocha tracking - Image in AE slightly off from planar surface in Mocha
on Apr 11, 2014 at 10:17:45 pm

Hi, and thanks for reading this. Before I describe the issue, let me mention that I have read most everything I can find from Imagineer Systems, and watched many YouTube tuts on this process so I am not coming to this "blind".
Here is the issue. I have successfully tracked the planar surface in Mocha and my surface holds as I want it to when scrubbing through the clip, however, when I export the tracking data and apply it to a separate clip in AE, I have a slightly offset result. The track that I am using as my corner pin is in a separate pre-comp, which is sized to mach original comp. I applied the tracking data to the pre-comp. and it is almost exact, but is off by a few pixels. Check the images below: you can see that these are both taken from Frame 13 in the track. The planar surface is built to be slightly larger than the green screen to allow for any drift. The image of the AE comp shows the pinned image above the green screen, however this is just to clearly show the problem, in the actual edit the pinned image would set below the keyed layer.

Mocha (notice the extra space around the screen in the planar surface):



AfterEffects (notice the green peeking through):



Any ideas?

Thanks in advance,

Eric McCarthy



Return to posts index

Eric McCarthy
Re: Issues with Mocha tracking - Image in AE slightly off from planar surface in Mocha
on Apr 11, 2014 at 11:06:40 pm

Doh!
I figured it out myself... In case anyone else is wondering, I was working with a clip that I had stabilized in AE using the Warp Stabilizer. When I activated "Track in Motion AE" I assumed that the same clip (stabilized version was going to "Dynamic Link" to the Mocha Project. This was NOT the case. Mocha grabbed the original clip, this was why the two were off. Once I exported my stabilized clip ad a ProRes, then brought it back into AE, then to Mocha AE, everything was purr-fect!
Thanks anyway Creative Herd.
Eric



Return to posts index

Dave LaRonde
Re: Issues with Mocha tracking - Image in AE slightly off from planar surface in Mocha
on Apr 11, 2014 at 11:19:40 pm

Glad you figured it out. If those two screen grabs are accurate, you also have an insight into the way Warp Stabilizer works: note the lack of hair on the subject on the second one.

Dave LaRonde
Promotion Producer
KGAN (CBS) & KFXA (Fox) Cedar Rapids, IA


Return to posts index


Bobby Yarsulik
Re: Issues with Mocha tracking - Image in AE slightly off from planar surface in Mocha
on Apr 16, 2014 at 9:02:35 pm

Slightly off topic, but at first I thought you were serious, and then I got the joke.

Literally laughed out loud.


Return to posts index

Eric McCarthy
Re: Issues with Mocha tracking - Image in AE slightly off from planar surface in Mocha
on Apr 17, 2014 at 12:12:25 am

At first it was a misunderstanding of the screen shot data - then I saw it was Dave (who has provided lots of help over the years) and I knew it was a "funny".



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]