ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

RAM/RENDER problem with AE and MacBook Pro

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
David EscurriolaRAM/RENDER problem with AE and MacBook Pro
by on Apr 2, 2014 at 1:44:33 pm

Hi everybody

My new MacBookPro is not working propertly. The Renderspeed slows down.
The normal render time used to be 4h, but now after several renders it takes 12h and is not jet finished!
My old MacPro (Early 2008, 16GB RAM) renders the sequence in 8h: no problems.
The renderspeed slows actually after 10-15 Minutes down.

I am producing a Art sequence: 41000 Frames (26 Minutes @ 30fps) with masks,
mash warps, plugins: revision re:flex warp and re:flex motion morph for morphing in
between faces.

My settings before I started to render:
Purged memory and emptied disk cache, cleaned database & cache,
(OFF) Multiprocessing
(ON) Reduce cache size when system is low on memory

Then I went to the "Secret Settings" and selected "Disable Layer Cache" and
Purge every 100 frames during make movie.

Device: MacBook 2.3 GHz Intel Core i7, 16 GB 1600MHz DDR3 RAM, Mac OS 10.9.2
System preferences: Energy saver:
(Never) Turn display off after...
(OFF) Put hard disks to sleep when possible
(ON) Prevent computer from sleeping when he display is off

What else can I check? I've been reading older posts about the same issue,
but I'm still struggling with it!

Thanks for your support

David





Return to posts index

Dave LaRondeRe: RAM/RENDER problem with AE and MacBook Pro
by on Apr 2, 2014 at 3:25:19 pm

It will be helpful to know the PRECISE version of AE you run, right down to the last decimal point. We only see 12.2. Same thing for the OS. The possibility exists that an update to either mitht help a lot.

I also see that you included a shot of processor activity. Are you really using all 8 processors to render?

Multiprocessing in AE has evolved into something of a crap shoot because there are a few effects that do NOT use it. As a start, I'd simply turn off multiprocessing and see what happens to render times. It's very easy to do, and doesn't involve massive changes to your machine.

Dave LaRonde
Promotion Producer
KGAN (CBS) & KFXA (Fox) Cedar Rapids, IA


Return to posts index

David EscurriolaRe: RAM/RENDER problem with AE and MacBook Pro
by on Apr 2, 2014 at 4:14:20 pm

Hi Dave

Thanks for your support. Yes, I'm running AFX 12.2 and OS X 10.9.2. Both are the newest one.
Multiprocessing is turned off.


Return to posts index


Walter SoykaRe: RAM/RENDER problem with AE and MacBook Pro
by on Apr 2, 2014 at 4:15:24 pm

[David Escurriola] "The renderspeed slows actually after 10-15 Minutes down."

Does it always slow down around the same frame in the render? Is there some effect coming in around that point in your timeline?



[David Escurriola] "My settings before I started to render:
Purged memory and emptied disk cache, cleaned database & cache,"


Don't do this. You should only empty the disk cache if you are seeing corrupt frames in your render. Otherwise, you are disabling a feature that can save you a lot of render time by reusing previously-rendered frames.



[David Escurriola] "(OFF) Multiprocessing"

With 16 GB of RAM in your system, I think you can turn multiprocessing ON -- just make sure you're leaving ample RAM for other apps (I'd start with 6 GB) and make sure that each instance of Ae has enough minimum RAM (I'd start with 3 GB per process). This will limit you to 3 CPUs max, but 3 is better than 1.


[David Escurriola] "Then I went to the "Secret Settings" and selected "Disable Layer Cache" and
Purge every 100 frames during make movie."


This was good advice pre-CS5 when Ae was 32-bit and was always running out of RAM. By disabling the layer cache and purging memory every 100 frames, you are preventing Ae from saving things in RAM, forcing it to recalculate more while rendering, and slowing yourself down.

[David Escurriola] "What else can I check?"

I'm not running Mavericks myself yet, but maybe you should turn off App Nap?

http://helpx.adobe.com/creative-cloud/kb/app-nap-reduces-application-perfor...

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index

David EscurriolaRe: RAM/RENDER problem with AE and MacBook Pro
by on Apr 2, 2014 at 5:03:19 pm

Hi Walter

Thanks for your support!

To your questions:

01. Is there some effect coming in around that point in your timeline?

No, the pre rendered Sequence ist ProRes422HQ and it is all the same. The content has no influence on the problem.

02. I agree, but for this long sequence of 26minutes, it doesn't seem to make a difference.

03. Multiprocessing: Either way with or without Multiprocessing, this problems appears. But I usually render without Multiprocessing. It doesn't seem to be trustworthy, in my opinion.

04. Secret Settings: The settings used to be by "1000" Frames at the beginning, but I reduce it yesterday to try something else. I will put it back to 1000 Frames.

05. Prevent "AppNap" is not turned on.

My question is still the same: Why is the render speed so slow newly?
One month ago, when I bought the MacBook it started to render the sequence within 4 hours. Later on the render speed started to decrease. I thought it was the external 2TB thunderbolt LaCie HD. But then I realised, that the problem persists even working with all the files on the local SSD HD.

Thanks for your help! ;)

Cheers

David


Return to posts index

Walter SoykaRe: RAM/RENDER problem with AE and MacBook Pro
by on Apr 2, 2014 at 5:29:29 pm

What format are you rendering to? Is it a QuickTime format? Does it make a difference if you render to a different format? For a project of your length, I'd suggest rendering to an image sequence.

RAM usage seems low. Your screenshot shows Ae only taking 1 GB out of 16. All the stuff you are doing in the Secret menu are techniques that sacrifice speed in order to conserve RAM and should be quite unnecessary here.


[David Escurriola] "03. Multiprocessing: Either way with or without Multiprocessing, this problems appears. But I usually render without Multiprocessing. It doesn't seem to be trustworthy, in my opinion."

Multiprocessing, more than anything else, is the thing that can improve your Ae render times. I don't always use MP for RAM previews, but I do all my final renders with MP.


[David Escurriola] "
05. Prevent "AppNap" is not turned on."


Try checking the box to prevent App Nap.

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index


Brian CharlesRe: RAM/RENDER problem with AE and MacBook Pro
by on Apr 2, 2014 at 6:34:24 pm

I note from the screen captures that the QT32 Server isn't responding, there's a long thread on this in the Adobe forum:

http://forums.adobe.com/thread/1360633



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]