ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Paths from AI not working right in AE ?

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Steve George
Paths from AI not working right in AE ?
on Mar 17, 2014 at 9:42:05 pm

I am struggling with importing paths from ai into ae.

The paths look right in ai ....




but when i paste them into ae i get this ....



As you can see the inner parts of the logo that should be transparent are present.

How can i solve this please ?

im using AI CS5 and AE CS5 on a mac


Return to posts index

Dave LaRonde
Re: Paths from AI not working right in AE ?
on Mar 17, 2014 at 11:23:18 pm

Highlight the layer in the timeline, hit m to reveal the masks, then play around with the various mask modes: add, subtract, intersect, etc.

Dave LaRonde
Promotion Producer
KGAN (CBS) & KFXA (Fox) Cedar Rapids, IA


Return to posts index

Steve George
Re: Paths from AI not working right in AE ?
on Mar 18, 2014 at 12:30:47 am

Thank you for your response Dave,

This worked, but i am presented with a new problem....

So i edited the masks until i had the logo exactly how i want it...


I then import the masks into element3d by setting the path layer to the logo. In element3d the new path outlines have not been recognised...


Im guessing i need to somehow flatten the masks after i edit them somehow ?

Thanks for your time.


Return to posts index


Joey Sperber
Re: Paths from AI not working right in AE ?
on Mar 18, 2014 at 1:30:27 am

Thanks this showed me were the folder was and I was able to change the permissions. All is working fine now.

Thanks,
Joey


Return to posts index


Steve George
Re: Paths from AI not working right in AE ?
on Mar 18, 2014 at 2:27:01 am
Last Edited By Steve George on Mar 18, 2014 at 5:55:49 pm

I'm confused by your reply Joey ?


Return to posts index

Mark Dizz
Re: Paths from AI not working right in AE ?
on Mar 18, 2014 at 11:15:18 pm

Do you have a link to your AI file?

Sometimes when you divide shapes in AI it makes more shapes than necessary. One shape may be the one you are looking for then the other shape may be the divided area. In essence you aren't seeing a hole in your work you are seeing 2 solids one being a positive shape the other being a negative shape.

If you have your file I could take a screengrab for you of what I mean. It is easier to find the pieces you don't need from Illustrator rather than scrolling through the many masks in AE IMO.


Return to posts index


George Goodman
Re: Paths from AI not working right in AE ?
on Mar 19, 2014 at 2:39:13 pm

Import the AI file to AE. Then convert to shape paths, you shouldn't be using solids.

Also, why are you bringing it into AE first? Can you just bring the AI file right into C4D?


"|_ (°_0) _|"

Sincerely,

George


Return to posts index

Mark Dizz
Re: Paths from AI not working right in AE ?
on Mar 19, 2014 at 6:27:14 pm

He is not using C4D, he is using Element 3D within After Effects.


Return to posts index

George Goodman
Re: Paths from AI not working right in AE ?
on Mar 19, 2014 at 7:51:30 pm

whoops, my b on the quick read.

You should still import the AI and convert it to shapes though.


"|_ (°_0) _|"

Sincerely,

George


Return to posts index


Steve George
Re: Paths from AI not working right in AE ?
on Mar 20, 2014 at 2:39:05 pm

Thank you for your help George.

I am new to AI & AE, It is my understanding that Element 3d only uses text or mask layers ?

How would i convert the ai path to a shape ?

Thanks


Return to posts index

George Goodman
Re: Paths from AI not working right in AE ?
on Mar 20, 2014 at 3:00:34 pm

I'm afraid I don't use element, so I can't speak to that. Looks like this is probably what you want to do though:



But for the record, all you'll have to do is drag the ai file into your timeline, right click it and click create shapes from vector layer.


"|_ (°_0) _|"

Sincerely,

George


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]