ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Masked object disappears when i add element 3D effect to it ....

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Steve George
Masked object disappears when i add element 3D effect to it ....
on Mar 5, 2014 at 2:57:53 am
Last Edited By Steve George on Mar 5, 2014 at 3:02:19 am

I'm relatively new to using after effects i am having a problem that i really can't get my head around.

1: I Import an EPS and use ray trace to separate the black background from my white logo, making sure i set the ray traced logo outline to a new layer.

2: With the new ray traced layer selected my logo is visible, i apply effect > element 3d to the layer and the text disappears (i will come back to this)

3: I go into element 3d, apply my bevel and material settings, click ok to take me back into after effects to find the logo is there, but very small and squashed ...



I have followed many tutorials and can't understand why this isn't working ?

I am using after effects CS5 on a Mac


Return to posts index

Walter Soyka
Re: Masked object disappears when i add element 3D effect to it ....
on Mar 5, 2014 at 11:21:23 am

[Steve George] "1: I Import an EPS and use ray trace to separate the black background from my white logo, making sure i set the ray traced logo outline to a new layer."

Do you mean auto-trace? Ray-tracing and auto tracing are very different.


[Steve George] "2: With the new ray traced layer selected my logo is visible, i apply effect > element 3d to the layer and the text disappears (i will come back to this)"

Element is meant to be applied to its own comp-sized solid. It has tools for referring to other layers.


[Steve George] "3: I go into element 3d, apply my bevel and material settings, click ok to take me back into after effects to find the logo is there, but very small and squashed ... "

See my response to 2. It is small and squished because the layer it is applied to is not comp-sized.

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index

Steve George
Re: Masked object disappears when i add element 3D effect to it ....
on Mar 5, 2014 at 12:37:16 pm

Thank you for your reply walter.

I did actually mean auto trace, not ray trace, sorry my mind was not focussing i guess.

I'm still have a problem with size after i apply element 3d to the solid layer.



No matter how big an image i drag onto a layer when i add bevel and texture in element 3d when i click ok it's still less than half the size when it comes out of element ?

As you will see in the pic above i made a solid layer (same size as comp) and applied element 3d to it.
I then imported a png that was 6000 pixels wide (my project is 1280 pixels wide).
The logo is way too big for the screen in this case but i purposely left it too big to see if size is an issue.
I then auto traced the logo, set the auto trace to a new layer and applied that layer into element 3d.
I then added a material and bevel, clicked ok.

Is it normal for images to come out of element so small ? when i scale the image up to fit the screen it doesn't look good ?

You (walter) mentioned about being comp size in your previous reply. Is there a way i can import my logo as comp size ?

Sorry i know i'm missing something here :-(


Return to posts index


Walter Soyka
Re: Masked object disappears when i add element 3D effect to it ....
on Mar 5, 2014 at 1:30:30 pm

Element should not be applied to a layer with stuff on it. Create a new solid layer, at comp size, and apply Element to that. Then, under Element > Custom Layers > Custom Text and Masks, point Element to the layer(s) with the masks you want to use.

This should be well-covered in Andrew Kramer's tutorials (really more of a video manual) for Element.

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index

Steve George
Re: Masked object disappears when i add element 3D effect to it ....
on Mar 5, 2014 at 1:40:10 pm

That is exactly what i did Walter, I watched all of his tutorials.

Here's what i did step by step

1, New solid layer
2, add element 3d to it
3, Import My logo, i have tried with PNG & EPS types
4, Drag my logo into the preview window to put that on a new layer
5, Auto trace the logo to convert the image into a mask, make a new layer from the mask (i also tried with not making a new layer)
6, In the settings for element go to custom layers etc, just like you suggested.
7, In element apply bevel, textures etc, then click ok

Then i get what you see in my screen shot every time. A very small logo in the middle of the page.

I must be missing something very small or not viewing something correctly ?


Return to posts index

Walter Soyka
Re: Masked object disappears when i add element 3D effect to it ....
on Mar 5, 2014 at 1:55:22 pm

In your screenshot, you do not have a comp-sized layer for Element. Element is applied to the layer generated by auto-trace, which the layer handles show is less than comp-sized.

If you are doing something else that you need help with, please upload an updated screenshot so I can see what you are seeing.

If you've correctly done the comp-sized layer for Element and the logo is simply coming in small, you can adjust the height in its group's Particle Look. For example, Element > Group 1 > Particle Look > Size

Mettle ShapeShifter is a different plugin that can work directly on shape layers, extruding and lighting them and responding to the comp camera.

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index


Steve George
Re: Masked object disappears when i add element 3D effect to it ....
on Mar 5, 2014 at 2:20:43 pm

"Element is applied to the layer generated by auto-trace, which the layer handles show is less than comp-sized."

How do i set the auto traced layer to be comp sized ?

"If you've correctly done the comp-sized layer for Element and the logo is simply coming in small, you can adjust the height in its group's Particle Look. For example, Element > Group 1 > Particle Look > Size"

This will distort the quality though, right ?


Thanks for your help Walter


Return to posts index

Walter Soyka
Re: Masked object disappears when i add element 3D effect to it ....
on Mar 5, 2014 at 2:26:18 pm

[Steve George] "How do i set the auto traced layer to be comp sized ? "

You do not. Do not apply Element to the auto trace layer. Create a separate solid, with no masks, at comp size.

The size of the layer does not matter. Element is looking at the mask data, not the pixel data.


[Steve George] "This will distort the quality though, right ? "

No. Scaling the Element layer itself will reduce quality, but telling Element to scale the group's particle will not. Element is working internally with geometry very similar to vectors, not pixels, for operations like these.

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index

Steve George
Re: Masked object disappears when i add element 3D effect to it ....
on Mar 5, 2014 at 2:41:44 pm

"You do not. Do not apply Element to the auto trace layer."

How do i import my auto traced layer into element then ?


"Create a separate solid, with no masks, at comp size."

How do i do this ?

Like i said i am relatively new to using after effects though i have watched all of the essential training on lynda.com this is not covered.

Could you possibly give me a step by step rundown on how to get my logo into element 3d so when i click ok it is at comp size ? or modify my existing steps please ?

1, new solid layer
2, apply element 3d to it
3, import my logo
4, drag it into the preview window
5, auto trace it (to remove the black background)
6, set create new auto traced layer
7, import that auto traced layer into element 3d
8, add bevel and click ok

Please bare with me, thank you so much for your help


Return to posts index


Walter Soyka
Re: Masked object disappears when i add element 3D effect to it ....
on Mar 5, 2014 at 3:24:47 pm

[Steve George] "How do i import my auto traced layer into element then ? "

You select the layer with the mask(s) on it in Element's "Custom Layers" control group as I said above.



[Steve George] "How do i do this ? [create a comp-sized solid]"

Step by step:

Press Ctrl+Y (PC) or Cmd+Y (Mac) to create a new solid. Click the "Make Comp Size" button. Click OK. Apply Element to this layer.

Twirl open the Custom Layers group under Element in the effects control panel. Twirl open the Custom Text and Masks group. For Path Layer 1, click the layer selector drop-down and choose the layer that has the mask(s) you want to use in Element. Repeat as necessary.

Twirl open Scene Interface, then click the Scene Setup button. Click "Extrude" to create an Extrusion Model and apply a bevel; this model will automatically refer to Path Layer 1. Repeat/change as necessary.

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index

Steve George
Re: Masked object disappears when i add element 3D effect to it ....
on Mar 5, 2014 at 3:35:55 pm

I Don't want to sound like i'm ungrateful for your help (honestly) but this is not a step by step guide.

After i have created a solid and added element 3d to it how can i choose a masked layer that i haven't made yet ?

Please can you give me a step by step guide, so i can follow it please, or just modify the steps i already made above.

Thanks again


Steve


Return to posts index

Walter Soyka
Re: Masked object disappears when i add element 3D effect to it ....
on Mar 5, 2014 at 3:46:32 pm

[Steve George] "After i have created a solid and added element 3d to it how can i choose a masked layer that i haven't made yet ? Please can you give me a step by step guide, so i can follow it please, or just modify the steps i already made above."

Well, obviously you have to make the masked layer before you can refer to it. I was assuming you already had those as shown in your screenshot.

Import your footage. Put it in your 1280x720 composition. Auto-trace it. Then pick up from where you left off in the steps above.

If you're new to After Effects, I'd recommend the following link, in which Adobe's Todd Kopriva pulls together some important introductory materials:
http://blogs.adobe.com/toddkopriva/2010/01/getting-started-with-after-eff.h...

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index


Ridley Walker
Re: Masked object disappears when i add element 3D effect to it ....
on Mar 5, 2014 at 4:17:26 pm

Perhaps this will clarify the process. Walter, you have the patience of Job...

E3D Demo



Return to posts index

Steve George
Re: Masked object disappears when i add element 3D effect to it ....
on Mar 5, 2014 at 4:50:57 pm

Thank you so much for this ridley,

These are the exact steps i have taken every time, the only difference being that when i click ok after leaving element 3d my image is small (half the project size) and yours was large, bigger than the screen.

My initial question was why is my design coming out of element very small when its very big when i put it in there ?

Your logo was pretty small when you put it into element but was twice as big when it came out, this is the opposite of what is happening to me.

When i enlarge my rendered image to fit the screen there is some loss of quality, i was asking how to avoid this ?

Thanks


Return to posts index

Walter Soyka
Re: Masked object disappears when i add element 3D effect to it ....
on Mar 5, 2014 at 5:25:31 pm

[Steve George] "When i enlarge my rendered image to fit the screen there is some loss of quality, i was asking how to avoid this ? "

How are you doing this?

If you are doing this by scaling the Element layer, don't do that. Use the particle look size as I described above.

If you are doing this by adjusting the particle size and still looks gross, that's probably because the auto-traced paths themselves are gross, possibly because the source image is gross (undersized), and you just can't see it when the source is smaller.

Vectorization of a still image is hard. If you have this as an Illustrator source, you should really consider the path workflow I mentioned above -- or at least exporting a higher-resolution image to give auto-trace a fighting chance.

There are also numerous options you can adjust in auto-trace that controls how the path-fitting works. The defaults may not be appropriate for your source. You can get a sense of how these controls work by ticking the "Preview" box in the auto trace dialog box and tweaking them.

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index


Steve George
Re: Masked object disappears when i add element 3D effect to it ....
on Mar 5, 2014 at 5:31:51 pm

Thanks for the great advice guys. I have been playing with the settings you mentioned and have found a comfortable level of quality now.

This forum rules :-)

Stevie


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]