ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

Converting between AE & Premiere speed ramps

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Navarro ParkerConverting between AE & Premiere speed ramps
by on Oct 25, 2013 at 9:55:49 pm

So After Effects Time Stretch works on a scale that seems to be the complete opposite of Premiere's Speed/Duration. In AE, a Time Stretch of 50% plays back twice as fast. While a Premiere Speed of 50% plays it back twice as slow. (So AE 50% = PP 200%)

Is there an easy formula to convert between the two? For example, I have a pre-rendered Premiere clip that is sped up 156%. What would be the time stretch value in AE to get the clip back to 100%?

Return to posts index

Erik WaluskaRe: Converting between AE & Premiere speed ramps
by on Oct 26, 2013 at 1:14:56 am

I think this will work:

Divide 100% by the Premiere speed factor to get the stretch % for AE.

So if your Premiere speed factor is 200% then it would be like this:


So you would enter a stretch value of 50% in AE.

100/156=.64 (rounded off)

Stretch factor in AE of 64%

The problem you may run into is that I believe there will be frames missing when you stretch the clip out again.

Erik Waluska

Return to posts index

Nate McLeanRe: Converting between AE & Premiere speed ramps
by on Nov 20, 2015 at 5:16:55 am

I have a similar debilitating problem, yet opposite directions. I speed ramp my GH4 96fps footage in PR to 1000 percent all the time. When I send an entire timeline (with multiple ramped clips involved) to After Effects via dynamic link "replacement" I occasionally get a clip in AE that blacks out. Meaning my AE clip will run black when there should be more frames of the clip I had in Premiere. I am totally lost in how to solve this one, and it is putting my business at a halt. I Check my premiere clips for extra key frames that aren't being used and delete them in case it would be in the way, but still, the problem occurs, and it seems to be at random. I am desperate for help. I am on a PC platform. I highlight all the clips in my premiere timeline and right click to replace with after effects. Straight from there, I render the selection in after effects to find the issue present.

Thank you!!

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved