ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Light Shadow Disabled on Comp with Mask

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Jason Schoenfeld
Light Shadow Disabled on Comp with Mask
on Oct 12, 2013 at 8:12:26 pm

So, I have a basic comp with:

Light
3D text layer
3D solid (multiply mode)
Background solid

The 3D text layer casts a shadow on a 3D solid that's been rotated to act as the ground. Everything works fine. But, if I change the Text layer into a comp and then add a mask - the comp no longer casts a shadow. If I remove the mask or change the mode to "none" the shadow returns. Been trying to figure this out for about an hour and can't get it to work. Any help is appreciated.


Return to posts index

Erik Waluska
Re: Light Shadow Disabled on Comp with Mask
on Oct 12, 2013 at 9:04:05 pm

I'm not sure exactly why the mask kills the shadow, maybe someone else can answer that, but I can tell you that turning off the continuous rasterization switch OR masking the text inside of the pre-comp works.

Erik Waluska
EAWmedia


Return to posts index

Jason Schoenfeld
Re: Light Shadow Disabled on Comp with Mask
on Oct 12, 2013 at 9:12:44 pm

Thanks for the reply. I did try the continuous rasterize but it still doesn't display the shadow. The masking the text inside the comp does work, but I'll be adding to it and I need to make it so that I can mask the entire comp. Thanks again for the help.

Jason


Return to posts index



Erik Waluska
Re: Light Shadow Disabled on Comp with Mask
on Oct 12, 2013 at 9:18:00 pm

Strange, it's working here. If you turn off continuous rasterization on the pre-comp, then the pre-comp will need to have its 3D switch enabled and "casts shadows" option turned on.

Erik Waluska
EAWmedia


Return to posts index

Jason Schoenfeld
Re: Light Shadow Disabled on Comp with Mask
on Oct 12, 2013 at 9:55:16 pm

That was it. Before I couldn't find a material options (not sure if I had missed the 3D box and left it unchecked. Anyways, turned on cast shadows and it's working. Thanks.


Return to posts index

Jason Schoenfeld
Re: Light Shadow Disabled on Comp with Mask
on Oct 12, 2013 at 10:04:03 pm

On another note - not sure why, but after making the comp 3D I actually had to switch off continuous rasterize to get the material options.


Return to posts index


Erik Waluska
Re: Light Shadow Disabled on Comp with Mask
on Oct 12, 2013 at 10:44:34 pm

Cool, glad you got it working.
If the continuous rasterization (actually collapse transformations in this case) switch is turned on then the comp uses the material settings from the layers within the comp rather than from the comp itself. So that's why they're not available with the switch turned on.

Erik Waluska
EAWmedia


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]