ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

3D Track Matte problem

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Patrick Murphy
3D Track Matte problem
on Oct 4, 2013 at 6:51:34 am

Hi,

I'm having a problem where I lose my track matte when I switch it to 3D. It's only happening on certain layers underneath another track matte (call it track matte A). Track Matte A works when the 3D mode is on and off. But the others only work when 3D mode is off.

I've searched around for similar problems but couldn't find any.

Any help is much appreciated! Thanks.





Return to posts index

Anders Hattne
Re: 3D Track Matte problem
on Oct 4, 2013 at 10:56:04 am

How Curious!
Are the layers correctly placed in 3d space?

If nothing else, a work around would be to pre-compose the needle with its track matte and link the nested animations with expressions. That way you only have to take care of one layer in 3d space..

http://www.ardillamedia.com


Return to posts index

Patrick Murphy
Re: 3D Track Matte problem
on Oct 4, 2013 at 10:35:13 pm

They seem to be all lined up correctly. I tried shifting them back and forth on the z-axis and rearranging layers, but still didn't work.

Your work around fixed the problem, so thanks a bunch!

Only thing, those meters were parented to another layer and now the precomp isn't lining up correctly when the parented layer moves. Also the precomp needs to have "continuous rasterize" on and that seems to mess up it's position when I turn that on and off.

But now I know, when in doubt, precomp.


Return to posts index


Anders Hattne
Re: 3D Track Matte problem
on Oct 5, 2013 at 8:48:15 am

http://forums.creativecow.net/thread/227/17874

In this post Dan Ebberts helped me out with the position of a precomped object. I don't understand how he understood my question but his answer works! ..although that one might be tricky too:

L1 = comp("Crane").layer("Hook");
P = L1.toWorld(L1.anchorPoint);
L2 = thisComp.layer("Crane");
L2.toWorld(P);

crane would be the precomped layer, hook the object therein.
I'm still struggling, but it works!

http://www.ardillamedia.com


Return to posts index

Patrick Murphy
Re: 3D Track Matte problem
on Oct 5, 2013 at 8:33:36 pm

Cool! Thanks for all the help, you rock!


Return to posts index

James Lee
Re: 3D Track Matte problem
on Oct 9, 2013 at 2:00:29 am

You might be have Fast Previews set to "Fast Draft". I can see that it is set to something in your image.
If you set it to "Off (Final Quality)" or "Adaptive" your comp may look as expected.
I suffered a similar problem with track mattes on a 3d layer and found another user on this forum that said the problem fixed itself in the final render, then I tried my comp as a final render and my objects appeared in the right order. So then I had a light bulb go off in my head and tried the setting above and it fixed my problem.


Return to posts index


Johannes Danielsen
Re: 3D Track Matte problem
on Sep 29, 2014 at 10:32:45 pm

Didn't take time to read all the answers, but if you turn off raytrace and choose classic rendering in your advanced comp settings, then it will appear again.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]