ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Time remapping stop motion effect bug

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Cesar Siena
Time remapping stop motion effect bug
on Sep 29, 2013 at 8:21:18 pm

Hello! My time remapped layer isn't following the exact numbers (corresponding to layers) typed.

Description of the situation and settings:
1) There are 8 different head layers (the same head shot in 8 different positions) that, when sequenced (ie, like stop motion), give the illusion of a head rotating in y axis. These 8 layers are in a pre-comp of 8 frames duration. Each layer has 1 frame duration and was sequenced (keyframe assistant - sequence layers). This small comp was put in the main comp - enable time remapping - deleted last keyframe - turn first keyframe hold. The layer was stretched along the entire main comp timeline. Now, when time remap 8 values (0-7) are changed in hold position, the corresponding head appears. Basic, ok?

2) A null was created in the main comp - add expression controller (slider) - range of the slider 0-7 - Pickwhip time remap of the previous layer to this slider. The slider generates hold keyframes as well. Now, the previous time remap property can be controlled by the slider. Basic, ok?


Description of the problem:

Along the animation, heads layers are changed through the slider, "rotating" the head as expected. BUT, at some point of the animation, it looses its control over the situation. In a given sequence during the same animation, although heads numbers (sequence) are 2, 3, 4, 5 (for example) in usual hold keyframes (spaced by 2 or 3 keyframes), the program mess all up, interpreting other heads numbers. When you pass the CTI over this sequence, the heads keep changing, although the hold keyframes are still there. RAM previewing doesn't change it. The head rotation continues messed up, not corresponding to the natural head movement expected, like if several other heads (or time remapped numbers, layers) were there in the middle.
Is this a bug? Does someone have experienced this? Does it have a solution?
I believe in the bug theory because in the same timeline, other sequences of hold keyframes from the same expression controller are perfectly interpreted (work well). I also experienced the same problem in one other project with a sequence of mouths time remapped the same way. In some points it's messed up; in others, it works well.

What I tried to do, BUT IT DIDN'T WORK:
1) Turning the expression controller keyframes to linear and the original time remapp layer keyframes to hold.
2) Turning the expression controller keyframes to hold and the original time remapp layer keyframes to linear.
3) Turning all of them to linear and, in the time remapp expression line, dividing everything by 25 (the number of frames/second of the comp). This trick is in Dan Gies lessons of rigging puppets, but also, as any other action done, didn't fix the problem.
4) Cache was deleted, Ae re-started, re-installed, but nothing changes.

All comps are 25 frames/sec. I have some considerable experience in rigging puppets in CS6, but don't know how to solve this issue. Someone? Thank you!

P.S.: George Griffin had already a similar problem, described at:
http://forums.creativecow.net/archivethread/2/238097#238097
http://www.asadesigner.com/29-adobe-after-effects/0d2ed91d325bc554.htm


Return to posts index

Dave LaRonde
Re: Time remapping stop motion effect bug
on Sep 30, 2013 at 7:39:01 pm

First question: is your version of AE fully updated? I assume it's still CS6.

Dave LaRonde
Former Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Cesar Siena
Re: Time remapping stop motion effect bug
on Sep 30, 2013 at 10:04:31 pm

Yes, Dave, it is! (CS6 updated)


Return to posts index


Cassius Marques
Re: Time remapping stop motion effect bug
on Oct 1, 2013 at 11:53:28 am

Do you have exactly round numbers on those keyframes? Does the curve viewer shows any indication of change between 2 hold keyframes?

From everything you said, it has to be some(sort of) bug. I can't think of anything else and never experienced anything like that.


Return to posts index

Cesar Siena
Re: Time remapping stop motion effect bug
on Oct 1, 2013 at 3:33:11 pm

No, the numbers on the time remap property do not change, although the head changes very fast in the RAM preview or in the final render.


Return to posts index

Darby Edelen
Re: Time remapping stop motion effect bug
on Oct 1, 2013 at 11:24:27 pm

I didn't see you cover this in your post so I'll mention it here.

The slider values going from 0-7 will be interpreted by Time Remapping as 0-7 seconds instead of frames if they are passed directly. This occurs regardless of how you view your timecode.

To convert 0-7 into frames you'll need to use the framesToTime(); function like this:

f = effect("Frame Number")("Slider");
framesToTime(f);


Darby Edelen


Return to posts index


Cesar Siena
Re: Time remapping stop motion effect bug
on Oct 2, 2013 at 1:47:45 am

Hi Darby, thank you for mentioning this expression! If you allow me, there are some considerations about this topic:

1) In the first post, I've mentioned that I used the Dan Gies' trick of letting the keyframes as linear and dividing the slider value by the number of frames/second of the comp, trick that avoids (and replaces) this elegant expression mentioned by you, also turning seconds of the slider to frames. It works for him, but didn't work for me, in this specific case.

2) I've been doing this for some time now and rigged a lot of other puppets simply by turning the keyframes hold. Instead of sliding the values of the controller, I click on the value and type whole numbers. In other projects, it worked, mirroring the slider value to the time remapp property. It's like not having the slider controller, only the time remapped stretched layer, and typing over the time remapp property whole numbers. But it didn't work in this specific case.

It's why I think that this is a bug (maybe a rare one, because only 3 other guys mentioned it in the net). It only happens when there's a lot of keyframing in the time remapp line and only happens in some periods of it.

But thank you again for the elegant expression! I'll keep it!


Return to posts index

Bruna Skrzypek Badalotti
Re: Time remapping stop motion effect bug
on Jun 9, 2014 at 10:59:44 am

Hi Cesar, were you able to fix this bug?
I am having the same problem as you are, and I realized that when I duplicated the layer, the time remapping started to work fine again, but as soon as I disabled the duplicated one or deleted it or even turned to 0 its opacity, the bug was back. I don't know what I can do to fix it


Return to posts index

Cesar Siena
Re: Time remapping stop motion effect bug
on Jun 9, 2014 at 10:55:07 pm

Hi Bruna! Unfortunately, I still didn't find a solution. It seems that only a few have this problem. One suggestion is giving up the time remapping in this particular case, replacing it by several checkbox opacity controllers. If you want the layer to appear, click the checkbox and unclick the others. It's a fast process, simpler than the previous one. The only issue is the bigger number of controllers in your panel. I hope this is useful!


Return to posts index


Bruna Skrzypek Badalotti
Re: Time remapping stop motion effect bug
on Jun 9, 2014 at 11:46:41 pm

Thanks Cesar, it turned out that when I opened the same file in another computer it worked fine, so I guess maybe it is something about mine (the other one is a better machine, with more ram, etc)
:D


Return to posts index

Dennis Rockhill
Re: Time remapping stop motion effect bug
on Jun 12, 2014 at 10:27:13 am

I have been experiencing what seems like that same issue. I can certainly believe it's my computer, but it would be nice to figure out what is actually the problem with my computer - as this was not a problem earlier... But If I have to explain to my wife that a new computer is needed, this may be good back-up for me =)

Here are some further details on the issue (I'm simplifying a bit for ease of explaining - I'm somewhat of a newbie):
1. I have 3 different views set up in a time remap sequence - Position A, B and C - (mouth positions for a speaking character).
2. I use time remapping to make my character's mouth move w the words. It looks "perfect". Save and close.
3. Open - now when I review my work the mouth positions look like ACC rather than the original ABC.
4. If I just move the timer along the time remap position B now looks like position C. However, if I just change the opacity of position B to 99% instead of 100% - it switches back to looking correct (position B)
5. OK - well it's a band aid, but it works, right? Save and close.
6. Nope - open and it's the same issue repeating itself. Same band aid applied (changing position B's opacity back to 100% seems to fix it again - the % doesn't seem to matter). Save and close...
7. Overall - the behavior of this issue doesn't seem completely consistent. It may change without saving or closing. I see it change in the middle of a RAM preview sometimes.

I wonder if other folks that are seeing this issue are running an older machine that doesn't have much RAM. I'm maxed at 4GB on my laptop (again, a newbie...) Any thoughts from smarter and more experience users?


Return to posts index

Cesar Siena
Re: Time remapping stop motion effect bug
on Jun 14, 2014 at 6:41:51 pm

I agree, it isn't consistent and more and more people are reporting this problem, which could receive some attention from Adobe, because it's such a useful tool. The RAM, though, doesn't matter. I have plenty of RAM and the problem is the same. A friend suggested cleaning the cache everytime it happens; it works for her, but not for me. Why don't you give it a try?


Return to posts index


Dennis Rockhill
Re: Time remapping stop motion effect bug
on Jun 15, 2014 at 2:11:55 pm

Thanks, Cesar - I'll give it a try and report back.


Return to posts index

Isabelle Joosen
Re: Time remapping stop motion effect bug
on Oct 23, 2014 at 12:39:40 pm

Hi,

A simple workaround that seems to fix the problem is this:
Add a new null object. Copy the slider-effect animation from the layer that seems to generate the bug.
Delete that layer. Relink your expressions. This should fix the problem.
Still a mystery though what seems to generate the problem...


Return to posts index

Cesar Siena
Re: Time remapping stop motion effect bug
on Nov 1, 2014 at 4:21:46 pm

Hi, Isabelle, thanks for the reply. Unfortunately, I've tried this already (transferring to a null), but didn't work in my case. It's sort of a random bug, occurring in some systems but not in others. The number of the repliers of this thread shows that this is a growing problem in after effects, although infrequent.


Return to posts index


Christoph Müller
Re: Time remapping stop motion effect bug
on Nov 13, 2014 at 6:46:47 pm

I have the same problem and just posted a new thread (which I shouldn't have) but I didn't find this thread earlier. I use CC2014 with the latest update and I have this problem from the beginning. It doesn't matter how many keyframes I use it just randomly takes whatever position of the blink composition I refer too. It does this with every puppet I create. Very weird, because I am following the steps exactly as seen in Digital Tutorials or others on Youtube. I thought it was a problem because the blinks and the expression were in another comp, but no, it doesn't matter either. :(


Return to posts index

Christoph Müller
Re: Time remapping stop motion effect bug
on Nov 13, 2014 at 8:32:35 pm

I just found two solutions to this problem:

1. Render your pre-comp out and import the MOV-file again. If you have your mouth shapes or blinks as a video file the problem does not happen.

2. In your pre-comp open the composition settings with cmd+k (on a Mac) or ctrl+k (I suppose on windows) and open the advance tab. Select 'Preserve Frame Rate when Nested'. Then purge All Memory & Disk Cache (from the Edit/Purge option in the menu). This even works with several layers from PS or AI or what ever you have done to your pre-comp.


I really don't know why, but both options have worked for me. Hopefully it works for someone else too.


Return to posts index

Cesar Siena
Re: Time remapping stop motion effect bug
on Nov 17, 2014 at 9:17:20 pm

Christoph, in my case, it's not feasible importing it as MOV file.
Purging the disk cache works only a few times, but not in others.
I didn't try yet the option of preserving the frame rate of nested comps, but I suspect that it solves only a few instances of the problem, because it has occurred also in projects where the entire puppet wasn't a nested comp, but the main comp.
Again, I think it seems a random problem and should deserve more attention from Adobe. I know that Ae isn't made specifically to animate puppets, but this is a exponential growing use, since the inverse kinematics eased by Duik Tools.
Thanks for the help, although the problem continues.


Return to posts index


Christoph Müller
Re: Time remapping stop motion effect bug
on Nov 17, 2014 at 9:23:58 pm

You should try (the 2. option). I applied it on all my present projects and it works since then without any issues. Also, how could you have a mouth or blink sequence without having it in a pre-comp?


Return to posts index

Cesar Siena
Re: Time remapping stop motion effect bug
on Nov 17, 2014 at 9:49:50 pm

. I understood now what you have said. There was a solution from others that was similar to yours; it teached dividing the frame rate of the comp for the number of frames per second of the main comp. I works for some people, but not for others. Using the expression framesToTime(f) also was one solution given.
. I will definitely try your option just for curiosity! But one thing that I'm doing in all projects since this bug appeared, is NOT using time remapping for blinks, mouth shapes or what ever, but using check boxes expression controllers instead. That is, instead of changing the numbers of the time remapped layer and having all the trouble to remember which layer each number means, I suggest simply clicking on the respective check box (ie., connected with the opacity*100 of each blink or mouth layer), while unclicking the previous check box.
. Each check box can have a representative name, easing the identification process of which layer they represent.
. I hope this tip is useful for others that were tired of time remapping problems in Ae.
. Thanks again for the help and for the new solution suggested!


Return to posts index

Adam Cohen
Re: Time remapping stop motion effect bug
on May 8, 2015 at 8:30:31 pm
Last Edited By Adam Cohen on May 8, 2015 at 8:32:18 pm

Christoph, THANK YOU for solution #2 - after a week of struggling with this problem, that worked!!! Can't tell you how grateful I am!


Return to posts index

Cesar Siena
Re: Time remapping stop motion effect bug
on Jan 10, 2017 at 8:45:53 pm

New: maybe one root/cause of this bug comes from "edit - preferences - sequence layers at -- /frames per second". In other words, there is a chance that many of us are creating comps like mouth or blink, clicking "keyframe assistant - sequence layers" and it sequences that layer with the pre-definitions in "preferences", not in the actual frame rate of our main comp. Thats why Christoph Müller's solution "preserve frame rate when nested" works in many cases. This seems pretty basic, but hasn't been pointed out in any other topic. This might be prevented in the future by Adobe, if "keyframe assistant - sequence layers" command asked for the frame rate wanted. This has been causing too much trouble around for some time now. I hope it dawns on some idea on understanding and on solving this issue. Best regards.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]