ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Black Halo After Precomping 3D Render Passes

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Ben WaflikBlack Halo After Precomping 3D Render Passes
by on Aug 31, 2013 at 6:40:04 pm

Hello! I think I don't understand the way Ae renders what I'm doing.
So I have some render passes from 3ds max with antialiased edge. When I'm stacking them onto a background picture, everything looks fine. But if I precomp those render passes, a black sharp line appears around the precomp.
As I understand it, since an antialiased edge of every render pass contains semi-transparent pixels, when I combine these passes using "add" blending mode, two overlaid semi-transparent pixels make a completely opaque one and a chain of such pixels create that dark outline. But why then if I put a background picture on the bottom of the comp it doesn't happen like this and I have a clean edge?
I'm planning a lot of 3d compositing onto photos and videos and this technical moment doesn't allow me to move on.
So could you tell me what are the calculations behind all of this?
Thanks!


Return to posts index

Tudor "Ted" JelescuRe: Black Halo After Precomping 3D Render Passes
by on Sep 1, 2013 at 12:46:49 pm

Maybe this will clarify the issue:

http://tv.adobe.com/watch/creative-cow-after-effects-tutorials/straight-vs-...

Tudor "Ted" Jelescu
Senior VFX Artist


Return to posts index

Ben WaflikRe: Black Halo After Precomping 3D Render Passes
by on Sep 1, 2013 at 2:23:36 pm

Unfortunately, no matter whether I interpret passes as straight or premultiplied with black, after precomping they get that nasty fringe.


Return to posts index


Tudor "Ted" JelescuRe: Black Halo After Precomping 3D Render Passes
by on Sep 1, 2013 at 6:29:20 pm

How are you rendering the alpha from your 3d app?

Tudor "Ted" Jelescu
Senior VFX Artist


Return to posts index

Ben WaflikRe: Black Halo After Precomping 3D Render Passes
by on Sep 1, 2013 at 6:54:41 pm

Well, I'm rendering on a black background into 32bit *.exr format. In the output settings, I choose zip compression and RGBA. There's no premultiply checkbox or something like that.


Return to posts index

Tudor "Ted" JelescuRe: Black Halo After Precomping 3D Render Passes
by on Sep 1, 2013 at 7:12:44 pm

My guess is that this is the reason you get the dark outline- premultiplied alpha on black.

Here's a helpful link:
http://docs.autodesk.com/3DSMAX/15/ENU/3ds-Max-Help/index.html?url=files/GU...

Tudor "Ted" Jelescu
Senior VFX Artist


Return to posts index


Darby EdelenRe: Black Halo After Precomping 3D Render Passes
by on Sep 1, 2013 at 9:02:45 pm

[Ben Waflik] "Well, I'm rendering on a black background into 32bit *.exr format. In the output settings, I choose zip compression and RGBA. There's no premultiply checkbox or something like that."

If you're using the EXtractoR effect to extract your passes from the EXR then the premultiplied/straight interpret footage options in AE have no effect.

Instead you'll want to use the 'Unmult' check box in the EXtractoR effect to interpret the footage as premultiplied, otherwise the assumption made by the effect is that the EXR has a straight alpha.

Also, if possible I'd recommend rendering to half float 16-bit EXRs as the file size is half as large and the quality is generally not much different.

Darby Edelen


Return to posts index

Ben WaflikRe: Black Halo After Precomping 3D Render Passes
by on Sep 2, 2013 at 4:34:59 pm

"My guess is that this is the reason you get the dark outline- premultiplied alpha on black.
Here's a helpful link:
http://docs.autodesk.com/3DSMAX/15/ENU/3ds-Max-Help/index.html?url=files/GU.....
"

Tudor "Ted" Jelescu, thanks, really helpfull info. But I don't know how to render out "straight" in 3ds max, I'll have to find it out.

"Instead you'll want to use the 'Unmult' check box in the EXtractoR effect to interpret the footage as premultiplied, otherwise the assumption made by the effect is that the EXR has a straight alpha."

Darby Edelen, As you suggested I've tried EXtractoR and checked "Unmult". What it changed is that now, in the render passes precomp, I have clean edges even on a transparent background! Great! But when I switch to the main comp, I see that render passes precomp still has that black fringe.


Return to posts index

Tudor "Ted" JelescuRe: Black Halo After Precomping 3D Render Passes
by on Sep 3, 2013 at 6:44:00 am

Try applying Effects/Channel/Remove Color Matting on the precomp and see if that works.

Tudor "Ted" Jelescu
Senior VFX Artist


Return to posts index


Darby EdelenRe: Black Halo After Precomping 3D Render Passes
by on Sep 5, 2013 at 6:18:42 am

My last ditch effort would be to solo the offending pre-comp and the background, if the problem still persists turn off any effects on the pre-comp, if it still persists make sure there are no layer styles that got mysteriously applied.

If you could post screen shots of the problem layers both inside and outside the pre-comp that might help deduce the issue as well.

Darby Edelen


Return to posts index

Ben WaflikRe: Black Halo After Precomping 3D Render Passes
by on Sep 5, 2013 at 8:51:57 am

Sure, I will upload all the images asap, thank you for helping me!


Return to posts index

Ben WaflikRe: Black Halo After Precomping 3D Render Passes
by on Sep 6, 2013 at 8:13:30 pm

Here they are. But note that I don't have problems when using just one pass. It looks as it should either on a transparent or opaque background, I can even safely precomp it and nothing bad happens. The halo only appears when I'm stacking 2 or more layers on top of each other. I've also attached the project file

Main Comp: Opaque BG
Main Comp: Transparent BG
Main Comp: PreComped Passes, Opaque BG
Main Comp: PreComped Passes, Transparent BG
PreComp: Opaque BG
PreComp: Transparent BG


Return to posts index


Darby EdelenRe: Black Halo After Precomping 3D Render Passes
by on Sep 8, 2013 at 2:32:09 am

This takes some knowledge of the order of operations (specifically blending) in AE.

In the pre-comp you are 'Add'-ing the reflection and lighting passes to the global illumination pass, but then in the Main Comp all of that information is being blended 'Normal'-ly with the shadow and background passes. The alphas of the 3 passes in the pre-comp are being added together before the normal blend in the main comp. In addition the color values at the edges actually end up being darker than you'd expect because in the area where the alpha blending occurs in the main comp the additive passes are not added to the background, but rather blended normally. This is simply due to AE's rendering.

There are 2 solutions for this problem.

The first is easy and more accurate, simply enable Continuously Rasterize/Collapse Transformations on the pre-comp layer in the main comp, however this will break if you apply any effects to the pre-comp layer.

The second takes a few steps and results in a slightly less pristine edge:

1. Enable the Layer > Preserve Transparency switch on the 2 additive layers inside the pre-comp. This will eliminate the additive build up of the alpha on the edges and should improve your results some.

2. To deal with the darkening of the color values you can apply the Channel > Remove Color Matting effect to the pre-comp layer in the main comp. This will result in some overbright values at the very fringes of the layer so apply the Channel > Set Matte effect to matte those out.

I'll also add that I don't usually run into the issue you're having here when using Unmult through the EXtractoR effect so I have a suspicion that there may be better render settings for AE in your 3D package that won't require the above workarounds.

Darby Edelen


Return to posts index

Ben WaflikRe: Black Halo After Precomping 3D Render Passes
by on Sep 8, 2013 at 2:27:30 pm

This is simply due to AE's rendering

Thanks for explaining how Ae renders things, just what I wanted to know!

...simply enable Continuously Rasterize/Collapse Transformations on the pre-comp layer in the main comp...

Yeah, I need to add effects to the precomp so it won't work.

...apply the Channel > Set Matte effect to matte those out

Well, I could apply a "set matte" effect to my precomp, but then, if I'll add a glow, say, to the reflection pass, it won't go beyond the matte I've set.

I'll also add that I don't usually run into the issue you're having here when using Unmult through the EXtractoR effect...

But how? I made a test even with plain red and blue solids using "add" blending mode. I applied feathered circular masks to them, precomped and got halo too!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]