ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Disappearing Layer/Comp

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
clay stearnsDisappearing Layer/Comp
by on Aug 10, 2013 at 4:27:01 am

I'm reasonably sure this is a different problem from the other guy who's having this problem today...

I have a layer in a comp that doesn't display in parent comps or when the layer is precomped. It's a 2d layer and none of the usual suspects (eyeball, opacity, masks) are at fault.

The other thing that's weird is that when I try to render the comp it renders without that layer, but when I play the comp inside AE it's there...

I'm not using any unusual plugins here, the only effects on the layer are Black and White, frame blending and a bunch of roto.

I can post screencap later if you guys think it'll be helpful but it's just a layer not showing up when I precomp it or render the comp...

Appreciate any ideas.

Clay


Return to posts index

clay stearnsRe: Disappearing Layer/Comp
by on Aug 10, 2013 at 4:59:33 am

Also as an update, there is no permutation of collapse transformations I could try that seems to fix my problem.


Return to posts index

Roland R. KahlenbergRe: Disappearing Layer/Comp
by on Aug 10, 2013 at 9:08:41 am

[clay stearns] "The other thing that's weird is that when I try to render the comp it renders without that layer, but when I play the comp inside AE it's there."

How are you "playing the comp"?

Post your screen caps. Ensure that you include the Comp, Timeline and Layer Panels and that all applicable property values are distinctly visible.

Cheers
RoRK

Intensive mocha & AE Training in Singapore and Other Dangerous Locations

Imagineer Systems (mocha) Certified Instructor
& Adobe After Effects CS6 ACE/ACI


Return to posts index


clay stearnsRe: Disappearing Layer/Comp
by on Aug 10, 2013 at 10:23:56 am

By playing in After Effects I mean Ram Preview. Screencap of the relevant comp and disappearing layer:
6391_aewindow.jpg.zip

Here's video capture of how it plays in the ram preview, and how I want it play when as a precomp/render...

Correct Ram Preview



Here's my AE window for the precomp:
6392_aewindowprecomp.jpg.zip

And here's the video result:

precomped/rendered



Hoping I got enough info here. It's really frustrating because I can't find any reason for this layer not to display. Collapse transformations is on in these caps but I have the same problem when it's off (in both the comp and the precomp).

Thanks again!
Clay


Return to posts index

Walter SoykaRe: Disappearing Layer/Comp
by on Aug 10, 2013 at 11:07:15 am

Your mystery layer is a "guide layer." Note the cyan icon next to it in the timeline. Guide layers are visible in the comp viewer, but do not render or appear in precomps. You can toggle a guide layer via the Layer menu or via right-click.

See help.adobe.com/en_US/aftereffects/cs/using/WS3878526689cb91655866c1103906c6dea-7dd2a.html#WS3878526689cb91655866c1103906c6dea-7e76a for more.

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index

clay stearnsRe: Disappearing Layer/Comp
by on Aug 10, 2013 at 6:33:33 pm

You sir, are correct. I have no idea how that happened. Thank you so much!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]