ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Trouble with 3d layers in a scene

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Brett HansenTrouble with 3d layers in a scene
by on Jul 30, 2013 at 5:36:02 pm

I've been working on a project with 2d elements in a 3d scene created by a camera tracker. I keep running into the same issue that is making the process quite difficult:

Many of my 2d layers need to be very close to each other in the 3d scene and so when I add a new one, I copy the transform data from the layer that is already placed correctly to the new one. And yet, the added layer never appears to be even close to the original layer. I thought it may be an issue with layer size or the anchor point, but even when I add a copy of the exact same asset I get the same issue.

I feel as though I'm missing something very simple, as I don't see how objects located at the same position, with the same scale, anchor point, orientation, and rotation could appear in completely different areas of the scene. I would really appreciate if someone could help me either fix this or find a workaround. Thanks!


Return to posts index

Darby EdelenRe: Trouble with 3d layers in a scene
by on Jul 30, 2013 at 6:18:27 pm

[Brett Hansen] "I feel as though I'm missing something very simple, as I don't see how objects located at the same position, with the same scale, anchor point, orientation, and rotation could appear in completely different areas of the scene."

Are any of the layers parented to another layer? The position of a child layer is relative to its parent. If you copy the position of a child and paste it to a layer that is not a child of the same parent then it will not be in the same position as the child layer.

Darby Edelen


Return to posts index

Brett HansenRe: Trouble with 3d layers in a scene
by on Jul 30, 2013 at 6:26:18 pm

Thank you; that was my issue. The one that I was trying to copy data was parented at one point, but I removed it as I thought it may have been a problem (before I made this thread). It seems that AE didn't respond immediately after doing so however because I was still having the issue while neither layer was parented to anything. After rebooting AE, though, I noticed that the position data had changed and layers copied to the same universal position did appear in the same position. Thanks again!


Return to posts index


Darby EdelenRe: Trouble with 3d layers in a scene
by on Jul 30, 2013 at 6:45:58 pm

Cool.

In the future an easy way to place a layer in the same position/orientation as another layer is to hold SHIFT while parenting the layer you want to move to the layer it is being moved to. This sets up a parent/child relationship where the child is moved to the position/orientation of the parent to start with.

You can then move the child as you like from there or un-parent the layer if need be.

Darby Edelen


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]