ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

Adjustment layer effect won't motion track

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Sean OffordAdjustment layer effect won't motion track
by on May 20, 2013 at 8:57:51 am

Hi all,

I have an odd problem. I Am trying to do something seemingly quite simple - make a person's teeth grow into vampire fangs as he opens his mouth and moves towards the camera.

My null object layer is motion tracking perfectly and I am using liquify in an adjustment layer to distort the teeth. Then I am using the null object as the parent of the adjustment layer - but the distortion remains resolutely in the same place!

To double checkthat I was doing everthing right I added a text later and used the null object as its parent, and the text moved perfectly.

I'm very puzzled. I'm probably not doing something really obvious but I can't for the life of me work out what it is!!

Any help gratefully appreciated...


Return to posts index

Cassius MarquesRe: Adjustment layer effect won't motion track
by on May 20, 2013 at 8:23:40 pm

I think its because liquify is a compound effect and since it is applied to an adjustment layer it has no clue about it's layer's anchor point or any matters of positional data.

What you need is to add an expression in the distortion mesh offset and pickwip the tracked null's position.

Return to posts index

Brent TaylorRe: Adjustment layer effect won't motion track
by on Aug 8, 2014 at 3:39:56 pm

Old thread, but I am having the same problem, so I thought I'd ask also.

Here is the tutorial I was using:

He does not have the problem Sean and I are having. No expression or anyting... it just works. But for me, just like Sean, the effect stays in the same place even though the adjustment layer follows the tracking null just fine.

Any ideas?

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved