ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Layer disappears after enabling as Envirorment Layer

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Michael Garske
Layer disappears after enabling as Envirorment Layer
on Apr 28, 2013 at 6:51:08 pm

I've just attempted to use the 3D Environment layer feature for the first time and when I enable it the layer I apply it to disappears.

Does anyone know what I'm missing?

Also, does this work only with still images or footage as well?


Return to posts index

Tom Daigon
Re: Layer disappears after enabling as Envirorment Layer
on Apr 28, 2013 at 6:58:37 pm

I have never seen the layer disappearing problem.

Heres some info that might help with your second question.

http://www.video2brain.com/en/lessons/environment-layers

http://tv.adobe.com/watch/learn-after-effects-cs6/3d-environment-map/

Tom Daigon
PrP / After Effects Editor
HP Z820 Dual 2687
64GB ram
Dulce DQg2 16TB raid
http://www.hdshotsandcuts.com


Return to posts index

Michael Garske
Re: Layer disappears after enabling as Envirorment Layer
on Apr 28, 2013 at 8:28:10 pm

Thanks for those. I'm wondering if it has something to do with the properties of the layer. Do environment maps have to be a certain resolution or are there any other requirements?


Return to posts index


Tom Daigon
Re: Layer disappears after enabling as Envirorment Layer
on Apr 28, 2013 at 8:43:44 pm

Not that Im aware of. It would be mentioned in those links if it were I would think.

Tom Daigon
PrP / After Effects Editor
HP Z820 Dual 2687
64GB ram
Dulce DQg2 16TB raid
http://www.hdshotsandcuts.com


Return to posts index

Joseph W. Bourke
Re: Layer disappears after enabling as Envirorment Layer
on Apr 28, 2013 at 9:17:51 pm

Do you by any chance not have a camera in the scene - that could be your problem - you also might want to check the "Appear in Reflection" setting. There are three possible settings, one of which will make the reflection disappear from the background, and only appear in the 3D object it was meant to show up in. Check out this tutorial:

http://tv.adobe.com/watch/learn-after-effects-cs6/3d-environment-map/

Joe Bourke
Owner/Creative Director
Bourke Media
http://www.bourkemedia.com


Return to posts index

Tudor "Ted" Jelescu
Re: Layer disappears after enabling as Envirorment Layer
on Apr 29, 2013 at 7:30:26 am

If you have a camera, are you sure you're looking at the Active Camera View and not at a Custom view?

Tudor "Ted" Jelescu
Senior VFX Artist


Return to posts index


Jason Jantzen
Re: Layer disappears after enabling as Envirorment Layer
on Apr 29, 2013 at 4:30:47 pm

If you're trying to use a layer as your background as well as your environment map, duplicate the layer, then set one of them to the environment map. Hit "AA" on the keyboard and click "Apear In Reflections" - set it to Only - and you should see your image as your background and the environment map will only show up on layers that have the reflection parameter turned up.

As far as footage, I don't know, but if you haven't tried it, go try it, it won't hurt :)

Jason Jantzen
vimeo.com/jasonj


Return to posts index

Michael Garske
Re: Layer disappears after enabling as Envirorment Layer
on Apr 30, 2013 at 3:44:58 pm

Hey guys,

Sorry for the delayed response. I've got a camera in the scene, I am in active camera view, and I duplicated the environment layer so one has "only" and one has "on" for the appears in reflections setting. I tried this with both footage and a still image so that doesn't seem to be the issue.

Sorry I should have specified also, I'm not using any ray-trace items. I have some extruded text from Element 3D but I'm less interested in making this work as an environment map for reflections than I am in just getting it to work as a background.

I've tried this on a couple of machines with the same result. Anyone have any other ideas?

I tried looking else where but it seems that the feature is fairly straight forward making this problem difficult to research. Is there anyway to achieve the same thing through Element 3D?


Return to posts index

Jason Jantzen
Re: Layer disappears after enabling as Envirorment Layer
on Apr 30, 2013 at 4:18:07 pm

Sounds like you have TWO layers set as environment layers, is that right? If you want one of those layers to act as your background, then you can't set it as an environment layer because it'll get "converted" to an HDRI image and look like it's disappeared. It actually just gets REALLY big and blurry.

So disregarding that whole process since you're mostly interested in just using it as a background and want a way to do it with Element. I've done this before a couple of times and it's REALLY easy. Here's Andrew Kramer's tutorial on how to do that -

Jason Jantzen
vimeo.com/jasonj


Return to posts index

Michael Garske
Re: Layer disappears after enabling as Envirorment Layer
on May 2, 2013 at 11:45:44 pm

Thanks for that! Great work around.


Return to posts index

Corey Holtgard
Re: Layer disappears after enabling as Envirorment Layer
on Oct 24, 2016 at 2:27:57 pm

So I just had this happen to me, only I really wanted the environment layer to be used as a reflection, so the background workaround mentioned above was no help to me. After bashing my head on the wall a couple times, because the other 3 projects I just did worked fine doing this, I realized my "Fast Previews" was set to "Fast Draft" instead of "off". So turning this to "off" instantly made my environment layer appear. From which I set to reflection only and so on......

Head of Production - Outhouse Entertainment - outhousetv.com


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]