ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Interlaced video nightmare [Moving to here from digital deliver]

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Kyle BalesInterlaced video nightmare [Moving to here from digital deliver]
by on Apr 22, 2013 at 7:34:29 pm

Hi everyone,

I have 5 hours of footage I am supposed to edit for a client into a 3 minute video for their website. The problem is that whoever was in charge of the footage compressed it to a DVD, interlaced. Of course this looks hideous on any monitor and I must find a way to de-interlace it. I have tried every method I could find from google and youtube to do this at absolutely no success. I have changed the field order and recompressed with de-interlacing. Applied directional blur, and ever other wacky solution there is on the web. I am working with adobe premiere and after effects.

Most solutions I've found seem to imply that this is a very easy fix, and I am completely stumped. I wonder if it has to do with the fact that I am not working with the raw, since the footage was actually compressed as interlaced video?

Any guidance or input would be very much appreciated.

Thanks,
Kyle


Return to posts index

Dave SimpsonRe: Interlaced video nightmare [Moving to here from digital deliver]
by on Apr 22, 2013 at 7:47:31 pm

Hi Kyle,

Although far from an ideal solution could you re-capture the footage from a DVD player back into your NLE? If the final destination is a web page the quality might still be okay.

Dave



Return to posts index

Kyle BalesRe: Interlaced video nightmare [Moving to here from digital deliver]
by on Apr 22, 2013 at 8:26:06 pm

Thanks for the response Dave.
I basically just copied the VOB files from the DVD and renamed them to .mpg.

Is there a more appropriate way to capture the footage?

Thanks


Return to posts index


Darby EdelenRe: Interlaced video nightmare [Moving to here from digital deliver]
by on Apr 22, 2013 at 8:06:42 pm

The appropriate solution will change depending on the format of the source footage and the DVD encoding. Can you provide more information? Was the source progressive or interlaced? What was the source frame rate and what is the frame rate of the DVD encoding?

Darby Edelen


Return to posts index

Kyle BalesRe: Interlaced video nightmare [Moving to here from digital deliver]
by on Apr 22, 2013 at 8:28:48 pm

Hey Darby thanks for the response.

The original files were VOB files that I copied off of the DVD. I am working with the source files still since I just renamed them to .mpg. Here are the properties of one of the clips....

File Size: 876.2 MB
Image Size: 720 x 576
Frame Rate: 25.00
Source Audio Format: 48000 Hz - compressed - Stereo
Project Audio Format: 48000 Hz - 32 bit floating point - Stereo
Total Duration: 00:15:24:24
Average Data Rate: 969 KB / second
Pixel Aspect Ratio: 1.4587

Thanks


Return to posts index

Darby EdelenRe: Interlaced video nightmare [Moving to here from digital deliver]
by on Apr 23, 2013 at 4:47:44 am

It sounds like you're working with a source that was interlaced from the get go (PAL 50i). The best thing you can do is to interpret the fields properly. Once that's done, and if you're definitely delivering progressive, you can also try the Preserve Edge Quality checkbox (this sometimes improves jaggies).

Applying a 1px vertical blur as you mentioned is also a good idea. You could also apply Timewarp at 100% speed and enable motion blur to apply a small amount of blur to objects in motion.

If you can deliver at 1/2 the vertical resolution you could place your footage in a 50 frames per second 360x288 composition (use the source footage pixel aspect ratio) and scale it to 50%. This should result in a good 50p video (twice the frame rate!), although at half the original resolution.

If you're still having trouble then it would help to see a short sample of the problematic footage. Of course only if the client isn't protective of the footage :)

Darby Edelen


Return to posts index


Kyle BalesRe: Interlaced video nightmare [Moving to here from digital deliver]
by on Apr 23, 2013 at 11:28:48 pm

Thanks for the suggestions!

I'm not sure I am adjusting the frame rate and resolution correctly. Should I just be be doing that in the comp settings or is it during the actual compressing?
I'm not seeing a huge difference no matter what I do even with the blur, timewarp, and resolution/fps adjustments ....
And another problem is that when I drag one of the clips onto the new comp button it is creating a composition that is 4:3 instead of widescreen and in addition to that, when I view the footage in AE it is 4:3 even though it says the aspect ratio is 1.46. Although when I turn pixel aspect ratio correction on it goes to widescreen but of course doesn't export that way.

Is there an email address I can send you some stills of what I'm working with to you?

Let me know, again thanks for your help!

Kyle


Return to posts index

Darby EdelenRe: Interlaced video nightmare [Moving to here from digital deliver]
by on Apr 24, 2013 at 2:01:45 pm

[Kyle Bales] "I'm not sure I am adjusting the frame rate and resolution correctly. Should I just be be doing that in the comp settings or is it during the actual compressing?"

In After Effects the output frame rate and resolution is defined in the Composition Settings of the composition you are rendering (although it can be overridden in the Render Settings). However, you should also confirm that the frame rate of the footage source in the project panel is correct. You can alter this as well as the field order by right clicking the footage in the project panel and using Interpret Footage > Main...


[Kyle Bales] "And another problem is that when I drag one of the clips onto the new comp button it is creating a composition that is 4:3 instead of widescreen and in addition to that, when I view the footage in AE it is 4:3 even though it says the aspect ratio is 1.46."

You should use the PAL D1/DV Widescreen Square Pixel composition preset if you want the rendered movie to be widescreen on square pixel devices (computer displays, HDTVs).


[Kyle Bales] "Is there an email address I can send you some stills of what I'm working with to you?"

You can upload images to the forum using the Image Upload button above the Message field where you reply (it's the 3rd from the right in a row of buttons). A short clip may be better as it's impossible to figure out field order from a still image. There's a button for that too :)

Darby Edelen


Return to posts index

Kyle BalesRe: Interlaced video nightmare [Moving to here from digital deliver]
by on Apr 24, 2013 at 5:00:47 pm

[Darby Edelen] "In After Effects the output frame rate and resolution is defined in the Composition Settings of the composition you are rendering (although it can be overridden in the Render Settings). However, you should also confirm that the frame rate of the footage source in the project panel is correct. You can alter this as well as the field order by right clicking the footage in the project panel and using Interpret Footage > Main...
"

I had the footage interpreted with 25fps and the composition as 50fps. Is this correct?


[Darby Edelen] "You should use the PAL D1/DV Widescreen Square Pixel composition preset if you want the rendered movie to be widescreen on square pixel devices (computer displays, HDTVs)."

Fixed! thanks!

[Darby Edelen] "You can upload images to the forum using the Image Upload button above the Message field where you reply (it's the 3rd from the right in a row of buttons). A short clip may be better as it's impossible to figure out field order from a still image. There's a button for that too :)"

Here is what I'm up against. You can see the motion distortion at the very end. Also it got re-encoded to a different size when I uploaded it so hopefully that won't derail your analysis :/

http://reels.creativecow.net/film/interlaced-sample

Thanks!!
Kyle


Return to posts index


Roland R. KahlenbergRe: Interlaced video nightmare [Moving to here from digital deliver]
by on Apr 25, 2013 at 2:55:42 am

Your output is displaying the following issues -
1) interlacing artefacts
2) incorrect pixel aspect ratio

For broadcast, these issues will be non-existent. However, for playback on a computer monitor, via a video playback app that doesn't de-interlace nor understand non-sqaure PAR, the two issues will stick out clearly.

To solve (1) -
interpret the footage as either upper or lower field. TO check if the field ordering is one or the other, set it to lower and then step through (use the Page Down key) the media asset in the Footage Panel. If the field ordering interpretation is correct, the exhibited motion will be accurate. If incorrect, the motion will exhibit a forward-backward motion when viewing the clip, on a field-by-field basis.

To solve (2) -
Create a square equivalent composition for your source clips and render out from there. This comp should be 1050x576, if I've read/remembered your previous posts correctly.

You may also want to scale the clip slightly, in the comp, to get rid of any black borders which are prevalent on most MPEG2 compressed media.

HTH
RoRK

Intensive mocha & AE Training in Singapore and Other Dangerous Locations

Imagineer Systems (mocha) Certified Instructor
& Adobe After Effects CS6 ACE


Return to posts index

Kyle BalesRe: Interlaced video nightmare [Moving to here from digital deliver]
by on Apr 25, 2013 at 3:36:26 am

Thank you, your suggestion worked for the aspect ratio dilemma.

As for the motion choppiness, there doesn't seem to be any difference in the motion when I set the separate fields parameter to either upper or lower field first. In both cases when I step through in the footage panel, I see motion only every other frame, and in between the lines shift vertically, no backwards movement in either one.

Am I testing it wrong?
Is it possible my footage is interlaced permanently? Is there such a thing?
I just can't seem to find any sort of relief in the atrociousness of the motion in this footage no matter what I try.

I've switched it to lower fields, higher fields, rendered it both ways.... what am I missing?


Return to posts index

Roland R. KahlenbergRe: Interlaced video nightmare [Moving to here from digital deliver]
by on Apr 25, 2013 at 3:42:28 am

Perhaps it's your Output Settings that are incorrectly set. You should be rendering WITHOUT fields. If things are unclear, then take a snapshot of your Output Module dialog. Also ensure that your comp is set to 25fps and not 50fps.

HTH
RoRK

Intensive mocha & AE Training in Singapore and Other Dangerous Locations

Imagineer Systems (mocha) Certified Instructor
& Adobe After Effects CS6 ACE


Return to posts index


Kyle BalesRe: Interlaced video nightmare [Moving to here from digital deliver]
by on Apr 25, 2013 at 4:20:48 am

These are the settings I just rendered with that outputted the same interlaced motion as the original. I double checked that the composition frame rate is set to 25fps. Same result when the footage interpretation is set to lower OR higher field separation.

Any ideas?



Thanks


Return to posts index

Roland R. KahlenbergRe: Interlaced video nightmare [Moving to here from digital deliver]
by on Apr 25, 2013 at 6:06:27 am

This is strange - I can only attribute it to (a) a CODEC that is defaulting to rendering an interlaced output or (b) your footage interpretation is incorrectly set (c) scaling and/or positional moves in the layer is causing the interlacing/combing artefact.

HTH
RoRK

Intensive mocha & AE Training in Singapore and Other Dangerous Locations

Imagineer Systems (mocha) Certified Instructor
& Adobe After Effects CS6 ACE


Return to posts index

Darby EdelenRe: Interlaced video nightmare [Moving to here from digital deliver]
by on Apr 25, 2013 at 2:20:35 pm

[Kyle Bales] "Here is what I'm up against. You can see the motion distortion at the very end. Also it got re-encoded to a different size when I uploaded it so hopefully that won't derail your analysis :/"

So the interlacing I see in that footage is a common problem, but I'm not sure if it's due to the resizing that occurred when you uploaded it or if it's in the source footage. If you turn Separate Fields Off and zoom into your footage do you see single lines of interlacing in that fast motion portion? Or do they look more like big fat lines as seen in the top two images on this site: http://www.100fps.com/

If the latter then your footage was at some point (probably long before you got it) resized without first being de-interlaced. There is no good way to fix this. The best option is to ask for better source footage.

Darby Edelen


Return to posts index


Kyle BalesRe: Interlaced video nightmare [Moving to here from digital deliver]
by on Apr 26, 2013 at 6:14:09 pm

[Darby Edelen] "So the interlacing I see in that footage is a common problem, but I'm not sure if it's due to the resizing that occurred when you uploaded it or if it's in the source footage. If you turn Separate Fields Off and zoom into your footage do you see single lines of interlacing in that fast motion portion? Or do they look more like big fat lines as seen in the top two images on this site: http://www.100fps.com/
"


I'm beginning to think it is the latter....

Here is a screenshot of my footage during motion with separate fields set to off. This would be the fat lines you were referring to right?



Return to posts index

Roland R. KahlenbergRe: Interlaced video nightmare [Moving to here from digital deliver]
by on Apr 26, 2013 at 11:57:52 pm

I'm beginning to believe that the interlacing artefact is inherent in the source video - the VOB files. I know of no way to remove these without introducing other issues. Stay away from such shots when you're selecting your footage.

HTH
RoRK

Intensive mocha & AE Training in Singapore and Other Dangerous Locations

Imagineer Systems (mocha) Certified Instructor
& Adobe After Effects CS6 ACE


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]