ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

Transparency/Alpha Great Mystery (IMPORTED PNG Sequence)

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Tim KocherTransparency/Alpha Great Mystery (IMPORTED PNG Sequence)
by on Mar 28, 2013 at 8:40:53 am

Ok, this one is going to fall under the "I would LOVE to get an explanation of this one!" category. Just when I thought I knew everything about transparency and alpha channels, etc ...

The problem: I am importing a PNG sequence into After Effects (CS 5.5), however AE refuses to see the Alpha channel contained within the sequence. Now before anyone jumps the gun and says, "But wait, PNG does not really support alpha, it just supports transparency!" Right, something I just learned, and still -- quite honestly -- baffles the heck out of me.

But anyway, another PNG sequence exported from the exact same program, imports into After Effects just fine with an "alpha channel" and all. I double-checked, and there is NOT an option in the program to export the PNG without transparency info.

Importing sample images from each sequence reveals the EXACT SAME THING ... both have transparency, but NEITHER have an alpha-channel per se.

Sooo ...

  • 1) ANY idea why in the heck AE would interpret one's transparency, and not the other?
  • 2) Is there a way to FORCE AE to see the transparency of the one?
  • 3) IF not, is there something out there that will convert the PNG's with transparency to another format (TIF, TGA, PSD) with an alpha? I just don't want to have to re-render the sequences again.

ANY insight into this bizarre-ness would be GREATLY appreciated.


Return to posts index

Paul RoperRe: Transparency/Alpha Great Mystery (IMPORTED PNG Sequence)
by on Mar 28, 2013 at 11:35:37 am

You've probably tried these already, but here goes:

1. After you've imported your PNG sequence, right-click it and choose Interpret Footage > Main... At the top, the alpha should be set to either Straight or Premultiplied. I'm guessing this alpha section is greyed out, meaning AE's not seeing the alpha.

2. Do you have Photoshop? If you have, open up one of your dodgy PNGs and check the transparency. If Photoshop doesn't see any transparency or alpha (check both the layers and channels palettes) then the image does not have any and the problem is with the program you used to create the PNG. If it DOES see transparency/alpha, then you could do a batch process in Photoshop to convert all the PNGs to some other format that supports alphas - such as TIFF or PSD.

3. Post one of those dodgy PNGs on here so other people can take a peek and offer more advice.

- Paul

Return to posts index

Tim KocherRe: Transparency/Alpha Great Mystery (IMPORTED PNG Sequence)
by on Mar 28, 2013 at 12:20:14 pm

Thanks, Paul. Didn't see your message until after I posted my solution. Thanks for trying to help out!

Return to posts index

Tim KocherRe: Transparency/Alpha Great Mystery (IMPORTED PNG Sequence)
by on Mar 28, 2013 at 12:19:33 pm

Nevermind, figured it out ... The 3D app does not export alpha information for those frames where NO background is showing. (i.e. an object(s) fill the frame. In this case, it was the first 60 frames or so of the animation. Thus AE saw it as having no alpha/transparency.

Dumb on the 3D app's part. Will test this with another 3D app to see if that is common or not.

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved