ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

The real downlow of 3D objects in after effects: Nested 3D compositions not casting shadows, or accepting lights.

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Tali JayThe real downlow of 3D objects in after effects: Nested 3D compositions not casting shadows, or accepting lights.
by on Feb 1, 2013 at 1:40:26 pm

Hi there,
I am hoping someone can help me out - I have searched the forums and alas, I cannot find anything that helps me solve my problem in its entirety.

In short, I have created a scene where there is a book lying on its side (in a3D environment) the camera zooms in and goes above the book, the book flips open, a few (ten or so) pages flip open, and we land on a page where an animation with the text occurs.

Now, I divided this into 3 main sections or comps. My main comp, where I have the room floor, lights and camera. A comp where I have the book pages flipping open, and a comp where I built the book to look 3d when it's lying on the floor. All comps are 3d

In the 2nd comp (book opening), I precomposed the pages turning (also 3d), the book covers are 3d layers.

Then in a new comp I nested my two book comps (the 3D book, and the pages turning book) and at one point (when the camera faces the book head on) the 3d book is gone, and the book opening takes its place.

Now, I was having MAJOR issues with casting and accepting shadows in the final composition. My shadows were acting crazy, becoming all pixelated and stripy. (I made sure that all comps were collapsed in order to keep the book in it's 3D state in the final comp)

So I went and turned off the material options of all the pre-comps EXCEPT the original 3D layers. Which helped - a little. Then I read that when two or more 3d objects occupy the same Z space I will have major shadow problems - is this true? So I went back, and changed my layers Z numbers (which took forever) so that no layer occupied the same Z space. (The highest layer sat at z=0, and then I wrote an expression that each layer's Z is equal to the Z of the layer above+15)

And boom! That worked. With each 3D layer collapsed, and only the ORIGINAL 3D layers casting shadows, accepting lights - in my final comp - it looked great.

But then I noticed some layers behaving oddly and one frame being above the layer below and the next frame being below. So I thought, there must be a simpler way to do this!?!?

So logically (or so I thought) what if I keep all my many comps and layers ALL 3D but have NONE of then accept shadows or cast shadows.And have everyone on the same z space. Which I did. And it took hours and hours. Then when I nest my book (which is the 3d book and the book opening together) into my final comp (which has lights and the camera) it will be 3D, but it will be the only object occupying the z space - so the shadow should work, right?!?! WRONG. I made sure the only layer to accept shadows is my final book comp layer.

Yes, my book is 3D but it doesn't accept light or shadow or anything. And when I turn on the cast and accept shadow on my previous layers and pre-nested comps I get the same stripey lines!

So what is the actual story here? If i want to work with 3D pre-comps and layers they cant occupy the same z space? Otherwise I have to have ALL my layers in one comp?

I am so confused and so very very very frustrated I want to smash my computer and go live on a commune that has no electricity so that I will never again be tempted to involve myself with technology.

Your help and understanding is greatly appreciated. And please, I beg of you - do not send me to the manual. I have read it - and if the answer is there I clearly haven't understood it and need it explained in a different way.

Thanks in advance

Return to posts index

Roland R. KahlenbergRe: The real downlow of 3D objects in after effects: Nested 3D compositions not casting shadows, or accepting lights.
by on Feb 3, 2013 at 5:07:06 am

Here are a couple of ideas -

1) Collapse Transform your nested comps and make it a 3D layer.
2) Try building the entire sequence in a single comp.

With regards to the stripy shadows, try moving the lights further from the layers - sometimes even a slight shift in a lights orientation helps to remove the shadow artefact.


Intensive mocha & AE Training in Singapore and Other Dangerous Locations

Imagineer Systems (mocha) Certified Instructor
& Adobe After Effects ACE/ACI (version 7)

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved