ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

After Effects error TDL??

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Dave FlemingAfter Effects error TDL??
by on Jan 3, 2013 at 7:17:25 pm

I've never seen this one before...I created a block in Illustrator and typed some letters to cut out of the block by creating outlines and then making a compound path to cut out the letters.

I brought the file into AE to be used in a ray-traced 3D comp to get some extrusion and environment mapping on it. When creating the outlines from the vector layer, I get:

"After Effects error: TDL: outline contains traingles that are too small to be rendered. Check for very thin triangles in original artwork. (88::3)"

Any ideas?

Dave


Return to posts index

Ridley WalkerRe: After Effects error TDL??
by on Jan 3, 2013 at 8:28:26 pm

A couple of things come to mind. When you made the Compound Path did you Expand the resultant shape? If not try that. The shape should be as simple as possible for After Effects.

When you view the Illustrator file in outline view are there any stray points? If so in Illustrator go to Select > Object > Stray Points and delete them.


Return to posts index

Dave FlemingRe: After Effects error TDL??
by on Jan 3, 2013 at 10:24:29 pm

Thanks for the reply, but unfortunately, that isn't the problem. But, I do have more information about how this error is occuring. The error occurs not when making the shapes from the vector layer - that works OK. But, as soon as I try to make the new outline layer 3D by clicking the 3D box on the layer, I get the error.

To test this further, I created a box in Illustrator. I typed the letter "I" in the box, created outlines for the letter and made a compound path for the cutout shape. So, in other words, the simplest shape I could possibly make that still gives me the look I want. I imported the file to AE, made shapes from the vector layer...OK. Turned the layer into 3D - boom - got the error.

Is this a bug?

Dave


Return to posts index


Ridley WalkerRe: After Effects error TDL??
by on Jan 3, 2013 at 10:48:22 pm

Just did the same thing without any problem. Did you select Expand Appearance from the Object menu before importing into AE?

BTW, I'm on CS6 with all updates.


Return to posts index

Dave FlemingRe: After Effects error TDL??
by on Jan 4, 2013 at 1:59:21 am

Honestly, I did not try that. I was so disgusted over the whole problem that I quit for the evening. I will give your solution another go tomorrow and let you know what happens. Thanks for the suggestion!

Dave


Return to posts index

Dave FlemingRe: After Effects error TDL??
by on Jan 4, 2013 at 2:26:57 am

Forgot to mention previously, also on CS6 - the whole suite.

The AE comp already utilizes 2 or 3 other Illustrator files converted to shapes from vectors - not like the one I'm trying to make, obviously, but with much more complex shapes than this one.

I'll start from scratch tomorrow and begin with a simple shape element with a cutout and go from there.

df


Return to posts index


Dave FlemingRe: After Effects error TDL??
by on Jan 4, 2013 at 10:38:55 pm

Ridley,

What I did in the final analysis to get things to work (I'm on a deadline, just like everybody else), was to switch fonts a few times until I fould something that would work. I ended up using Brandon Grotesque instead of Helvetica Neue, which I think we would both agree are pretty similar sans serif fonts. But, for some reason, it likes the one and not the other. I did try "expanding" the shape (expand appearance wasn't available), but I'm not sure what that did if it did anything. How do you know?

I did have a colleague in another state duplicate my workflow and he got the same result (error at first, then OK when switching fonts), so, in my opinion, that spells B-U-G. Plus, I have multiple other AI objects within the same comp, all with shapes made from vectors - highly complex shapes at that - and AE has no problem with them.

df


Return to posts index

Ridley WalkerRe: After Effects error TDL??
by on Jan 5, 2013 at 12:33:28 am

Dave;

That's really very odd. I've just duplicated the process using both Apple's Helvetica Neue and Adobe's Helvetica Neue with no issue whatsoever.

I'm running on a Mac using 10.8.2.

I've done a screen recording of the workflow I followed, I do use keyboard shortcuts for some steps such as Create Outlines for the Type in Illustrator, see the following:

3D Type from Shape Layer



Return to posts index

Ridley WalkerRe: After Effects error TDL?? Replicated problem
by on Jan 5, 2013 at 12:55:12 am

OK. I *was* able to replicate the problem using a smaller point size (12 pt) though with Myriad.

I suspected this would happen with any font if the size is small enough, however even at 100 pt Myriad would produce the error where other fonts would not.

Perhaps it is font related.





Return to posts index


Ridley WalkerRe: After Effects error TDL?? Replicated problem it gets weird
by on Jan 5, 2013 at 1:17:04 am

It gets weirder.

Just tried this with the same files on another machine and it works fine.


Return to posts index

Dave FlemingRe: After Effects error TDL?? Replicated problem it gets weird
by on Jan 5, 2013 at 1:58:25 am

Thanks for all of your testing. It is very appreciated!

I had sort of suspected early on that having a too small font size would be a problem. So, I stuck to sizes 75 points or larger.

My title word is "EDITORIAL" (in all caps) in a white rectangle. The specific font I was trying to work with is Helvetica Neue Medium Condensed - Heavy at around 100 points. That never worked for me.

I can't remember all the test fonts I tried, but I remember trying Bank Gothic, which didn't work. That really sucked, because Helvetica Neue Medium Condensed and Bank Gothic are our two main station fonts.

I tried Adobe Caslon Pro, which worked. My out-of-state buddy suggested than one, since it was an Adobe font! Ironically, it is a heavily serifed font, and so would have more complex shapes than a simple sans serif. Interestingly, Myriad Pro also worked in my system (I'm on a PC). Odd, since that didn't work on one of your boxes...

But, thank God, I got approval on the Brandon Grotesque version late this afternoon! But, there's just been so much craziness with this problem that I'm going to submit it as a bug report on Adobe's site.

Thanks again,

Dave


Return to posts index

Nikhil PatelRe: After Effects error TDL?? Replicated problem it gets weird
by on Dec 17, 2013 at 6:04:21 pm

I tried changing my display (Fast Previews) from "Daft" view to "Adaptive Resolution" and It worked in AE CC 12.2


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]