ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

Flickering 3D illustrator layers

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
David FuchsFlickering 3D illustrator layers
by on Oct 24, 2012 at 9:15:51 pm

I'm creating a series of comps with some toon characters created in Illustrator CS6 (saved with no compression), and being precomped and rigged, then used in a larger comp. 3D and rasterization are enabled in both the main comp and precomp.

In Illustrator, I applied an inner glow for some depth to the illustrator layers. However when the camera does a simple z-move, the inner shadow flickers everywhere, like i was animating its offset and opacity properties every single frame. Turning off rasterization in the main comp or any combination in the other comps fixes this, but of course blurs things. The precomped characters are all at 100%, so it's not like I shrunk these down and the details are getting lost like so much judder or thin type scrolls.

An example is shown in this video:

Anyone know of ways to fix this, other than blurring it by turning off rasterization? Or is this an issue with having both the comp/precomp rasterization layers checked?

Return to posts index

Vishesh AroraRe: Flickering 3D illustrator layers
by on Oct 25, 2012 at 6:59:55 am

Disable the Collapse Transformation for your Precomps that are in your main comp.

Enable Continuously Rasterize for AI files.

Just make your precomps 3D and them animate the camera.

I did the same thing as you have written and found that if I enable the
Collapse Transformation of my Precomp, it jitters.

may be this will work.

Vishesh Arora
3D and Motion Graphics Artist
Films Rajendra


Demo Reel(3D):

Return to posts index

Cassius MarquesRe: Flickering 3D illustrator layers
by on Oct 25, 2012 at 1:43:12 pm

Layer styles take precedence I think over anything. If you collapse the transformations it will render out over the animated footage. And I'm guessing it flickers because it can't correctly calculate AE does.

Your solution is to increase your vector's resolution in a precomp. Apply styles inside and don't collapse.

Now use this comp as if your vector was rasterized.

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved