ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

Multiprocessing freezes CS6

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Scott RenaudMultiprocessing freezes CS6
by on Oct 4, 2012 at 11:21:05 pm

Any time I've got multiprocessing enabled and hit render, it never gets passed the "Initializing Background Processes" stage. It just hangs. I've let it think for up to a half hour. Nothing. End process.

Here are some details:
Win 7 Ultimate 64
2 x Intel Xeon E5645 2.4GHz
48GB Ram
Quadro 4000

Multiprocessing settings:

Installed RAM: 48 GB
RAM reserved for other applications: 12 GB
RAM available for AE : 36 GB
Installed CPUs : 24
CPUs reserved for other applications: 8
RAM allocation per background CPU : 2 GB
Actual CPUs that will be used: 16

Return to posts index

Roland R. KahlenbergRe: Multiprocessing freezes CS6
by on Oct 5, 2012 at 2:13:53 am

This is an issue that comes and goes and has been impossible to pin down. If AE is still stuck at initializing after 5 minutes then just switch MP off and proceed. Once it's stuck, it never seems able to get out of it.


Intensive AE & Mocha Training in Singapore and Malaysia
Adobe ACE/ACI (version 7) & Imagineer Systems Inc Approved Mocha Trainer

Return to posts index

Scott RenaudRe: Multiprocessing freezes CS6
by on Oct 5, 2012 at 3:16:03 pm

ughhh, I was afraid I might get an answer like this.

Thanks for the reply.

Return to posts index

John CuevasRe: Multiprocessing freezes CS6
by on Oct 5, 2012 at 4:17:44 pm

Sometimes when I run into the same issue, I will turn off MP, do a RAM preview and let it complete, purge it and then turn MP back on and it will work fine again.

But along with Roland I have never found any rhyme or reason why it happens.

Johnny Cuevas, Editor

"I have not failed 700 times. I have succeeded in proving that those 700 ways will not work. When I have eliminated the ways that will not work, I will find the way that will work."
---THOMAS EDISON on inventing the light bulb.

Return to posts index

Craig RogersRe: Multiprocessing freezes CS6
by on Oct 21, 2012 at 9:31:25 am

This doesn't happen "some times" it happens every time. Unless I "dumb" down to only using 5 cores it'll get all 16 cores blasting away at 100% and get stuck. Even after I force AE closed, I have to manually go in and end each an every process. What's the point of having 16 cores and 32GB of RAM if I can't use it? Thinking the problem may be slow hard drives, I've tried rendering to SSD and that didn't solve any problems.

I can't verify it yet, but these CS6 bugs seem to foul up my windows os as well. Everything was running great, I had AE and AME act up and then EVERYTHING started freezing up randomly. Windows boot time now takes upwards of 10 minutes.

After the first time, I did a fresh install of my OS and CS6 and the same thing is happening again. I'm ready to pull my hair out - and I can't afford that! I've got work to do!

I'm very nearly ready to do another fresh OS install and trash CS6 and just go back to using CS5.5. What a waste of time and money CS6 has been.

Win7 Ultimate 64bit - SP1
dual E5-2650
GTX 690

If ANYONE has any suggestions, I'm all ears.

Return to posts index

mihai wilsonRe: Multiprocessing freezes CS6
by on Nov 13, 2012 at 8:00:01 pm

Seems like I'm facing similar issues on a mac pro. Sometimes MP completely locks up my machine, forcing a cold reboot. Are people here running the latest version? I can't be sure, but it seems like the issues are getting worse now that I updated to

Giving AE more than 3 processors is pretty much a 100% fail for me. Thats with 3gb per core on a 12 core mac pro with 64gb of ram. Even at 3 or less it still feels like russian roulette. I thought it was BGRenderer -- which I have used the heck out of in 5.5 with only minor issues, but even rendering in AE I get the same behaviour.

Return to posts index

Roland R. KahlenbergRe: Multiprocessing freezes CS6
by on Nov 13, 2012 at 8:26:01 pm

The following AE Team's blog post is a good read on the topic. -

The best take-away message IMO is the following - "After Effects is a multithreaded application that can also use other forms of multiprocessing beyond just Render Multiple Frames Simultaneously multiprocessing". Seeing that you are having issues with RMFS, deselect MP (aka Render Multiple Frames Simultaneously) in AE's prefs dialog. Set aside some RAM for other applications. Such a setting will allow AE to manage its multi-threaded/multiple processing architecture on-the-fly.

If you have sufficient RAM, and the plugins you use support MP, then you should have similar, not necessarily better or worse, experience to having MP selected in the prefs dialog.


Intensive mocha & AE Training in Singapore and Other Dangerous Locations

Imagineer Systems (mocha) Certified Instructor
& Adobe After Effects ACE/ACI (version 7)

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved