ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Multiply blending mode stops working as soon as I create an alpha matte with the layer above

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
David Cabestany
Multiply blending mode stops working as soon as I create an alpha matte with the layer above
on Sep 11, 2012 at 11:28:25 pm

I have a comp wich has three layers in it, all three are set to multiply in the blending mode.
I'm dropping that comp into another one, where a set of doors partially covers it,
I duplicated the layer with the doors, so that I can use the exact same animation in the alpha matte, but as soon as I turn the alpha matte on the blending mode stops working, I have collapsed trans on, but still the blending stops working with the alpha.



What am I doing wrong? Is this an expected behavior?

Thanks in advance.


Return to posts index

Vishesh Arora
Re: Multiply blending mode stops working as soon as I create an alpha matte with the layer above
on Sep 12, 2012 at 6:16:23 am

Mr. Cabestany

From the first image it seems that the doors have some transparency or they are in blending modes as you can see through them. Change blending mode of doors to none if they are in some other blending mode.

Vishesh Arora
VFX and Motion Graphics Artist

Blog:
http://digieffects.wordpress.com

Demo Reel(3D):







Return to posts index

Cassius Marques
Re: Multiply blending mode stops working as soon as I create an alpha matte with the layer above
on Sep 12, 2012 at 12:44:37 pm

It is to be expected... Layer mattes will break blending modes from multiple layers.

You can turn off continuosly rasterization for this pre-comp, and set it to multiply. It will change your look slightly. But it usually solves the problem.


Return to posts index


David Cabestany
Re: Multiply blending mode stops working as soon as I create an alpha matte with the layer above
on Sep 12, 2012 at 2:17:42 pm

Hey guys, thank you both for taking the time to look at my problem.

Vinesh, I need the transparency, what I needed is to keep while also keeping an alpha channel to prevent seeing the layer in its entirety, not get rid of the multiply blending mode.

Cassius, if I turn off the collapse transformations switch I lose the relative position I need, here's what I did in the end and solved my problem:

I turned off collapse transformations in the layer and set the blending mode to multiply, went inside the comp and set them to multiply too, sort of a double multiply thing, then I turned the collapse switch on again, so I recovered the 3d position, immediately the blending mode changed from multiply to - (you know, when you can;t change it without uncollapsing) but nonetheless the blending mode worked as I needed.

Thanks again!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]