ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Masks, comps and 3D camera issues

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Olly Lawer
Masks, comps and 3D camera issues
on Aug 24, 2012 at 1:55:48 pm

Hi,

I've got a phone which I am animating a screen to slide onto from the right. Previously in other animations it was a nightmare as I had to create a mask round the phone screen so you couldn't see the phone screen to the right of the phone hanging in mid air.

This causes problems with the 3D camera as when I then move the camera, the masked screen doesn't respond like the other layers. All layers have continuos rasterisation on.

So I created a comp just big enough for the phone screen and laid that comp within the phone comp hoping that when I move the phone screen outside of the active comp area in the screen comp, you wouldn't see it in the phone comp. This hasn't happened so I am left scratching my head.

Another way I can think to fix this, but it's messy, is to move the camera into position, animate using a mask as before, then replace the comp with the mask with the screen comp - effectively reducing the opacity to 0% on the masked comp and to 100% on the screen comp. Then when I move the camera again all is great.

But am I missing something?

***

Hmm that's strange, by accident it seems I've discovered that a mask does work with a 3D camera...but only after you have added the camera moves first.

So move the camera in the main comp with the mask layer and the mask will not act like the other layers.

Animate the camera move then create the mask and it works just fine. Strange. I guess this is just a glitch of AE?

Olly Lawer


Return to posts index

Walter Soyka
Re: Masks, comps and 3D camera issues
on Aug 24, 2012 at 5:31:14 pm

You might not want to use a mask for this -- a track matte [link] or the Set Matte effect [link] might be a lot easier.

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index

Olly Lawer
Re: Masks, comps and 3D camera issues
on Aug 24, 2012 at 5:40:25 pm

Of course! How did I forget this!

Thanks

Olly Lawer


Return to posts index


Olly Lawer
Re: Masks, comps and 3D camera issues
on Aug 25, 2012 at 12:24:46 pm

Track Matte works a beaut, however, I do notice the same issue with the 3D camera.

Basically if I apply a mask or Track Matte before I do a 3D camera move, layers don't move (that have either effect applied to them) as other layers do.

Applying after ensures that the camera move is correct.

Is this just a bug of AE?

Olly Lawer


Return to posts index

Olly Lawer
Re: Masks, comps and 3D camera issues
on Sep 11, 2012 at 8:47:07 am

Any ideas on this? I've got another animation on the go and this is now a real issue.

I've rebuild the whole website in AE shape layers so I can zoom in, but because I have masks within the pre-comp, I now cannot use the 3D camera. I know I can zoom in, but it would be nice to use the 3D camera as I also want the background elements to move too.

Olly Lawer


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]