ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Project Updated from CS5 to CS6---Now adjustment layers/masks not working correctly?(Sample project uploaded)

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
John Cuevas
Project Updated from CS5 to CS6---Now adjustment layers/masks not working correctly?(Sample project uploaded)
on Jul 31, 2012 at 8:26:00 pm

Created a project in CS5 that has an adjusmement layer in the precomp that blurs the video layer in the main composition. Above my adjustment layer is a masked solid that is parented to a null that is scaling up. For unknown reasons the adjustment layer is not following my solids alpha channel, but just the alpha if it wasn't scaling.

I did this 3 times in this project and the first one works perfectly, the second and third ones do not. If you look at the project, you will see the blur/levels in the main comp follow the text precisely in the first text box, in the next two, they don't follow it at all.

I have the most recent version of CS6.

4469_adjustmentlayerprojectfolder.zip

Johnny Cuevas, Editor
Thinkck.com

"I have not failed 700 times. I have succeeded in proving that those 700 ways will not work. When I have eliminated the ways that will not work, I will find the way that will work."
---THOMAS EDISON on inventing the light bulb.


Return to posts index

Brian Charles
Re: Project Updated from CS5 to CS6---Now adjustment layers/masks not working correctly?(Sample project uploaded)
on Aug 1, 2012 at 1:11:10 am

John;

I'm not entirely sure how this should look. When I open the file the adjustment layers are at the bottom of the layer stack, a technique with which I'm unfamiliar.



Return to posts index

John Cuevas
Re: Project Updated from CS5 to CS6---Now adjustment layers/masks not working correctly?(Sample project uploaded)
on Aug 1, 2012 at 1:21:38 am

The adjustment layers are in precomps and they affect the video layer in the final comp. The final comp is 6.1 Quality Control, and the three precomps are labeled "Title 12" "Title 13" and "Title 14". Title 12 is working correctly in the final comp, but the other two are not.

Thanks for taking a look, I'm completely befuddled and as I have near 50 animations total I have to update, I'd like to figure out why this isn't working in CS6, rather than go back to CS5...
---though to be honest, at this point I think I've come across a bug in CS6.

Johnny Cuevas, Editor
Thinkck.com

"I have not failed 700 times. I have succeeded in proving that those 700 ways will not work. When I have eliminated the ways that will not work, I will find the way that will work."
---THOMAS EDISON on inventing the light bulb.


Return to posts index


Roland R. Kahlenberg
Re: Project Updated from CS5 to CS6---Now adjustment layers/masks not working correctly?(Sample project uploaded)
on Aug 1, 2012 at 2:05:00 am

This could be related to cache files not updating correctly although such an occurrence is normally associated with time-sensitive plugins. Regardless, can you delete your cache files to check if such is the issue.

HTH
RoRK

Intensive AE & Mocha Training in Singapore and Malaysia
Adobe ACE/ACI (version 7) & Imagineer Systems Inc Approved Mocha Trainer


Return to posts index

John Cuevas
Re: Project Updated from CS5 to CS6---Now adjustment layers/masks not working correctly?(Sample project uploaded)
on Aug 1, 2012 at 11:42:23 am

I opened the project on a second computer with CS6 and the exact same issue, but I did clear the cache to check. Still is not working correctly.

Just for fun, I copied and pasted the layers that weren't working in original precomp into a new precomp and everything is working as it should. So something is wrong with my project files in the originals, but if I make new compositions they seem to work. It will be a work around(with 50 videos, a tiresome one) but the project will get finished.

Johnny Cuevas, Editor
Thinkck.com

"I have not failed 700 times. I have succeeded in proving that those 700 ways will not work. When I have eliminated the ways that will not work, I will find the way that will work."
---THOMAS EDISON on inventing the light bulb.


Return to posts index

John Cuevas
Re: Project Updated from CS5 to CS6---Now adjustment layers/masks not working correctly?(Sample project uploaded)
on Aug 1, 2012 at 1:05:28 pm

I was incorrect about copy & pasting, still having the same errors as before, which can be seen in the project I posted earlier.

Unless someone can figures this out, I'm going to send the project to Adobe later as I believe it's a bug/error, I've gone back and opened this project in CS5 & C5.5 versions and it works.

Johnny Cuevas, Editor
Thinkck.com

"I have not failed 700 times. I have succeeded in proving that those 700 ways will not work. When I have eliminated the ways that will not work, I will find the way that will work."
---THOMAS EDISON on inventing the light bulb.


Return to posts index


Roland R. Kahlenberg
Re: Project Updated from CS5 to CS6---Now adjustment layers/masks not working correctly?(Sample project uploaded)
on Aug 1, 2012 at 1:54:01 pm

There's something definitely strange happening and most likely a strange bug is at play.

I tried moving the second and then the third precomps to start first in the timeline and I could see the Adjustment Layer's edges flashing between its desired and unexpected results.

Analogously, when the nested comp that was initially placed first was moved to appear later than one or the other two nested comps in the Timeline, it too started to flash between desired and unexpected results.

BTW, that's a novel and interesting use of an Adjustment Layer. FWIW, I've been cutting down on nesting as much as possible since I've upgraded to a faster rig. I find I have fewer 'AE' issues. Unless I'm going to hit 200+ layers in a 'final comp' I find it best to create everything I need in the 'final comp' unless it is absolutely necessary to have precomps.

Filing a bug will be good for this.

Cheers
RoRK

Intensive AE & Mocha Training in Singapore and Malaysia
Adobe ACE/ACI (version 7) & Imagineer Systems Inc Approved Mocha Trainer


Return to posts index

John Cuevas
Re: Project Updated from CS5 to CS6---Now adjustment layers/masks not working correctly?(Sample project uploaded)
on Aug 1, 2012 at 2:55:24 pm

Thanks for taking a look at this Roland and at the least confirming I haven't lost my mind(at least lost more of it). With the way the project worked, I deleted the the null that was scaling the layers in the precomps and just added the scaling to the precomps in the final composition...different approach to get the same result.

This has just been one of those projects that has taken on a life of it's own-from one language to 9 languages. Had I known then what I know now, I probably would of built the entire thing differently.

Soon as I finish this, I'll contact Adobe about the bug.

Thanks again.

Johnny Cuevas, Editor
Thinkck.com

"I have not failed 700 times. I have succeeded in proving that those 700 ways will not work. When I have eliminated the ways that will not work, I will find the way that will work."
---THOMAS EDISON on inventing the light bulb.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]