ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Problem importing Mocha shapes in AE

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
André Inácio
Problem importing Mocha shapes in AE
on Jul 24, 2012 at 4:10:23 pm

Hi all!
I've just updated to mocha3, and i'm having a problem that i didn't have in mocha 2.

I can't import shapes from mocha to AE CS6 correctly.. only the first frame pastes correctly, all the other frames starts to mess up all the masks.. it happens when i do copy(in mocha) and paste via ''paste mocha mask'' in ae, and when i export as a shape layer.
It only works fine when i export the sequence in B/W images and use it as a luma mask in after effects.

Anyone as had this problem before? I'm getting really frustrated after hours of rotoscoping and not being able to pass the information properly to ae.

Thanks in advance, and sorry for my bad english.

André Inácio

http://www.andreinacio.com


Return to posts index

Ross Shain
Re: Problem importing Mocha shapes in AE
on Jul 25, 2012 at 5:31:57 pm

I have not seen this issue. Your best bet is to contact mocha support and provide a copy of your project: http://www.imagineersystems.com/contact_form

good luck,
Ross

Ross Shain
Imagineer Systems
http://www.imagineersystems.com


Return to posts index

André Inácio
Re: Problem importing Mocha shapes in AE
on Jul 26, 2012 at 9:15:03 am

Yes that's what i did. Apparently it is a CS6 bug, and it is already adressed to the next patch, what means that i'll have to wait for the next patch for CS6

http://www.andreinacio.com


Return to posts index


Daniel Davis
Re: Problem importing Mocha shapes in AE
on Oct 9, 2012 at 11:00:00 pm

I had the same problem. I found a work around, although it's not ideal. If you only key the first frame of your TL in Mocha, even if you are tracking frames well into the TL, and don't key anything else it will paste the mask information correctly.

This means you can't go through and correct your mask. Might be a solution you can use in certain situations.

best of luck!


Return to posts index

Changgeon Keum
Re: Problem importing Mocha shapes in AE
on Dec 27, 2013 at 6:58:46 pm

Hello, André.

Were you ever able to fix your problem? I've experienced the same problem you described. I use AE 5.5 and Mocha Pro 3.2.1. In AE 5.5, my attempts to Edit -> Paste and especially Edit -> Paste mocha mask methods do not work. But File -> Export Rendered Shapes in Mocha Pro works when I bring the rendered shape into AE (with luma matte, etc). I've sent my question to Imagineer and am hoping for a solution at some point.

Best,
Changgeon


Return to posts index

André Inácio
Re: Problem importing Mocha shapes in AE
on Dec 27, 2013 at 9:12:05 pm

Hi!

Yes i was able to fix this problem with the 11.2 update (for After Effects CS6). It was an after effects bug that was fixed with the 11.2 update for AECS6, available for download in the adobe site. In AE CC the problem is also corrected.
I think the best solution for you is really to update your AE version ;)

Best,

André Inácio

http://www.andreinacio.com


Return to posts index


Changgeon Keum
Re: Problem importing Mocha shapes in AE
on Jan 6, 2014 at 4:09:44 pm

Thanks for your response. Yes. The upgrade to CC is the solution. I downloaded a trial of CC just to test it out. It works fine: both the Edit -> Paste and the Edit -> Paste mocha mask modes.

By the way, it only seemed to happen when I had keyframes rotosplines. Mask shapes with no keyframes translated fine when brought into AE 5.5. A moot point at this point.

Thanks again for your input. Happy roto-ing!

Changgeon


Return to posts index

Yuri Reiter
Re: Problem importing Mocha shapes in AE
on Aug 15, 2014 at 3:09:56 am

I am using the Mocha pro v4 but still using CS5.5 as I see no reasons to get CC. But I did have this same problem and have not yet heard from Imagineer. I have 4 masks that are are linked to one master track. Everything looks perfect in Mocha Pro. But when I import into AE the first frame shows one mask, by the 2nd frame the 1st mask disappears and then another mask shows up for a while then disappears, then a new set of masks show up.

What I did notice was that on certain tracks, which had some manual keyframing, the blinking of the frames in AE coincided perfectly with the frames those keyframes were on. I really dont want to have to buy another adobe product! Such a PITA converting all the plugins over. Uggg. There has to be another way.


Return to posts index

Ross Shain
Re: Problem importing Mocha shapes in AE
on Aug 15, 2014 at 3:38:21 am

Have you contacted Imagineer support? This workflow should work fine in CS5. If you view your surface in mocha, is the track data looking correct?

Ross Shain
Imagineer Systems
http://www.imagineersystems.com


Return to posts index


Yuri Reiter
Re: Problem importing Mocha shapes in AE
on Aug 15, 2014 at 6:31:31 am

I have, they are trying to figure it out. Everything looks perfect inside of Mocha. clearly this is an export/import issue. Perhaps I am forgetting to check something off before exporting? Seems pretty straightforward though. And the fact that all masks import fine and are tracked fine but they glitch on/off over time is odd. There is a clear sync though between some keyframes in mocha and where the masks decide to shut off in AE.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]