ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

Problems Animating Logo using a Track Matte

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Nathan KaramanskiProblems Animating Logo using a Track Matte
by on Jun 1, 2012 at 2:47:27 am

Hi, long time reader, first time poster.

Im currently having trouble creating a simple track matte animation. Basically, my goal is to create a multi-colored logo that zips upward from inside of a track matte. I am not sure if this is the technique that i need to use for this situation, but every time I create a shape layer and track matte it to a single color text layer, it works just fine. As long as the layer I am luma track matte-ing is a single color I am not running into any issues. It's when I try and use that same concept on a multicolored logo i run into issues. Once i select the luma/alpha track matte option on my shape layer and connect it to the multi-colored layer above it I cant seem to figure out a way to keep the logo's original color scheme intact. The logo will take on the color property of the single fill color of the Shape layer I am using to Alpha/luma track matte. I've tried using null objects/adjustment layers. Ive also tried making the opacity of the shape layer 0%. All that does is make anything track matte-ed invisible. All i want to do is create a simple square track matte that i can put around a logo and animate the logo upwards or downwards into the track matte without transforming the multi-colored logo into a single color logo. Can anyone help?

Return to posts index

Dan FredleyRe: Problems Animating Logo using a Track Matte
by on Jun 1, 2012 at 8:32:14 pm

  • The logo needs to be below the square shape layer in the timeline window.
  • Make sure both layers are visible at this point.
  • In the comp window make sure the top of the square shape layer is at the top of the logo.
  • Animate the logo so that it comes above the square shape.
  • Make sure the square shape layer is set to 100% opacity.
  • Then on the logo layer in the timeline set the track matte to "alpha inverted matte."
  • The square shape layer's visibility switch should be turned off automatically when you set the track matte
  • Then as you scrub through your timeline the logo should appear as it rises above the shape layer.

Dan Fredley

Return to posts index

Nathan KaramanskiRe: Problems Animating Logo using a Track Matte
by on Jul 1, 2012 at 7:57:08 pm

Ahhh. Thank you! I knew it was going to extremely simple. The C.C. community is the best!

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved