ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

AE alpha not working in photoshop

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Tom DurhamAE alpha not working in photoshop
by on May 17, 2012 at 4:07:53 am

Greetings Folks!

Big comp in AE with many layers. A movie poster. Many of the layers are people masked with nice soft edges. Exported each layer with alpha in hopes of creating a layered photoshop file. (Didn't use "create photoshop layers" because there are a million effects and precomps and adjustment layers that don't translate well.)

So in photoshop, I gather the exports into one layered photoshop file and use the alphas from each export to create masks on each layer. But for some reason, the alphas in photoshop are much too "dim" for lack of a better term. So when I mask a layer using the respective alpha provided by AE, or inverse select it to delete the unwanted background, the image that remains is much more transparent than in the AE comp. It's as if AE exported the alpha at half of its opacity.

Does this description make any sense? If so... please help!!! :)

thanks,

Tom





================================================
YOU can help save TimeSpace. Join the Chronos Protectorate!

http://www.95ers.com
http://www.SpaceAceMedia.com


Return to posts index

Tom DurhamRe: AE alpha not working in photoshop
by on May 17, 2012 at 6:14:01 am

Ah. Figured it out. Straight vs. premultiplied alphas. Photoshop wants them straight. AE defaults to premultiplied. Seems like with the photoshop preset in AE they would default it to the kind of alpha photoshop likes... but whatever. :)





================================================
YOU can help save TimeSpace. Join the Chronos Protectorate!

http://www.95ers.com
http://www.SpaceAceMedia.com


Return to posts index

Kevin CampRe: AE alpha not working in photoshop
by on May 17, 2012 at 3:29:49 pm

i'd agree... you can change that photoshop preset to always be straight (unmatted) by clicking menu button next to the output module, selecting the make template option and then choose delete (to delete the 'untitled' preset that it automatically generates).

then choose the photoshop setting from the list, click edit and set it to straight unmatted then click ok.

another option (what i usually do) is render to png. no problems there -- technically, there's no actual alpha channel, it just renders a layer with transparency so you don't need to apply the alpha as a matte in photoshop.

you can create a png preset (using same make template option above). just give the 'untitled' template a name, click edit and set the format to png sequence and click ok.

you can then also make that the default for still frame rendering by choosing that template from the list for 'frame default' in the output module templates window.

lastly, if you happen to render out an image sequence with alpha, take it into ps and then realize that you didn't set it to straight with alpha, once you create a matte from the alpha, apply it to the layer and then choose layer>matting>remove black matte to avoid needing to re render.

Kevin Camp
Senior Designer
KCPQ, KMYQ & KRCW


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]