ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

How do i make AE not blur my graphics by default?

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
David Ghast
How do i make AE not blur my graphics by default?
on May 12, 2012 at 8:48:38 pm

I was trying to place this simple 7x32 graphic side by side when i noticed gaps or overlaps between them.



I zoomed down in AE CS5 to get a closer look and found what appeared to be feathered edges:



Checking to see if the graphic really did have feathered edges i opened it up in acdsee and found it was normal:




So i went back into AE and exported it out to see if it were just a preview anomaly and opened it in acdsee to find this:





So it looks like AE forces a blur. Anyone know a workaround?

=======
Update:

I remembered that AE likes to do subpixel feathering when the comp dimensions are indivisible with the asset dimensions, so i made a comp that was 49x82 and it got rid of the feathering in AE:



But when when i rendered it out again and opened it up in ACDsee i got this:



So it looks likes AE blurs graphics regardless.


Return to posts index

Dan Fredley
Re: How do i make AE not blur my graphics by default?
on May 12, 2012 at 10:21:36 pm

Try setting the transfer mode to "Alpha Add."

Dan Fredley


Return to posts index

Roland R. Kahlenberg
Re: How do i make AE not blur my graphics by default?
on May 13, 2012 at 12:45:36 am

[David Ghast] "I remembered that AE likes to do subpixel feathering when the comp dimensions are indivisible with the asset dimensions"

This is incorrect. AE resamples a layer when the difference between a layer's Anchor Point and Position values is not an integer - separately for x and y coordinates,

Try these -
1) create a 50x50 pixel solid
2) place it at position (200,50.5)
3) notice that the top and bottom of the solid is anti-aliased
4) change its Anchor Point value to (25,25.5)
5) notice that the anti-aliasing goes away

Experiment with different values and you will see that the statement in my first paragraph accurately describes the resampling issue.

The fix is to either set the layer to draft mode, where AE does not calculate motion with sub-pixel accuracy. This is likely to be undesirable if your layer is being animated.

The other fix is to ensure that the difference between your Anchor Point and Position values result in a integer.

HTH
RoRK

Intensive AE & Mocha Training in Singapore and Malaysia
Adobe ACE/ACI (version 7) & Imagineer Systems Inc Approved Mocha Trainer


Return to posts index


David Ghast
Re: How do i make AE not blur my graphics by default?
on May 13, 2012 at 2:10:05 am

I tried the two suggestions so far which turned out to be right as far as the subpixel issues go ( or at least one way to solve them ):



but the problem remains, whether i use "alpha add" or make sure the positions are whole numbers or use export with draft quality:




AE blurs graphics and there doesnt appear to be any way to prevent it.


Return to posts index

Roland R. Kahlenberg
Re: How do i make AE not blur my graphics by default?
on May 13, 2012 at 2:35:43 am

It looks like you're trying to post images but all I see are broken links to images. Try and post them directly to the COW - there is a camera icon just to the top of each message input area.

[David Ghast] "whether i use "alpha add" "
This doesn't work!

[David Ghast] "make sure the positions are whole numbers"
It's not just the position values. Please re-read my original post.

[David Ghast] "use export with draft quality"
Please re-read my original post. I suggested that you set the layer to draft quality. You do so by clicking on the forward slash icon in the Timeline (to the left of the fx switch). When the line is full, the layer is at full quality. When the line has a dash, it is at draft quality. I'm not certain how setting the Render Settings to draft quality works - it may be analogous to a layer being in draft quality, it could not. Therefore, it's best to set the layer to draft, if you can or have to.


[David Ghast] "AE blurs graphics and there doesnt appear to be any way to prevent it."
Do you by any chance have Camera DOF switched, an effect applied or if you are using pre CS6, do you have OpenGL enabled?

As a last resort, you may want to post and AEP which includes your graphic.

HTH
RoRK

Intensive AE & Mocha Training in Singapore and Malaysia
Adobe ACE/ACI (version 7) & Imagineer Systems Inc Approved Mocha Trainer


Return to posts index

David Ghast
Re: How do i make AE not blur my graphics by default?
on May 13, 2012 at 5:15:10 am

Um ok, then use a different browser if yours is broke. Dont know what else to say, im asking for what amounts to a fix to a design fault. Ive ran into this before where thin transparencies are blurred into uselessness, i guess this is why no major motion picture uses AE for anything serious, if at all. I guess its time to start learning nuke.


Return to posts index


Darby Edelen
Re: How do i make AE not blur my graphics by default?
on May 13, 2012 at 6:33:16 pm

[David Ghast] "Ive ran into this before where thin transparencies are blurred into uselessness, i guess this is why no major motion picture uses AE for anything serious, if at all. I guess its time to start learning nuke."

Nuke is definitely worthwhile to learn, but I wouldn't abandon AE either.

You've been given a fix for your sub-pixel sampling issue: change the layer quality switch from Best to Draft. This is a per-layer switch in the composition timeline. You could also change it in the Layer menu with your layer selected.

Nuke has a ton of sub-sampling choices where as AE only has these two, so if you're disappointed with these options it might be time to explore others.

Darby Edelen


Return to posts index

Walter Soyka
Re: How do i make AE not blur my graphics by default?
on May 13, 2012 at 12:06:51 pm

[David Ghast] "AE blurs graphics and there doesnt appear to be any way to prevent it."

That's not true at all.

See 4133_shadtile49x82aep.zip, created from the PNG file you originally posted.

Here's a view of the nice, clean alpha channel [image]:


I noticed that your viewer was zoomed to 1600% in the images you posted where you were evaluating the image quality. Is it possible that your image viewer was adding antialiasing?

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index

David Ghast
Re: How do i make AE not blur my graphics by default?
on May 14, 2012 at 3:51:35 pm

No, one of the first pictures i posted was the original png zoomed 2400% in with acdsee and looking normal.


Return to posts index


Walter Soyka
Re: How do i make AE not blur my graphics by default?
on May 14, 2012 at 5:58:22 pm

[David Ghast] "No, one of the first pictures i posted was the original png zoomed 2400% in with acdsee and looking normal."

Sorry, I missed that.

Did the AEP file I posted render cleanly for you?

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index

David Ghast
Re: How do i make AE not blur my graphics by default?
on May 15, 2012 at 6:09:07 am

Not sure what you did there but its producing the inverse of what it is. Also when the comp's width increases the whole thing goes to hell. Thanks anyways.


Return to posts index

Walter Soyka
Re: How do i make AE not blur my graphics by default?
on May 15, 2012 at 10:30:05 am

[David Ghast] "Not sure what you did there but its producing the inverse of what it is."

Like I said in my original post, the image I showed here was the alpha channel. You were complaining about blurry transparency, so I was showing you that the alpha output was clean.


[David Ghast] "Also when the comp's width increases the whole thing goes to hell. Thanks anyways."

Read Roland's description of anchor and position again.

The layers' width in pixels is odd, so their center point is a half-pixel. When the comp's width is also odd, its center point is a half pixel, so everything works.

The comp's width is currently an odd number, and the layer's width is an odd number. Because all the layers are centered in the comp, they are both positioned and anchored on a half-pixel. If you increase the comps' width to an even number of pixels (and leave the comp's anchor centered in Composition Settings > Advanced), then their positions will be a whole number and you will have a fractional difference between the layers' anchor points and position points. This fractional difference will cause sub-pixel sampling.

If you want to avoid sub-pixel sampling, make sure that the difference between a layer's anchor point and its position is a whole pixel, as Roland said. That means nudging the layers half a pixel right or left.

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]