ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Luma/Alpha Mattes Camera Issue

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
S.J. DeLuise
Luma/Alpha Mattes Camera Issue
on Apr 14, 2012 at 1:59:06 pm

I have a pre-comp with 2 layers that have a Luma Matte on them.
In the main comp I have a camera. Continuous raster is on for the pre-comp layer.
When I move the camera around, the layers in the pre-comp that have the track mattes on them don't move with the camera - the other 3d layers move normally. But when I turn off the track mattes in the pre-comp, they behave normally with the camera. What am I missing here?

People say my motion graphics are moving.


Return to posts index

Erik Waluska
Re: Luma/Alpha Mattes Camera Issue
on Apr 14, 2012 at 3:45:22 pm

The Continuous Rasterization switch (called the Collapse Transformations switch on a pre-comp) makes the layers inside the pre-comp behave as if they are in the main comp. So any layers that are not 3D in the pre-comp will not be 3D in the main comp, regardless of whether the pre-comp itself is 3D.


Return to posts index

S.J. DeLuise
Re: Luma/Alpha Mattes Camera Issue
on Apr 14, 2012 at 6:35:35 pm

That I know, and the layers in question are indeed 3D inside the precomp and in the main. The issue is the track mattes. When they're switched on the layer doesn't behave as 3D or respond to camera moves. Where they're off, they work again.

People say my motion graphics are moving.


Return to posts index


Erik Waluska
Re: Luma/Alpha Mattes Camera Issue
on Apr 14, 2012 at 7:38:23 pm

Are ALL of the layers in the pre-comp, including the track matte layers, 3D? If not, that could be the issue.


Return to posts index

S.J. DeLuise
Re: Luma/Alpha Mattes Camera Issue
on Apr 14, 2012 at 7:57:58 pm

Yes, every single layer is 3D.

People say my motion graphics are moving.


Return to posts index

Erik Waluska
Re: Luma/Alpha Mattes Camera Issue
on Apr 14, 2012 at 8:25:30 pm

I would try pre-comping each of the layers with their track mattes inside of your pre-comp and turn on the 3D switch for them but not the collapse transformations switch and see if that works.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]