ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

When i render, the blacks become grey

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Alberto FontanaWhen i render, the blacks become grey
by on Mar 5, 2012 at 2:28:42 am

Good morning.

I recently formatted my computer (changing from ATI to NVIDIA) and i'm experiencing a very strange problem with AE CS5.5. When i render with AE, the resulting video is lighter than the original video. Especially the blacks are not anymore blacks...they're kinda dark grey. If you take a look at this picture where i compare on the right the original clip and on the left the rendered clip
http://www.fontanavideostudios.com/public/blacks.jpg
you can clearly see how the blacks lost intensity after rendering.
It's not an optical illusion, because i checked the blacks into photoshop and, as you can se from the RGB values, they're different.
I'm getting crazy because i can't find out why this is happening!
If i make an AVI lossless render, the result is ok. So, the issue occurs only when i use the H.264 codec.

-I (obviously) removed any effect. I simply dragged the video in a new comp, then exported it.
-I use: Render settings: BEST. Output format: H.264, mainconcept, 11Mbps
-I installed VLC 2.0 and the K-lite mega codec pack. And i tried to play the videos with all the players but the result is always the same(so the problem is not in the media player)

Can anybody help me to figure out where the problem is?
Thank you guys, this forum is really helping me a lot


Return to posts index

Paul RoperRe: When i render, the blacks become grey
by on Mar 5, 2012 at 4:58:02 pm

You've kinda answered your own question - DON'T use After Effects to output an H264! You will, undoubtedly, get quite a few answers along these lines.....
DON'T use After Effects to output an H264!
DON'T use After Effects to output an H264!
DON'T use After Effects to output an H264!
DON'T use After Effects to output an H264!

After Effects is not optimised for video compression - if you need a compressed video file, output from After Effects using one of the Lossless/uncompressed/non-temporally compressed formats such as ProRes 422 or Uncompressed 10-bit, then use one of the many compression programs to create your final, compressed movie.

So, make a lossless AVI render from After Effects (this shows that After Effects is rendering OK, it's just the compression process that's screwing things up) then you can try many different compression codecs/settings as you like in Apple Compressor, Cleaner, Adobe Media Encoder or whatever compression software you use, without having to go through the unnecessary step of re-rendering.

There are probably about 5 posts per week on this forum from people having problems outputting a render to H264 or some such codec. I wish Adobe would actually REMOVE the option to do so - it is a complete waste of time!

- Paul


Return to posts index

David GhastRe: When i render, the blacks become grey
by on Mar 7, 2012 at 11:04:51 pm

Oh, with nvidia theres an option in the control panel, "adjust video color settings" select "use nvidia settings", then go to advanced tab, and select full dynamic range. I know, why dont they do it by default, but its nvidia, be happy anything works at all.


Return to posts index


Alberto FontanaRe: When i render, the blacks become grey
by on Mar 7, 2012 at 11:19:51 pm

ARE YOU KIDDING ME?? o.O Oh my god, that really worked!!! Now the blacks are restored...but...that's so strange...i have some question now!

1)Before changing the setting you said, the original footage was perfect, and the rendered video was not good. Now, after having changed that setting, the original footage is still perfect, but the rendered video now have become perfect!
So: if the setting is only about the output from GPU to monitor and not about the AE rendering, why do the original footage is perfect in both situation, but the rendered video is not? What really changed with that setting?

2)Is it true that the H.264 in AE is not good, like Paul said?

3) why does nvidia has a so stupid setting by default?


Return to posts index

Paul NordinRe: When i render, the blacks become grey
by on Mar 11, 2012 at 5:13:55 pm

I'm having the same problem on my MacPro system.
(OSX 10.3.7, CUDA 4.1.29, Nvidia driver 270)

is there a way for me to make a similar switch to the NVideo config?

_______________________
El Mundo Bueno Studios
Film * Audio
http://www.EMBstudios.com
Emeryville, CA
_______________________


Return to posts index

Barnaby FredricRe: When i render, the blacks become grey
by on Sep 16, 2012 at 3:51:45 pm

I love you! You just made my videos look so much better!!!!


Return to posts index


Tomas ZelenyRe: When i render, the blacks become grey
by on Sep 8, 2014 at 2:35:35 pm

I am not using CUDA or any graphic card for rendering. The scene looks 200% lighter with ANY compression, but with NO compression looks the render same like in AE. But after conversion to all compressions (Format Factory) - the same problem. I tried the HDTV (Rec. 709) profile for rendering and the result is better, but still cannot make any color adjustments in AE - still different... Adobe Help is also useless...


Return to posts index

Alberto FontanaRe: When i render, the blacks become grey
by on Sep 8, 2014 at 4:31:57 pm

I actually found the issue....which fixes my problem. It's the stupidest issue ever and it concerns nvidia drivers and not AE.

If you go to (i have the italian SW, so i'm going to translate literally) nVidia control panel -> video (on the bottom) -> Change video settings -> advanced -> then you change from limited (16-235) to maximum (0-255).

Now your exported videos should look better with blacks properly rendered.

What's strange is that if you play the video with VLC (before applying my fix) it looks washed out. If you play it with Windows Media Player it looks good.

Hope it helped


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]