ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Adobe After Effects Insufficient RAM. Multiprocessing disabled.

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Martin LawrenceAdobe After Effects Insufficient RAM. Multiprocessing disabled.
by on Feb 13, 2012 at 4:44:06 am

Hello,

I have been working a lot with editing video in After Effects but when I try to do RAM preview with After Effects Multiprocessing I get an error saying "Insufficient RAM. Multiprocessing disabled." I have a core i7 with 16GB of RAM. I don't know what the problem is nor how to fix it. Does anyone have any ideas?

I'm running:
Mac OSX Lion
Adobe CS5.5

Sincerely,
Martin




Return to posts index


Angelo LorenzoRe: Adobe After Effects Insufficient RAM. Multiprocessing disabled.
by on Feb 13, 2012 at 5:22:40 am

The rule of thumb for multicore processing you'll hear is two gigs of RAM per core used.

So lets take a look:
AE & Premiere share 12 gigs of RAM according to your settings. Usually, Adobe programs split memory management evenly; if you turn multicore processing on then try not to have Premiere open or plan on optimizing your settings for 6 gigs of RAM.

Try running only three processor threads (3*2=6 gigs of RAM) and check performance.


Return to posts index

Todd KoprivaRe: Adobe After Effects Insufficient RAM. Multiprocessing disabled.
by on Feb 13, 2012 at 8:48:14 am

Tell us about the composition that you're trying to render. If you're trying to render something that requires greater than a 2GB image buffer, for example, then After Effects will go back to using just the foreground process for rendering.

---------------------------------------------------------------------------------------------------------
Todd Kopriva, Adobe Systems Incorporated
Technical Support for professional video software
After Effects Help & Support
Premiere Pro Help & Support
---------------------------------------------------------------------------------------------------------


Return to posts index


Martin LawrenceRe: Adobe After Effects Insufficient RAM. Multiprocessing disabled.
by on Feb 13, 2012 at 6:25:02 pm

I restarted my computer to reset my memory. I only set optimization for 3 cores, 2GB per, and it works pretty well. More RAM would help but I just don't have the money right now.

Thank you for your help!


Return to posts index


Andrew SomersRe: Adobe After Effects Insufficient RAM. Multiprocessing disabled.
by on Feb 13, 2012 at 8:46:48 am

First off:

1) Reboot - this is the best way to fix memory leaks - you have probably been doing a lot of work in these apps, and possibly other apps, and have "lost memory".

2) Don't run Premiere at the same time - premiere will take memory resources away from AE rendering.

3) See if you can set a lower GB per CPU - depending on your project bit-depth, and the complexity of your comp, you may be able to get away with smaller RAM allocations per CPU.

4) Get more RAM. RAM is the best way to improve system performance. IMO 16GB is *bare minimum* if you just want to run After Effects all by itself - and don't expect o be able to use too many processors. If you want to run other apps, then you really need more.

For running several big apps at once, 24 GB is a minimum - but 32 (or more if your system allows) will let you get the most from your system.

5) Remember that when you turn on MP, a *separate* background instance of AE is launched, for *each and every CPU" you have specified. Each instance needs its own RAM. If you want to be taking good advantage of multiprocessing, you need a lot of RAM. If you increased your system up to 24 GBm you should be able to use 3 or 4 CPUs for MP (with 2 or 3 GB allocated to each). If you want to do more, you need to bump up to 32 GB.


Return to posts index

Martin LawrenceRe: Adobe After Effects Insufficient RAM. Multiprocessing disabled.
by on Feb 13, 2012 at 6:28:26 pm

Restarting my computer is what did the trick. I then lowed the amount of RAM per CPU so then it actually used 7. I then took the first suggestion by Angelo Lorenzo and lowered the amount of CPU's reserved so AE is only using 3 CPUs and bumped my RAM per to 2GB. It works well and now I just need to get the money for more RAM.

Thank you for your help!


Return to posts index


Todd KoprivaRe: Adobe After Effects Insufficient RAM. Multiprocessing disabled.
by on Feb 13, 2012 at 6:30:04 pm

There's a lot more detail about memory & multiprocessing settings in After Effects here.

---------------------------------------------------------------------------------------------------------
Todd Kopriva, Adobe Systems Incorporated
Technical Support for professional video software
After Effects Help & Support
Premiere Pro Help & Support
---------------------------------------------------------------------------------------------------------


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]