ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

After Effects recovery time extremely slow

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Ian GallowayAfter Effects recovery time extremely slow
by on Feb 4, 2012 at 3:04:28 pm

Hi. I'm running AE CS5 on a quad core i7 2011 Macbook Pro, 8Gb RAM.

Render speeds and work speeds seem to be absolutely fine, UNTIL I complete a render. After a render has finished, the machine is incredibly sluggish until I give it a reboot. It still seems to render frames quite happily in the workspace, but typing, renaming, and any other application performs incredibly slowly.

Obviously I expect this to be the case while a render is running, but there seems to be no pick up in general computer speed once the render has finished.

Any ideas?


Return to posts index

John CuevasRe: After Effects recovery time extremely slow
by on Feb 4, 2012 at 3:58:12 pm

One thing you could try is under Edit > Purge > All. Might free up RAM that AE has grabbed.

Johnny Cuevas, Editor

"I have not failed 700 times. I have succeeded in proving that those 700 ways will not work. When I have eliminated the ways that will not work, I will find the way that will work."
---THOMAS EDISON on inventing the light bulb.

Return to posts index

Erik WaluskaRe: After Effects recovery time extremely slow
by on Feb 4, 2012 at 6:41:58 pm

Yes, it definitely sounds like a RAM problem. I would try reducing the amount of RAM dedicated to AE in the preferences and see if that helps.

Return to posts index

Andrew SomersRe: After Effects recovery time extremely slow
by on Feb 5, 2012 at 3:14:31 am

In your system utilities folder, there is a program called "Activity Monitor".

I leave it running at all times.

It will show you how RAM is being allocated, and processor utilization, etc.

KEY NOTES on Activity Monitor:

1) There should ALWAYS be SOME "GREEN" in the RAM indicator. ALWAYS. If you let yellow and blue take over all the green, then your system is forced to use paging (aka virtual memory) to the hard drive. this will drag your system to a virtual halt (pardon the pun).

2) Don't focus on trying to redline all your processors all the time - just because you have a quad core does not mean you necessarily want to have AE try and use all 4 (especially when you don't have the RAM to do so).

KEY NOTES on your system:

1) You don't have enough RAM. I have 24 GB on my Octocore, and sometimes I think that is not enough.

2) With only 8GB of RAM, turn multiprocessing OFF. Uncheck the "Render multiple frames simultaneously" in the "Memory and multiprocessing" preferences pane. Note that if you use too many CPUs, your total render time can actually increase due to system resource shortages. "Less is more" in many cases.

3) Also in your memory pane, make certain that there is enough RAM for other processes - I don't think you can even set it below 3. I leave mine at 6. Obviously for you, you need to have all other applications quit, and set to 3 or 4.

4) If you *DO* use multi processing, only use 2 processors, so set 2 as reserved for other applications. Set RAM per core to 1 GB. This may not be enough if you are doing large comps in 32 bit mode.

5) You can expand RAM on your system to GB - if you think you would get benefit from multi-processing, then upgrade your RAM. Nevertheless, with 16 GB I'd suggest reserving 4 GB for other apps (provided you run no other apps except Activity Monitor), use no more than 3 CPUs, and when you allocate more than 1 GB of RAM per core, watch Activity Monitor, and take note how much free (green) RAM remains during and at the end of a render.


For the record, I mainly use a MacPro Octocore with 24GB of RAM - "RAM reserved" is set to 6 GB, I use only 4 of my 8 processors under multiprocessing, and I set the RAM to 3 GB for each of them. Considering disk bandwidth, this seems to be a good compromise on responsiveness.

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved