ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

All of my keyframed masks are rendering one frame off, but look correct within the comps

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Evan SeitzAll of my keyframed masks are rendering one frame off, but look correct within the comps
by on Jan 29, 2012 at 5:51:35 pm

What is this madness!?


Return to posts index

Andrew SomersRe: All of my keyframed masks are rendering one frame off, but look correct within the comps
by on Jan 29, 2012 at 10:46:31 pm

Are all of your comps at the exact same frame rate?


Return to posts index

Evan SeitzRe: All of my keyframed masks are rendering one frame off, but look correct within the comps
by on Jan 30, 2012 at 2:02:21 am

Yep.


Return to posts index


Michael SzalapskiRe: All of my keyframed masks are rendering one frame off, but look correct within the comps
by on Jan 30, 2012 at 2:33:17 pm

What is the frame rate of your compositions? What is the frame rate at which you are rendering them?
Is your footage interlaced?

- The Great Szalam
(The 'Great' stands for 'Not So Great, in fact, Extremely Humble')

No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.


Return to posts index

Michael SzalapskiRe: All of my keyframed masks are rendering one frame off, but look correct within the comps
by on Jan 30, 2012 at 2:36:28 pm

Also, what version of AE are you using and what assets are in your composition? Is it CS4? Do you have HDV footage or footage from a DSLR?

- The Great Szalam
(The 'Great' stands for 'Not So Great, in fact, Extremely Humble')

No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.


Return to posts index

Evan SeitzRe: All of my keyframed masks are rendering one frame off, but look correct within the comps
by on Jan 30, 2012 at 9:47:33 pm

It's all at the same frame rate with no real footage (30 fps). Only assets are from C4D, Action Essentials, and masking solids in After Effects. If it's a frame rate issue, I've never run into it before using those elements. Are there any other possibilities?


Return to posts index


John HadwinRe: All of my keyframed masks are rendering one frame off, but look correct within the comps
by on May 7, 2012 at 5:22:26 pm

Evan,

I am having the same problem running AE CS5 on an 8 core (Snow Leopard) Mac Pro. Over the last month it has cost me untold hours of re-render time. Did you find a solution?

The only work around I can find is to literally move the problem layer and it's mask to the incorrect frame. So on the timeline, and during preview, the cut will be off by one, but when I render they are not off by one. Using this absolutely unacceptable work around has been my only saving grace, allowing to re-render at the cost of several hours of re-render time instead of losing the job itself. Where is Adobe on this?

~John Hadwin


Return to posts index

Evan SeitzRe: All of my keyframed masks are rendering one frame off, but look correct within the comps
by on May 7, 2012 at 5:46:37 pm

I ended up doing the same thing that you are doing until the end of my project. That particular project was "ABCinema", so yeah - it was definitely a nightmare. Regardless, ever since, I haven't encountered the problem again. One thing that I tried in brand new projects going forward that may have helped was that whenever I did import a filmed effect - I immediately right clicked it in the viewport and made it my composition's frame rate... but in the end, I really think it was just a glitch in the project I was working in on Adobe's side - not user error.

If it's happening in other projects that you start from scratch, you may want to try reinstalling the program or contacting Adobe for specialized help.

Hope this helps,
Evan


Return to posts index

Dumytru NemţucRe: All of my keyframed masks are rendering one frame off, but look correct within the comps
by on Jun 13, 2014 at 6:56:26 pm
Last Edited By Dumytru Nemţuc on Jun 14, 2014 at 8:53:55 am

Okay, I had the exact same problem. And it's annoying!
And masking the previous frame wasn't exactly an option, since in my case it would double the work I have to do.

So here's what fixed it for me.
Context:
I have a lagarith video imported. In the "Interpret Footage" menu I selected "Use framerate from file (23.97)".
I dropped the video to a new composition. As you probably expect, the new comp should have the same framerate as the footage. And it does, 23.97.
Solution: The actual framerate of the footage is 23.976.
In had to change it from 23.97 to 23.976 manually, both in the Interpret footage and in the composition, and that did it.

It's likely that if you encounter this bug, it's probably because of the incorrect framerate. After Effects apparently imported the footage with the wrong fps and when it rendered the movie, it used the actual fps, which messed up the masking.

Hope that helps some of you who have this very annoying problem.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]