ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

Mask not working properly?

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Andrew SohMask not working properly?
by on Jan 20, 2012 at 6:45:03 am


Please bear with me as I try to explain the problem I'm having.

I'm trying to do a little bit of an animation with a logo.

The logo looks like this (somewhat).

Basically the ring is rotating around the words 'OSG'. Due to poor lighting in 3ds max I had to redo the 'OSG' words and try to composite them back again in AE.

In AE, as I place the new render of the words 'OSG', the layer was then on top of everything, even the rotating ring.

So I duplicated the RING layer, put the duplicate at the very top (above the WORDS layer), then masked around the areas so it would seem as though the ring goes around the words.

Like this:

--Now to the problem. Masking has been done fine. The problem is after I render a sequence or video file of it, I start to see the letter of the word 'OSG' bleed through at one edge.

Like so:

The letter 'G' appears on the side of the ring.

Here's a closer look at the last two:

I really don't know what's going on. It's at though the mask is shifting or something. Can someone please tell me what I'm supposedly doing wrong?

NOTE: This ONLY happens when I render it out as PNG sequence or even a VIDEO file. BUT this DOESN'T happen when I render out a still image. So it's really weird.
The frame rates are fine.

Thanks for reading up to here and hopefully someone understands what I tried my best to explain and can help me out as I'm tired of losing most of my hair.


Return to posts index

Tudor "Ted" JelescuRe: Mask not working properly?
by on Jan 20, 2012 at 10:08:42 am

It may be an OpenGL error- if you are using OpenGL turn it off.
Also, are you by chance making the top ring layer a 3d layer? If that is so, then use it as a 2d layer.

Tudor "Ted" Jelescu
Senior VFX Artist

Return to posts index

Andrew SohRe: Mask not working properly?
by on Jan 21, 2012 at 3:03:34 pm

No not using OpenGL. Also not using 3D layer.

Is it because those layers are precomped? I am putting the precomped (RING) layer above the WORD layer, then duplicating the ring layer and putting that on top the WORD layer. Maybe it's not good to use precomped layers on top of each other?

Return to posts index

ben g ungurenRe: Mask not working properly?
by on Jan 21, 2012 at 3:26:14 pm

I've had problems with nested rotoscopes when the frame rate doesn't match up exactly. Even something like 23.976 in a 24fps comp will send things awry. Check to make sure your comp frame rates are identical. If that doesn't work, you can use a series of hold keyframes (this only works if you don't need motion blur on your moving mask):

Option-click your mask path to make an expression -- for the expression, type in "value" or just leave it at the default. This should create an expression that creates the same result as before you had the expression. Then right click on the mask path and choose Keyframe Assistant --> Convert Expression to Keyframes. This gives you a keyframe on EVERY FRAME of your animation for that value. Finally, select all the keyframes, right click on them and choose Hold Keyframes.

If this fixes the problem, here's why:
Before, AE wasn't reading your keyframed mask value; rather it was reading an interpolated (halfway-between) value somewhere between two keyframes, even if those keyframes were right next to each other. By enabling hold keyframes, you force AE to read the last available keyframe for the mask, so no more interpolation troubles!

Ben Unguren
Motion Graphics & Editing

Return to posts index

Bret WilliamsRe: Mask not working properly?
by on Jan 22, 2012 at 7:21:08 am

I get these kinds of errors all the time in complex 3D models built of flat planes in AE. On one frame something will decide it's in front of, then the next frame it's behind, then the next it's in front of, etc. This example really looks like that. But if they aren't 3D layers then it's something else. Could be a related bug. But could be the keyframes of the mask aren' t linear and are jumping around. I like the hold keyframes idea. Gonna try that on my 3D comp I'm currently having issues with.

If none of this works, just try simplifying. Put the mask on the text, and do try to do the sandwich of layers. Ring on the back layer, text in front, and use the mask (same mask) on the text layer in subtract mode to hide those areas of the text instead. That way there is no reliance on the "sandwich" of layers cooperating. Hidden/masked text is hidden/masked text.

Return to posts index

Matthew KeaneRe: Mask not working properly?
by on Jan 22, 2012 at 2:24:02 pm

I think Ben is on the right track with this. I've had problems in the past with motion tracking going awry when the tracked 25fps sequence was nested in a 25fos sequence - AE interpolates the movement and things don't line up. However, in your precomp composition settings, there is an option to 'preserve frame rate when nested' (I forget the exact wording) which might sort out your problem more quickly than redoing your keyframes.


Return to posts index

Andrew SohRe: Mask not working properly?
by on Jan 26, 2012 at 3:36:39 am

@Ben: I tried doing what you said but it didn't work for me. I tried to right click the mask path but there is no option for 'keyframe assistant'. So I think were talking about my keyframes so I selected all of them, converted the expression to keyframes which made them turn into round keyframes, then 'hold keyframes' which made them into squarish keyframes with a left indentation. But when I rendered out it was still the same. Thank you as your suggestion helped in explaining it to Matthew.

@Bret: That is actually such a simple solution that I'm amazed at how I tried to make it so complex. Thanks!

@Matthew: This worked for me! Yes I went to comp settings and checked that and it worked perfectly. Thanks.

Thanks for all the replies guys. I appreciate it. I'm glad to at least have learned something new and can sleep peacefully now :)


Return to posts index

Matthew KeaneRe: Mask not working properly?
by on Jan 26, 2012 at 10:09:26 am

I obviously typed that way too fast! It was meant to read:
"when a tracked 24fps sequence was nested in a 25fps sequence"

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved