ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

mask not working on layer

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Aditi Khosla
mask not working on layer
on Jan 16, 2012 at 6:40:39 pm

The end result of my video is meant to be me writing a letter (gesturing it in the video, and as I move my finger, lines appear to form the letter). I'm not using motion tracking, i'm simply using Trapcode Particular and adjusting the positional value as my finger moves. Since I had to rotate the layer, the edges are showing up within the frame, which makes it look awful. the first picture is of the problem *top of the window, in the middle*. The second picture is with the mask, and I've increased the mask feather but it's not applying itself to the layer... the third picture shows that the mask is clearly just not working at all on the layer, I added a point and dragged it over the layer, showing that it's not making any difference.....

I tried blurring the edges using all the Blur's under the effects menu but nothing seems to work... How do I soften these edges??












Return to posts index

Kevin Camp
Re: mask not working on layer
on Jan 16, 2012 at 6:51:19 pm

some effects will ignore masks, particular is one of those.

however you can do the same thing with a track matte. create a new solid and create a mask on that solid as needed.

place it above the particular layer and then from the modes panel in the timeline, set the particular layer to use the layer above it as a track matte (alpha matte).

Kevin Camp
Senior Designer
KCPQ, KMYQ & KRCW


Return to posts index

Andrew Somers
Re: mask not working on layer
on Jan 16, 2012 at 6:56:04 pm

First off, don't rotate the layer. If you have to do that as a work around, then increase the layer's size.

But you should not need to rotate the layer as Particular works in 3D space, you can move and rotate the particles however you want in 3D space.

If you production camera is moving, then create a 3D track, and use that comp with a 3D camera, and particular will move with the production camera.

Why are you rotating the layer that particular is on?

As for masks - Particular will not use any masks applied to the layer, you need to use an alpha matte.


Return to posts index


Aditi Khosla
Re: mask not working on layer
on Jan 16, 2012 at 7:02:59 pm

Thanks so much for the immediate response.

As for having the emitter follow my hand, how do I get it to stay in the shape of the D? That's why I'm rotating it because I want it to follow my hand as well as have the trail be in the same shape...


Return to posts index

Andrew Somers
Re: mask not working on layer
on Jan 16, 2012 at 7:15:42 pm

Go under the "WORLD TRANSFORM" section, near the bottom of the plug in, above "Visibility".

ALTERNATELY, create a camera in the comp, and animate the camera - Particular will obey the camera movements.


Return to posts index

Aditi Khosla
Re: mask not working on layer
on Jan 16, 2012 at 7:26:16 pm

Its still not retaining the shape.. is it possible to apply a motion path?


Return to posts index



Kevin Camp
Re: mask not working on layer
on Jan 16, 2012 at 7:51:37 pm

since the movement to trace your finger is pretty much x and y, you could simply create a mask path on a layer in the shape that follows your finger and then copy/paste the mask shape in the xy position property of the emitter.

Kevin Camp
Senior Designer
KCPQ, KMYQ & KRCW


Return to posts index

Aditi Khosla
Re: mask not working on layer
on Jan 16, 2012 at 9:45:55 pm

Thanks Kevin :)


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]