ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

After Effects Rendering Problem!

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Harry GroomAfter Effects Rendering Problem!
by on Jan 12, 2012 at 11:14:01 am

I have a restless issue here with rendering and RAM preview. I am simply trying to create a viral ad which uses the cloning effect I achieved with masking for my college coursework and I have completed the process of creation but I have ran into problems. The RAM preview will only play up to a certain point then it will just stop and this effects the final render because it gets to the point in the rendering where the RAM preview stops and then a message will pop up saying the rendering has failed or something? (Screenshots Below)

I have tried RAM previewing just one of the three videos I am using and it still stops at the same point.

I am using .avi files and have tried converting to .mov, .mp4, .wmv all of which didn't work.

I am using After Effects CS4 ver
My computer specs
AMD SEMPRON processor 2.7Ghz (single core)
2GB RAM (I know its not alot ;))
ATI Radeon HD 5600 512mb
Creative audigy 2 sound card
Windows XP Serivice Pack 3

It's quite urgent and I hope someone can help!


Return to posts index

hosein alfaRe: After Effects Rendering Problem!
by on Jan 12, 2012 at 11:40:53 am

perhaps the open gl of your GPU is not recognize with ae .
go to prefermence option in ae , change this option .

Return to posts index

Tudor "Ted" JelescuRe: After Effects Rendering Problem!
by on Jan 12, 2012 at 1:31:46 pm

If you use OpenGL, turn it off. Adobe recommends that as well.
Try rendering out a sequence of files. This way if the render fails you will not loose the ones you rendered already. You can try starting the render again from where it failed or even one frame after and see if it still does the same thing. In the end you can create a new AE project, import all frames as sequence of files and render out again. If you need a highly compressed version (to put on the web, DVD, or H264 playback) do not compress from AE. Render an uncompressed version (huge file) and use Adobe Media Encoder to compress.
You can also try to turn off one at a time any fx that you may have on your layers at the point where the render fails and see if you figure out which one is causing the failure.

Tudor "Ted" Jelescu
Senior VFX Artist

Return to posts index

Dave LaRondeRe: After Effects Rendering Problem!
by on Jan 12, 2012 at 4:00:04 pm

AE will use all the RAM available to it to do a RAM Preview. Since you have barely enough memory to run both the OS and AE at the same time, you won't be able to preview the entire comp at once.

You can preview in segments by setting a Work Area:

And since you run AE 9, I STRONGLY recommend transcoding all long-gop footage (H.264, any kind of MPEG, MP4, AVCHD, AVC Intra) to a lossless codec before importing it into AE. Since I'm a Mac guy, I like Quicktime's PNG codec for the task. I even do that on my Windows machine at home.

I also recommend that you learn how to use the AE Render Queue if you don't use it already:

It's also best in AE 9 to render a lossless movie, then use Adobe Media Encoder to do the compression for final delivery. If you're going to an editing application after AE, it may also be capable of doing good compression.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA

Return to posts index

Kevin CampRe: After Effects Rendering Problem!
by on Jan 12, 2012 at 4:37:58 pm

the thing you are running into with ram previews is that a ram preview caches all rendered frames in to ram. the less ram available, the fewer frames it can fit into ram fro playback.

in addition to dave's work area suggestion, you can also use the preview 'zoom' in the lower left corner of the preview window (currently set to 100%) to make the cached frames smaller, and thus consume less ram. a reduction to 50% will fit 4 times as many frames into ram.

you can also do a shift-ram preview, which by default will skip every other frame and thus consume half as much ram. combining those 2 options would give you 8 times the current cached duration. by default shift-preview also cuts the resolution to half (resolution is different from zoom). those settings can be changed in the preview palette.

as for the error message, i don't think that is an ae error. ae errors usually come with an error code. that looks more like a windows error message saying that ae is having an issue... my best guess as for what caused it is that ae and windows are fighting for ram, and windows is winning.

what are you current multiprocessing and memory settings in ae? i would definitely have multiprocessing off, and i would try leaving half your ram for other apps (other apps include the os) and i would suggest having no other apps running when ae is running.

Kevin Camp
Senior Designer

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved